Sangoma A101DE

alfil2k

Joined
Aug 17, 2009
Messages
25
Likes
0
Points
0
#1
Hi all,

we have a big problems with a sangoma A101DE. We are using elastix 1.6-14 with asterisk 1.4.28, wanpipe 3.5.7, dahdi 2.2.0.2-6.

Below, youi can see the error on the log and config files:

Code:
Mar 15 16:48:58 riogordo kernel: wanpipe1: RAI alarm is ON
Mar 15 16:48:58 riogordo kernel: wanpipe1: E1 disconnected!
Mar 15 16:48:59 riogordo kernel: wanpipe1: AFT communications disabled! (Dev Cnt: 1 Cause: Link Down)
Mar 15 16:48:59 riogordo kernel: wanpipe1: TDM Free Run Timing Enabled 1 ms
Mar 15 16:49:02 riogordo kernel: wanpipe1:    AIS : ON
Mar 15 16:49:04 riogordo kernel: wanpipe1:    RAI : OFF
Mar 15 16:49:08 riogordo kernel: wanpipe1: E1 connected!
Mar 15 16:49:08 riogordo kernel: wanpipe1: AFT communications enabled!
Mar 15 16:49:08 riogordo kernel: wanpipe1: AFT Global TDM Intr
Mar 15 16:49:08 riogordo kernel: ADDRCONF(NETDEV_CHANGE): w1g1: link becomes ready
Mar 15 16:49:08 riogordo kernel: wanpipe1: Global TDM Ring Resync TDM = 0x1
Mar 15 16:49:15 riogordo kernel: wanpipe1:    AIS : OFF
Mar 15 16:49:22 riogordo kernel: wanpipe1: RAI alarm is ON
Mar 15 16:49:22 riogordo kernel: wanpipe1: E1 disconnected!
Mar 15 16:49:23 riogordo kernel: wanpipe1: AFT communications disabled! (Dev Cnt: 1 Cause: Link Down)
Mar 15 16:49:23 riogordo kernel: wanpipe1: TDM Free Run Timing Enabled 1 ms
Mar 15 16:49:26 riogordo kernel: wanpipe1:    AIS : ON
Mar 15 16:49:28 riogordo kernel: wanpipe1:    RAI : OFF
Mar 15 16:49:32 riogordo kernel: wanpipe1: E1 connected!
Mar 15 16:49:32 riogordo kernel: wanpipe1: AFT communications enabled!
Mar 15 16:49:32 riogordo kernel: wanpipe1: AFT Global TDM Intr
Mar 15 16:49:32 riogordo kernel: ADDRCONF(NETDEV_CHANGE): w1g1: link becomes ready
Mar 15 16:49:32 riogordo kernel: wanpipe1: Global TDM Ring Resync TDM = 0x1
Mar 15 16:49:38 riogordo kernel: wanpipe1:    AIS : OFF
Mar 15 17:00:56 riogordo kernel: wanpipe1: RAI alarm is ON
Mar 15 17:00:56 riogordo kernel: wanpipe1: E1 disconnected!
Mar 15 17:00:56 riogordo kernel: wanpipe1: AFT communications disabled! (Dev Cnt: 1 Cause: Link Down)
Mar 15 17:00:56 riogordo kernel: wanpipe1: TDM Free Run Timing Enabled 1 ms
Mar 15 17:00:59 riogordo kernel: wanpipe1:    AIS : ON
Mar 15 17:00:59 riogordo kernel: wanpipe1:    LOF : ON
Mar 15 17:01:01 riogordo kernel: wanpipe1:    RAI : OFF
Mar 15 17:01:01 riogordo kernel: wanpipe1:    RED : ON
Mar 15 17:01:11 riogordo kernel: wanpipe1:    AIS : OFF
Mar 15 17:01:11 riogordo kernel: wanpipe1:    LOF : OFF
Mar 15 17:01:13 riogordo kernel: wanpipe1:    RED : OFF
Mar 15 17:01:17 riogordo kernel: wanpipe1: E1 connected!
Mar 15 17:01:17 riogordo kernel: wanpipe1: AFT communications enabled!
Mar 15 17:01:17 riogordo kernel: wanpipe1: AFT Global TDM Intr
Mar 15 17:01:17 riogordo kernel: ADDRCONF(NETDEV_CHANGE): w1g1: link becomes ready
Mar 15 17:01:17 riogordo kernel: wanpipe1: Global TDM Ring Resync TDM = 0x1
Mar 15 17:01:19 riogordo kernel: wanpipe1:    RAI : ON
Mar 15 17:01:20 riogordo kernel: wanpipe1: E1 disconnected!
Mar 15 17:01:20 riogordo kernel: wanpipe1: AFT communications disabled! (Dev Cnt: 1 Cause: Link Down)
Mar 15 17:01:20 riogordo kernel: wanpipe1: TDM Free Run Timing Enabled 1 ms
Mar 15 17:01:22 riogordo kernel: wanpipe1:    LOF : ON
Mar 15 17:01:25 riogordo kernel: wanpipe1:    RAI : OFF
Mar 15 17:01:25 riogordo kernel: wanpipe1:    RED : ON
Mar 15 17:01:35 riogordo kernel: wanpipe1:    LOF : OFF
Mar 15 17:01:37 riogordo kernel: wanpipe1:    RED : OFF
Mar 15 17:01:41 riogordo kernel: wanpipe1: E1 connected!
Mar 15 17:01:41 riogordo kernel: wanpipe1: AFT communications enabled!
Mar 15 17:01:41 riogordo kernel: wanpipe1: AFT Global TDM Intr
Mar 15 17:01:41 riogordo kernel: ADDRCONF(NETDEV_CHANGE): w1g1: link becomes ready
Mar 15 17:01:41 riogordo kernel: wanpipe1: Global TDM Ring Resync TDM = 0x1
Mar 15 18:20:55 riogordo kernel: wanpipe1: RAI alarm is ON
Mar 15 18:20:55 riogordo kernel: wanpipe1: E1 disconnected!
Mar 15 18:20:56 riogordo kernel: wanpipe1: AFT communications disabled! (Dev Cnt: 1 Cause: Link Down)
Mar 15 18:20:56 riogordo kernel: wanpipe1: TDM Free Run Timing Enabled 1 ms
Mar 15 18:20:59 riogordo kernel: wanpipe1:    AIS : ON
Mar 15 18:21:01 riogordo kernel: wanpipe1:    RAI : OFF
Mar 15 18:21:05 riogordo kernel: wanpipe1: E1 connected!
Mar 15 18:21:05 riogordo kernel: wanpipe1: AFT communications enabled!
Mar 15 18:21:05 riogordo kernel: wanpipe1: AFT Global TDM Intr
Mar 15 18:21:05 riogordo kernel: ADDRCONF(NETDEV_CHANGE): w1g1: link becomes ready
Mar 15 18:21:05 riogordo kernel: wanpipe1: Global TDM Ring Resync TDM = 0x1
Mar 15 18:21:12 riogordo kernel: wanpipe1:    AIS : OFF
Mar 15 18:21:19 riogordo kernel: wanpipe1: RAI alarm is ON
Mar 15 18:21:19 riogordo kernel: wanpipe1: E1 disconnected!
Mar 15 18:21:19 riogordo kernel: wanpipe1: AFT communications disabled! (Dev Cnt: 1 Cause: Link Down)
Mar 15 18:21:19 riogordo kernel: wanpipe1: TDM Free Run Timing Enabled 1 ms
Mar 15 18:21:24 riogordo kernel: wanpipe1:    RAI : OFF
Mar 15 18:21:28 riogordo kernel: wanpipe1: E1 connected!
Mar 15 18:21:28 riogordo kernel: wanpipe1: AFT communications enabled!
Mar 15 18:21:28 riogordo kernel: wanpipe1: AFT Global TDM Intr
Mar 15 18:21:28 riogordo kernel: ADDRCONF(NETDEV_CHANGE): w1g1: link becomes ready
Mar 15 18:21:28 riogordo kernel: wanpipe1: Global TDM Ring Resync TDM = 0x1

wanpipe1.conf

#================================================
# WANPIPE1 Configuration File
#================================================
#
# Date: Wed Dec  6 20:29:03 UTC 2006
#
# Note: This file was generated automatically
#       by /usr/local/sbin/setup-sangoma program.
#
#       If you want to edit this file, it is
#       recommended that you use wancfg program
#       to do so.
#================================================
# Sangoma Technologies Inc.
#================================================

[devices]
wanpipe1 = WAN_AFT_TE1, Comment

[interfaces]
w1g1 = wanpipe1, , TDM_VOICE, Comment

[wanpipe1]
CARD_TYPE       = AFT
S514CPU         = A
CommPort        = PRI
AUTO_PCISLOT    = NO
PCISLOT         = 4
PCIBUS          = 6
FE_MEDIA        = E1
FE_LCODE        = HDB3
FE_FRAME        = NCRC4
FE_LINE         = 1
TE_CLOCK        = NORMAL
TE_REF_CLOCK    = 0
TE_SIG_MODE     = CAS
TE_HIGHIMPEDANCE        = NO
TE_RX_SLEVEL    = 430
LBO             = 120OH
FE_TXTRISTATE   = NO
MTU             = 1500
UDPPORT         = 9000
TTL             = 255
IGNORE_FRONT_END = NO
TDMV_SPAN       = 1
TDMV_DCHAN      = 16
TDMV_HW_DTMF    = YES
TDMV_HW_FAX_DETECT = NO

[w1g1]
ACTIVE_CH       = ALL
TDMV_HWEC       = YES
MTU             = 8


system.conf

#autogenerated by /usr/sbin/wancfg_dahdi do not hand edit
#autogenrated on 2010-03-11
#Dahdi Channels Configurations
#For detailed Dahdi options, view /etc/dahdi/system.conf.bak
loadzone=es
defaultzone=es

#Sangoma A101 port 1 [slot:4 bus:6 span:1] <wanpipe1>
span=1,1,0,ccs,hdb3
bchan=1-15,17-31
hardhdlc=16


chan-dahdi.conf:

;autogenerated by /usr/sbin/wancfg_dahdi do not hand edit
;autogenrated on 2009-12-02
;Dahdi Channels Configurations
;For detailed Dahdi options, view /etc/asterisk/chan_dahdi.conf.bak

[trunkgroups]

[channels]
context=default
usecallerid=yes
hidecallerid=no
callwaiting=yes
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=yes
transfer=yes
canpark=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=yes
relaxdtmf=yes
rxgain=0
txgain=0
group=1
callgroup=1
pickupgroup=1
immediate=no

;Sangoma A101 port 1 [slot:4 bus:10 span:1] <wanpipe1>
switchtype=euroisdn
context=from-pstn
group=0
echocancel=yes
signalling=pri_cpe
channel =>1-15,17-31
We are desperate, we think that the problem was on the provider, but they said that your line is OK. Somebody have any idea?

Thanks,
Pablo
 

marc.sangoma

Joined
Jul 20, 2009
Messages
14
Likes
0
Points
0
#2
Hi,

This is a bad repeater on the line. Because you have a AIS which is an "alarm indication signal" and this means one of the repeaters is down or in a blue alarm. Then sometimes the line goes down because of an RAI alarm which is "remote alarm indication" which means the telco switch is in alarm. So this is probably just a repeater because you are going down because of the AIS and then when you get the RAI its because the telco switch goes down first (probably as well because of the repeater) and sends an alarm out to our card.

So just get in touch with the telco and they will help you out with this one.
 

alfil2k

Joined
Aug 17, 2009
Messages
25
Likes
0
Points
0
#3
Thanks for your answer Marc,


What means bad repeater? We are talking with the provider about the problem but still with out responce.

How can i confirm that the problem is not the card?

Regards,
Pablo
 

marc.sangoma

Joined
Jul 20, 2009
Messages
14
Likes
0
Points
0
#4
Hi,

You can leave it in loopback mode (insure clock is set to MASTER) but this is not recommended because you are getting a AIS alarm. So this means the repeater (device along the line to boost signal) is having issues and the telco needs to look into this.
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,887
Members
17,566
Latest member
Fpino
Top