safe_asterisk PROBLEM

jasong

Joined
Aug 20, 2009
Messages
34
Likes
0
Points
0
#1
I keep getting this message over and over again in my CLI.

Aug 21 08:40:01 VERBOSE [4838] logger.c: -- Remote UNIX connection
Aug 21 08:40:02 VERBOSE [6076] logger.c: -- Remote UNIX connection disconnected
Aug 21 08:45:01 VERBOSE [4838] logger.c: -- Remote UNIX connection
Aug 21 08:45:02 VERBOSE [6112] logger.c: -- Remote UNIX connection disconnected


From my investigations online, people are saying it caused by safe_asterisk.

Wouldn't be such a big deal, except it keeps causing the registration of my phones to fall off.

From reading online, I am learning that safe_asterisk is meant to check and see if asterisk is running and restart it if it is not. But it is real buggy. Is there a way to turn this feature off, or fix this issue?
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#2
FWIW:

That is standard, we all see them, it just notes (is "caused by" ) a connection on 5038 to the "Asterisk Manager Interface" (AMI) lots of things do that, safe_asterisk FOP, a2billing etc., and any concept that it is buggy is likely to have been otherwise noted over the past 5 or 6 years, it is just a shell script at /usr/sbin/safe_asterisk , Feel free to edit it to suit. (I do, and IMHO opinion everyone should but nobody does!! )

if it bothers you, set verbosity to something less than 3 (the default)

However, I believe I can assure you that this is not the cause of your de-registration problem. I suggest you investigate elsewhere.

Perhaps you can post a snip of your /var/log/asterisk/full log file that shows the problem?
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,886
Members
17,563
Latest member
dineshr
Top