Ringing another line while on the phone

Discussion in 'General' started by MUD, Jan 13, 2009.

  1. MUD

    MUD

    Joined:
    Sep 12, 2007
    Messages:
    15
    Likes Received:
    0
    Ever since I've set up Elastix, from a move from default CentOS install with freePBX and Trixbox I dont have the use of my other lines for incoming calls when I'm on the phone.

    I have the current Elastix using Linksys SPA-941.

    Anyone know how to resolve this?
     
  2. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Check that "call waiting" is enabled for the extension (you can change the default behavior in amportal.conf)
     
  3. wiseoldowl

    Joined:
    Aug 19, 2008
    Messages:
    251
    Likes Received:
    0
    Set up a Follow-Me for the extension... let's say it's extension 200, and if it is busy you want calls to go to 201 or 201. In the follow-me list, you simply put these extensions in order, e.g.

    200
    201
    202

    Set the Ring Strategy to firstnotonphone and set the Destination if no answer to Voicemail <200> (or whatever you want). Set Initial Ring Time to 0 (zero) and Ring Time to whatever you like (the length of time before calls go to voicemail, or whatever no-answer destination you select).

    Now for extension 201 you'd do the same thing, except put it first in the follow-me list, e.g.:

    201
    202
    200

    And for extension 202:

    202
    200
    201

    So in every case, calls to an extension go to that extension first, then if it is busy they to the next one in the group, and so on. You can have separate voicemail boxes for each extension, or set the destination if no answer to use one primary mailbox for all extensions - that's up to you.

    Note: For this to work, Call Waiting needs to be DISABLED for all extensions in the group (both in Asterisk and possibly also at the VoIP adapter or phone).
     

Share This Page