Ringall only works with SIP extensions, not Dahdi.

Discussion in 'General' started by CoolHand, Sep 28, 2009.

  1. CoolHand

    Joined:
    Sep 17, 2009
    Messages:
    5
    Likes Received:
    0
    Is the ringall feature supposed to work when dialing a sip number and another line using a Dahdi channel?

    I have had the ability use a ring-group or follow-me to have calls ring on my office phone and mobile, and it works fine as both phones ring until the timeout and music is heard on the calling parties end. I've always used a VOIP provider for the outbound call to my mobile so I never had the following problem.

    I've just set up a system for a client and was noticing that both ring-groups and follow-me would ring the internal sip extension once or twice, but then would stop a moment before the mobile phone started ringing. The outbound calls are going over a Dahdi channel. I checked this out back at my office and noticed the same thing once I switched the outbound route to a Dahdi channel.

    Two more things:
    1) Once the internal extension stops ringing, the music on the calling parties end stops and you hear the mobile dialing.
    2) When the call gets sent to the mobile, it never goes to the "destination if no answer" so if the mobile is not answered, the call will just go dead (asterisk won't send it to voice mail). It's like the system just hands it off to Dahdi and forgets about it. Using a VOIP provider to ring a mobile or other outside non-sip line, everything works.

    Is this expected behavior? Any way around this?
     
  2. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    You might try enabling "confirm calls" in the follow me settings. (look at the "hover over" info for more info)
     
  3. CoolHand

    Joined:
    Sep 17, 2009
    Messages:
    5
    Likes Received:
    0
    Thanks dicko! I've seen that there a million times but never needed to use it before, so it completely slipped my mind when it came time to use it.

    It works, but currently it continues to ring on the outside line several times after the caller has hung up, and it plays a message saying the call has ended or been answered by someone else. The internal office line simply stops ringing. Is there a way to configure this where it simply disconnects the outgoing line instead of playing that message?

    Thanks again,
    CH

    Edit: I see this is set in the "Too-Late Announce" option, but that only has options for Default and other recordings, no option to enable or disable it that I can see. Is the only option to record a short 1 second blank message and use that to have the call quickly disconnected?
     

Share This Page