Rhino R8FXX-e-EC not recognized in elastix 1.5.2+

Discussion in 'General' started by ronaldlw, May 8, 2009.

  1. ronaldlw

    Joined:
    May 7, 2009
    Messages:
    81
    Likes Received:
    0
    Hello all,

    First, elastix rocks!

    Next I wanted to share my fun (not) experience trying to put a R8FXX-e-EC card with a FXO and FXS module in our new elastix server.

    After struggling, googling, searching the forums here and generally not finding anything helpful for this issue I gave up and called Rhino tech support. They were extremely helpful and got me going pretty quick.

    There were two problems, first the module for rhino cards was removed somewhere between version 1.5.2 and 1.5.2-2.3. The second was a perl script bug that the tech said he submitted a bug report "a long time ago" and that it is fixed in newer versions of the script, but elastix is still using an old version apparently.

    To fix the first issue you have to add rcbfx to the /etc/dahdi/modules file.

    To fix the second issue you have to edit:

    /usr/lib/perl5/site_perl/5.8.8/Dahdi/Chans.pm

    and change line 143:
    } elsif ($fqn =~ m{\b---/.*}) {
    to read:
    } elsif ($fqn =~ m{---/.*}) {

    Then you have to run:

    dahdi_genconf
    dahdi_cfg

    and restart asterisk

    amportal restart

    After this the card and modules should be found and initialized correctly.

    Anyone have any idea why the rhino card module would be removed in newer versions of elastix? Also can someone please make sure these fixes get into the next release so that I don't have to re-check this every time I update???

    Thanks!!

    Ron
     
  2. ronaldlw

    Joined:
    May 7, 2009
    Messages:
    81
    Likes Received:
    0
    I just wanted to update this to say that I submitted a bug report and the issues are being addressed (there is already a new dahdi package with a fix to the script). here is a link (i think this will work) to the bug:
    http://bugs.elastix.org/view.php?id=92

    Thanks,
    Ron
     
  3. rafael

    Joined:
    May 14, 2007
    Messages:
    1,454
    Likes Received:
    1
    Hi ronaldlw, thanks to your bug report now the issue is solve :). It is very important to post the bugs in http://bugs.elastix.org

    Regards,

    Rafael
     

Share This Page