retrieve_conf failed, config not applied...

johnalam

Joined
Jul 11, 2009
Messages
2
Likes
0
Points
0
#1
Dear all,

I having problem applying configuration on elastix 1.6.2-27.

My machine spec is
GenuineIntel Intel(R) Core(TM)2 Quad CPU Q8400 @ 2.66GHz 4GB RAM

The problem starts when I add a new outbound route with multiple dial patterns on the Elastix pbx configuration. When I submit and apply configurations, the apply configuration tab hang.

Then I decided to take a look over Freepbx and found this error below.


retrieve_conf failed, config not applied
Ignore this
Reload failed because retrieve_conf encountered an error: 255
Added 55 minutes ago
(freepbx.RCONFFAIL) :dry:

On the freepbx reload message, I see this

exit: 255

Checking for PEAR DB..OK
Checking for PEAR Console::Getopt..OK
Checking for /etc/amportal.conf ..OK
Bootstrapping /etc/amportal.conf ..OK
Parsing /etc/amportal.conf ..OK
Parsing /etc/asterisk/asterisk.conf ..OK
Connecting to database..OK
Connecting to Asterisk manager interface..OK
Added to globals: ASTETCDIR = /etc/asterisk
Added to globals: ASTMODDIR = /usr/lib64/asterisk/modules
Added to globals: ASTVARLIBDIR = /var/lib/asterisk
Added to globals: ASTAGIDIR = /var/lib/asterisk/agi-bin
Added to globals: ASTSPOOLDIR = /var/spool/asterisk
Added to globals: ASTRUNDIR = /var/run/asterisk
Added to globals: ASTLOGDIR = /var/log/asterisk
Added to globals: CWINUSEBUSY = true
Added to globals: AMPMGRUSER = admin
Added to globals: AMPMGRPASS = elastix456
PHP Warning: array_keys(): The first argument should be an array in /var/www/html/admin/extensions.class.php on line 292
PHP Warning: Invalid argument supplied for foreach() in /var/www/html/admin/extensions.class.php on line 292
PHP Warning: array_keys(): The first argument should be an array in /var/www/html/admin/extensions.class.php on line 292
PHP Warning: Invalid argument supplied for foreach() in /var/www/html/admin/extensions.class.php on line 292
PHP Warning: array_keys(): The first argument should be an array in /var/www/html/admin/extensions.class.php on line 292
PHP Warning: Invalid argument supplied for foreach() in /var/www/html/admin/extensions.class.php on line 292
PHP Warning: array_keys(): The first argument should be an array in /var/www/html/admin/extensions.class.php on line 292
PHP Warning: Invalid argument supplied for foreach() in /var/www/html/admin/extensions.class.php on line 292
PHP Warning: array_keys(): The first argument should be an array in /var/www/html/admin/extensions.class.php on line 292
PHP Warning: Invalid argument supplied for foreach() in /var/www/html/admin/extensions.class.php on line 292
PHP Warning: array_keys(): The first argument should be an array in /var/www/html/admin/extensions.class.php on line 292
PHP Warning: Invalid argument supplied for foreach() in /var/www/html/admin/extensions.class.php on line 292
PHP Warning: array_keys(): The first argument should be an array in /var/www/html/admin/extensions.class.php on line 292
PHP Warning: Invalid argument supplied for foreach() in /var/www/html/admin/extensions.class.php on line 292
PHP Warning: array_keys(): The first argument should be an array in /var/www/html/admin/extensions.class.php on line 292
PHP Warning: Invalid argument supplied for foreach() in /var/www/html/admin/extensions.class.php on line 292
PHP Warning: array_keys(): The first argument should be an array in /var/www/html/admin/extensions.class.php on line 292
PHP Warning: Invalid argument supplied for foreach() in /var/www/html/admin/extensions.class.php on line 292
PHP Warning: array_keys(): The first argument should be an array in /var/www/html/admin/extensions.class.php on line 292
PHP Warning: Invalid argument supplied for foreach() in /var/www/html/admin/extensions.class.php on line 292
PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 38 bytes) in /var/www/html/admin/extensions.class.php on line 303


What is this mean ? Clearly there is a PHP code execution problem.

I need to know how I can resolve this.

Thanks

John
 

fmvillares

Joined
Sep 8, 2007
Messages
1,785
Likes
0
Points
0
#2
with so littel info its really difficult do you have upgraded something before the fault? do you have rebooted the sysetm? disck space free?? its on open internet etc etc asterisk is running?
 

johnalam

Joined
Jul 11, 2009
Messages
2
Likes
0
Points
0
#3
I setup the outbound route, input multiple dial patterns and submit it. However I cannot apply configuration.

I had to delete the route and apply configuration, then it work.

Now somehow, I believe the problem setting up of the multiple dial patterns


John
 

fmvillares

Joined
Sep 8, 2007
Messages
1,785
Likes
0
Points
0
#4
Re: Re:retrieve_conf failed, config not applied...

dont konow at all as we dont have any information of asterisk cli from you or versions of freepbx or if you aer using embedded freepbx o r unembedded, fully upgraded system etc
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,898
Messages
130,879
Members
17,560
Latest member
manuelc
Top