retrieve_conf failed, config not applied AGAIN

agidi

Joined
Jan 13, 2008
Messages
152
Likes
0
Points
0
#1
I had a fresh installed that worked for about a week. Then I had agi-bin issues

With no way to fix, it I backed up, re intalled from scratch. Backed up the fresh install, and restored with mine.

Unfortunatelly, it restores with the errors. So, I re restore with the fresh backup and got a clean system

With almost everything running, I was enabling an DID incoming, and got this error again!.

retrieve_conf failed, config not applied
Reload failed because retrieve_conf encountered an error: 1
Added ago
(freepbx.RCONFFAIL)

Is it a version bug? It keeps happening. Im worried because Im setting a 90 ext system next week on this version :S

please advice.
thanks! :)
 

agidi

Joined
Jan 13, 2008
Messages
152
Likes
0
Points
0
#2
this also shows up

exit: 1

Checking for PEAR DB..OK
Checking for PEAR Console::Getopt..OK
Checking for /etc/amportal.conf ..OK
Bootstrapping /etc/amportal.conf ..OK
Parsing /etc/amportal.conf ..OK
Parsing /etc/asterisk/asterisk.conf ..OK
Connecting to database..OK
Connecting to Asterisk manager interface..OK
Added to globals: ASTETCDIR = /etc/asterisk
Added to globals: ASTMODDIR = /usr/lib/asterisk/modules
Added to globals: ASTVARLIBDIR = /var/lib/asterisk
Added to globals: ASTAGIDIR = /var/lib/asterisk/agi-bin
Added to globals: ASTSPOOLDIR = /var/spool/asterisk
Added to globals: ASTRUNDIR = /var/run/asterisk
Added to globals: ASTLOGDIR = /var/log/asterisk
Added to globals: CWINUSEBUSY = true
Added to globals: AMPMGRUSER = admin
Added to globals: AMPMGRPASS = elastix456
[FATAL] Cannot write Queues configurations Failed creating/overwriting Queues extensions file: /etc/asterisk
/queues_additional.conf

1 error(s) occured, you should view the notification log on the dashboard or main screen to check for more details.
 

ramoncio

Joined
May 12, 2010
Messages
1,663
Likes
0
Points
0
#3
Try with:

touch /etc/asterisk/queues_additional.conf
chown -R asterisk:asterisk /etc/asterisk/
amportal restart
 

agidi

Joined
Jan 13, 2008
Messages
152
Likes
0
Points
0
#4
Distinguido Ramoncio

I tried as suggested. It went fine, but still get

Failed to copy from module agi-bin
Ignore this
Retrieve conf failed to copy file(s) from a module's agi-bin dir: copy(/var/lib/asterisk/agi-bin
/enumlookup.agi): failed to open stream: No such file or directory
copy(/var/lib/asterisk/agi-bin
/checksound.agi): failed to open stream: No such file or directory
copy(/var/lib/asterisk/agi-bin
/directory): failed to open stream: No such file or directory
copy(/var/lib/asterisk/agi-bin
/fixlocalprefix): failed to open stream: No such file or directory
copy(/var/lib/asterisk/agi-bin
/list-item-remove.php): failed to open stream: No such file or directory
copy(/var/lib/asterisk/agi-bin
/dialparties.agi): failed to open stream: No such file or directory
copy(/var/lib/asterisk/agi-bin
/recordingcheck): failed to open stream: No such file or directory
copy(/var/lib/asterisk/agi-bin
/user_login_out.agi): failed to open stream: No such file or directory

Added ago
(retrieve_conf.CPAGIBIN)

I posted on FREEPBX.org, as I thouhgt it was a FREEPBX issue, but they pointed back at elastix.
See
http://www.freepbx.org/forum/freepbx/us ... es-upgrade

Any other ideas?
thanks
 

Gwayne

Joined
Jul 31, 2008
Messages
19
Likes
0
Points
0
#5
I had that before... It could not read the agi files. They where still owned by root.
 

ramoncio

Joined
May 12, 2010
Messages
1,663
Likes
0
Points
0
#6
Maybe you can solve it with:
chown -R asterisk:asterisk /var/lib/asterisk

As Gwayne says it is again a permissions problem.
Maybe your problem is that you are modifying files logged in as root using ssh or winscp.
You must remember to check permissions after modifying files as root, though I can't imagine why would you modify /var/lib/asterisk/agi-bin
/enumlookup.agi. Maybe you have run asterisk as root??
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,915
Messages
130,920
Members
17,595
Latest member
feparra121
Top