[RESOLU] Plus de son - Call Forward

apcloic

Joined
May 6, 2009
Messages
90
Likes
0
Points
0
#1
Bonjour à tous,

On vient de me signaler un problème avec les transferts d'appels permanents via le code fonction *72 (Call Forward All Activate) vers des numéros externes (en 01,02,03,04,05,06 ou autre).

Le transfert d'appel se fait bien, ça sonne et on peut décrocher mais pas d'audio, rien ne passe, ni dans un sens, ni dans l'autre.

J'ai d'abord pensé à un problème de firewall, donc j'ai fait des tests en ouvrant tout et c'est idem, pas de son.

Du coup, je fais un test avec un blind transfer (In-Call Asterisk Blind Transfer, code fonction ## sur ma config.) et là, pas de problème je peux transférer l'appel sur mon portable.

En résumé :
- appel depuis numero externe --> extension elastix --> Call forward via *72 --> autre numéro externe /// transfert ok mais pas de son

- appel depuis numero externe --> extension elastix --> Call forward via *72 --> autre extension elastix /// ok, tout fonctionne

- appel depuis numero externe --> extension elastix --> Blind transfer via ## --> autre numéro externe /// ok, tout fonctionne

Une idée pour me sauver ? je sais pas trop où regarder du coup...:huh:

Merci d'avance, byye
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#2
Re:plus de son - fonction Call Forward All Activate

Visiblement un problème de RTP semblerait-il!
Regardes les flux RTP et SIP:
CLI> rtp debug
CLI> sip debug

Fais attention au canreinvite!
 

apcloic

Joined
May 6, 2009
Messages
90
Likes
0
Points
0
#3
Re:plus de son - fonction Call Forward All Activate

danardf said:
Fais attention au canreinvite!
Slt,

Tu peux préciser ce point, jusqu'à présent j'ai toujours mis partout "canreinvite=no"
Je vais chercher à quoi ça correspond.

Sinon, ce qui m'intrigue quand même c'est pourquoi ça fonctionne en blind transfer, s'il y a un probleme avec les flux RTP, ni le blind transfer ni le Call forward ne devrait fonctionner, non ?

Merci bcp pour ton aide. ;)
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#4
Re:plus de son - fonction Call Forward All Activate

Le canreinvite = rtp direct.

Si tu passes une comme entre 2 extensions, la comme passera de A vers Asterisk puis d'asterisk vers B

En direct rtp, ta comm passe de A vers B!

Donc il y a des fois ou il ne vaut mieux pas s'en servir et d'autre oui.
 

apcloic

Joined
May 6, 2009
Messages
90
Likes
0
Points
0
#5
Re:plus de son - fonction Call Forward All Activate

danardf said:
Le canreinvite = rtp direct.

Si tu passes une comme entre 2 extensions, la comme passera de A vers Asterisk puis d'asterisk vers B

En direct rtp, ta comm passe de A vers B!

Donc il y a des fois ou il ne vaut mieux pas s'en servir et d'autre oui.
Yep,

Merci bcp pour les explications. ;)

J'ai activé le rtp debug, je vois bien des tas de sent RTP, Got RTP donc il me semble que les packets partent et arrivent bien...
Cela dit, j'ai des utilisateurs qui doivent également passer des comm. en ce moment donc je sais pas si c'est significatif.
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#6
Re:plus de son - fonction Call Forward All Activate

Evidemment, il veux mieux faire les essais au calme.
Sinon, tu peux déjà vérifier si la comm utilise les bon codec!
CLI>sip show channels

Tu verras toutes les comm dont les codecs utilisés.
il peut y avoir un problème dans ce sens....
 

apcloic

Joined
May 6, 2009
Messages
90
Likes
0
Points
0
#7
Re:plus de son - fonction Call Forward All Activate

Ok, je vois bien ma comm avec comme user/ANR le numéro externe vers lequel mon appel est transféré et le codec utilisé (alaw qui est bien également dans les codecs autorisés sur mon trunk).
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#8
Re:plus de son - fonction Call Forward All Activate

Faire donc attention que toute la chaine autorise bien le G711a.
Dans ce cas, il ne devrait pas y avoir de problème.

Est-ce que le serveur est bien configuré a niveau du NAT?
(voir fichier sip_nat.conf)
 

apcloic

Joined
May 6, 2009
Messages
90
Likes
0
Points
0
#9
Re:plus de son - fonction Call Forward All Activate

danardf said:
Faire donc attention que toute la chaine autorise bien le G711a.
Dans ce cas, il ne devrait pas y avoir de problème.
Je vais vérifier.

Est-ce que le serveur est bien configuré a niveau du NAT?
(voir fichier sip_nat.conf)
Il est vierge...
Il faut que je déclare ma passerelle, IP publique, etc ?

Merci pour ton aide. :)
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#10
Re:plus de son - fonction Call Forward All Activate

Ben oui.
A en croire ton histoire, tu dois avoir un opérateur ToIP.

Donc il faut renseigné ton IP public statique ou dynamique.

externip=ip_publique
ou externhost=ton_domaine
localnet=192.168.1.0/255.255.255.0

Mettre nat=yes dans le trunk au moins et tout ce qui extra-domaine ou réseau.
 

apcloic

Joined
May 6, 2009
Messages
90
Likes
0
Points
0
#11
Re:plus de son - fonction Call Forward All Activate

danardf said:
Ben oui.
Donc il faut renseigné ton IP public statique ou dynamique.

externip=ip_publique
ou externhost=ton_domaine
localnet=192.168.1.0/255.255.255.0

Mettre nat=yes dans le trunk au moins et tout ce qui extra-domaine ou réseau.
Ok, c'est fait, serveur rebooté au cas où... mais pas d'amélioration.
Ce qui me chiffonne vraiment c'est que si c'était un problème réseau (nat ou firewall), le blind transfer ne fonctionnerait pas non plus puisque c'est la même chose mais en live au lieu d'un transfert programmé, non ?

Est-ce que le call forward et le blind transfer font appel à des circuits/macro différents ?
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#12
Re:plus de son - fonction Call Forward All Activate

Bon.

Ce qu'il faudrait identifier, c'est comment la comm passe t-elle.
As-tu mappé les ports SIP et RTP sur ton routeur vers ton serveur Elastix
Petit rappel.... les ports sont sur la couche UDP et non TCP!
 

apcloic

Joined
May 6, 2009
Messages
90
Likes
0
Points
0
#13
Re:plus de son - fonction Call Forward All Activate

Oui, j'ai bien ouvert les ports UDP sur mon interface WAN et je les ai natté vers mon IPBX, donc j'ai tendance à pense que ce n'est pas là que se situe le problème.
Si c'était mal paramétré rien ne passerait non ? Je veux dire que mes comm. en direct passent bien, les blind transfer fonctionnent, donc normalement le reste aussi non ?

D'un autre côté, le call forward fonctionne très bien vers une extension interne, du coup je me dis qu'elastix fait bien son boulot et que si ça ne sort pas c'est un problème de réseau...

Il faudrait que je trouve un outil pour suivre les paquets à la trace et voir si ça coince quelque part.

Merci bcp pour ton aide. ;)
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#14
Re:plus de son - fonction Call Forward All Activate

Un seul outil... WireShark

Sniffer gratuit. par contre, à utiliser avec un hub ou switch manageable pour mettre le port en "hub"
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#15
Re:plus de son - fonction Call Forward All Activate

Il faudrait déjà que tu puisses faire l'essai sur une heure creuse (entre 12 et 13h) pour pouvoir tracer le RTP et la comm.
Faire une comparaison avec une comm qui fonctionne et une qui ne fonctionne pas.

Il est possbile après qu'il y est un bug.
Je vais essayer de faire un essai de mon côté. (pas évident).
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#16
Re:plus de son - fonction Call Forward All Activate

Intéressent!
J'ai la même chose. :laugh:
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#17
Re:plus de son - fonction Call Forward All Activate

Hmmm, il semblerait qu'il y ait un problème de codec!
Lors de la comm, il y a des channels avec nothing! ça pourrait venir de là.
Soit c'est un bug, soit c'est un problème de paramétrage.

Le premier qui trouve....
 

apcloic

Joined
May 6, 2009
Messages
90
Likes
0
Points
0
#18
Re:plus de son - fonction Call Forward All Activate

danardf said:
Intéressent!
J'ai la même chose. :laugh:
Ah ben ça me rassure de pas être le seul ! ;)

Bon, j'ai aussi des channels avec "nothing".

Le truc c'est que d'après un de mes utilisateurs, ça fonctionnait avant.
Donc ça doit être en rapport avec les modif. que j'ai fait depuis.
Ce que j'ai changé :
- dtmfmode --> dtmfmode en inband au lieu de rfc2833 qui passe pas chez OVH pour résoudre le problème avec les serveurs vocaux distants, mais normalement ça ne devrait pas avoir d'incidence
- il me semble que j'ai modifié également Asterisk Dial command options / Asterisk Outbound Dial command options dans les paramètres généraux (j'ai d'ailleurs mis des valeurs que tu m'as recommandé dans un autre post) quand je cherchais pourquoi je ne pouvais pas transférer mes appels vers l'extérieur (au final il s'est avéré que je devais cocher la case "never override CallerID" sur le trunk).

Sinon, quand je regarde via sip show channels, au niveau des channels correspondant à l'appel transféré, il y a dans last message Tx: ACK et Rx: ACK alors que sur les autres channels il y a Rx: Register, tu sais ce que ça veut dire ?

Merci encore. :)
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#19
Re:plus de son - fonction Call Forward All Activate

Pour mes essais, je rentre par OVH et sort sur un SPA3102 -> freebox : Pareil
Et OVH vers VoipDiscount : Même chose

Faut qu'on creuse.
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#20
Re:plus de son - fonction Call Forward All Activate

Sur ce lien, il y a un loup visiblement
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,886
Members
17,563
Latest member
dineshr
Top