Registrar Telefono Cisco 7841 en Asterisk (problema)

Joined
Dec 5, 2017
Messages
5
Points
1
Buenos dias, saludos a todos.

Tengo unos telefonos Cisco 7841 y no los he podido registrar en Asterisk.


Ya he descargado el Firmware necesario y lo monté en el Servidor de Elastix en la carpeta tftpboot, tambien he configurado lo necesario en el telefono para que se actualice y he configurado los archivos necesarios para que funcione, sin embargo al reiniciar el telefono se queda eternamente la leyenda "Registering..." y de ahi no pasa.

He visto que aparentemente este modelo de telefono no es compatible con asterisk y quisiera saber si hay alguna forma o truco para poder registrarlo correctamente o si de plano no se puede, pero con bases sustentables.

Les agradezco el tiempo que tomen en leer el problema, muchas gracias.
 
Joined
Dec 5, 2017
Messages
5
Points
1
Gracias por responder.... el estandar de telefonos en la compañia son los Cisco SPA504g, estos sin problema se autoregistran.

La configuracion manual en el telefono 7841 ya se realizó, pero nunca se registra en el PBX, he revisado los logs del telefono y no encuentro ningun error
 
Joined
Nov 27, 2014
Messages
84
Points
8
Buenas tardes..
Ha probado este scenario?
Colocar una pc y habilitar un TFTP server, y hacer que el telefono en el proceso de provision, se vea o lo realice en esa pc...
si es el caso que si aparece la configuracion de provision en el telefono, el problema podria ser la configuracion del TFTP server en linux.

Si conecta, pero el proceso de provision no funciona cuando conecta al server, ya reviso ? / var / log / syslog a ver que registra? podria solo ser, el largo de la contraseña, la complejidad de la misma, o algun valor que se ha omitido... o la version del firmware que soporte la configuracion SIP.

Es lo que haria, aunque no se si ya ha probado estas ideas ...
 
Joined
Dec 5, 2017
Messages
5
Points
1
gracias, he montado el Tftp server en Windows y he puesto todos los archivos de configuracion en ese directorio, sin embargo tengo este mensaje en el telefono:

SEP005F8690F2E8.CNF.XML (TFTP)
"Error Verifying Config Info"

Ya he revisado ese archivo (SEP005F8690F2E8.CNF.XML) y no encuentro el error. (Anexo el archivo en el Spoiler, por favor podrias echar un vistazo?)

Muchas gracias!!



<?xml version="1.0"?>

-<device>

<deviceProtocol>SIP</deviceProtocol>

<sshUserId>root</sshUserId>

<sshPassword>Intermex</sshPassword>


-<devicePool>


-<dateTimeSetting>

<dateTemplate>M/D/Ya</dateTemplate>

<timeZone>Eastern Standard/Daylight Time</timeZone>


-<ntps>


-<ntp>

<name>10.3.0.8</name>

<ntpMode>Unicast</ntpMode>

</ntp>

</ntps>

</dateTimeSetting>


-<callManagerGroup>


-<members>


-<member priority="0">


-<callManager>


-<ports>

<ethernetPhonePort>2000</ethernetPhonePort>

<sipPort>5060</sipPort>

<securedSipPort>5061</securedSipPort>

</ports>

<processNodeName>10.3.0.8</processNodeName>

</callManager>

</member>

</members>

</callManagerGroup>

</devicePool>


-<commonProfile>

<phonePassword/>

<backgroundImageAccess>true</backgroundImageAccess>

<callLogBlfEnabled>2</callLogBlfEnabled>

</commonProfile>

<loadInformation>sip78xx.10-3-1-12</loadInformation>


-<vendorConfig>

<disableSpeaker>false</disableSpeaker>

<disableSpeakerAndHeadset>false</disableSpeakerAndHeadset>

<pcPort>0</pcPort>

<settingsAccess>1</settingsAccess>

<garp>0</garp>

<voiceVlanAccess>0</voiceVlanAccess>

<videoCapability>0</videoCapability>

<autoSelectLineEnable>0</autoSelectLineEnable>

<webAccess>1</webAccess>

<spanToPCPort>1</spanToPCPort>

<loggingDisplay>1</loggingDisplay>

<loadServer/>

</vendorConfig>

<networkLocale>United_States</networkLocale>


-<networkLocaleInfo>

<name>United_States</name>

<uid>64</uid>

<version>1.0.0.0-1</version>

</networkLocaleInfo>

<deviceSecurityMode>1</deviceSecurityMode>

<authenticationURL>http://#SERVER#/cisco/services/authentication.php</authenticationURL>

<directoryURL>http://#SERVER#/xmlservices/PhoneDirectory.php</directoryURL>

<idleURL>http://#SERVER#/xmlservices/index.php</idleURL>

<informationURL/>

<messagesURL/>

<proxyServerURL/>

<servicesURL>http://#SERVER#/xmlservices/index.php</servicesURL>

<dscpForSCCPPhoneConfig>96</dscpForSCCPPhoneConfig>

<dscpForSCCPPhoneServices>0</dscpForSCCPPhoneServices>

<dscpForCm2Dvce>96</dscpForCm2Dvce>

<transportLayerProtocol>4</transportLayerProtocol>

<capfAuthMode>0</capfAuthMode>


-<capfList>


-<capf>

<phonePort>3804</phonePort>

</capf>

</capfList>

<certHash/>

<encrConfig>false</encrConfig>


-<sipProfile>


-<sipProxies>

<backupProxy/>

<backupProxyPort/>

<emergencyProxy/>

<emergencyProxyPort/>

<outboundProxy/>

<outboundProxyPort/>

<registerWithProxy>true</registerWithProxy>

</sipProxies>


-<sipCallFeatures>

<cnfJoinEnabled>true</cnfJoinEnabled>

<callForwardURI>x--serviceuri-cfwdall</callForwardURI>

<callPickupURI>x-cisco-serviceuri-pickup</callPickupURI>

<callPickupListURI>x-cisco-serviceuri-opickup</callPickupListURI>

<callPickupGroupURI>x-cisco-serviceuri-gpickup</callPickupGroupURI>

<meetMeServiceURI>x-cisco-serviceuri-meetme</meetMeServiceURI>

<abbreviatedDialURI>x-cisco-serviceuri-abbrdial</abbreviatedDialURI>

<rfc2543Hold>false</rfc2543Hold>

<callHoldRingback>2</callHoldRingback>

<localCfwdEnable>true</localCfwdEnable>

<semiAttendedTransfer>true</semiAttendedTransfer>

<anonymousCallBlock>2</anonymousCallBlock>

<callerIdBlocking>2</callerIdBlocking>

<dndControl>0</dndControl>

<remoteCcEnable>true</remoteCcEnable>

</sipCallFeatures>


-<sipStack>

<sipInviteRetx>6</sipInviteRetx>

<sipRetx>10</sipRetx>

<timerInviteExpires>180</timerInviteExpires>

<timerRegisterExpires>3600</timerRegisterExpires>

<timerRegisterDelta>5</timerRegisterDelta>

<timerKeepAliveExpires>120</timerKeepAliveExpires>

<timerSubscribeExpires>120</timerSubscribeExpires>

<timerSubscribeDelta>5</timerSubscribeDelta>

<timerT1>500</timerT1>

<timerT2>4000</timerT2>

<maxRedirects>70</maxRedirects>

<remotePartyID>false</remotePartyID>

<userInfo>None</userInfo>

</sipStack>

<autoAnswerTimer>1</autoAnswerTimer>

<autoAnswerAltBehavior>false</autoAnswerAltBehavior>

<autoAnswerOverride>true</autoAnswerOverride>

<transferOnhookEnabled>false</transferOnhookEnabled>

<enableVad>false</enableVad>

<preferredCodec>none</preferredCodec>

<dtmfAvtPayload>101</dtmfAvtPayload>

<dtmfDbLevel>3</dtmfDbLevel>

<dtmfOutofBand>avt</dtmfOutofBand>

<alwaysUsePrimeLine>false</alwaysUsePrimeLine>

<alwaysUsePrimeLineVoiceMail>false</alwaysUsePrimeLineVoiceMail>

<kpml>3</kpml>

<natEnabled>0</natEnabled>

<natAddress/>

<stutterMsgWaiting>0</stutterMsgWaiting>

<callStats>false</callStats>

<silentPeriodBetweenCallWaitingBursts>10</silentPeriodBetweenCallWaitingBursts>

<disableLocalSpeedDialConfig>false</disableLocalSpeedDialConfig>

<startMediaPort>16384</startMediaPort>

<stopMediaPort>32766</stopMediaPort>

<voipControlPort>5060</voipControlPort>

<dscpForAudio>184</dscpForAudio>

<ringSettingBusyStationPolicy>0</ringSettingBusyStationPolicy>

<dialTemplate>dialplan.xml</dialTemplate>

<phoneLabel>Office</phoneLabel>


-<sipLines>


-<line button="1">

<featureID>9</featureID>

<featureLabel>2077</featureLabel>

<name>2077</name>

<displayName>2077</displayName>

<contact>2077</contact>

<proxy>10.3.0.8</proxy>

<port>5060</port>


-<autoAnswer>

<autoAnswerEnabled>2</autoAnswerEnabled>

</autoAnswer>

<callWaiting>3</callWaiting>

<authName>2077</authName>

<authPassword>42456f440dae2c</authPassword>

<sharedLine>false</sharedLine>

<messageWaitingLampPolicy>1</messageWaitingLampPolicy>

<messagesNumber>*97</messagesNumber>

<ringSettingIdle>4</ringSettingIdle>

<ringSettingActive>5</ringSettingActive>


-<forwardCallInfoDisplay>

<callerName>true</callerName>

<callerNumber>false</callerNumber>

<redirectedNumber>false</redirectedNumber>

<dialedNumber>true</dialedNumber>

</forwardCallInfoDisplay>

</line>

</sipLines>

</sipProfile>

</device>
 
Joined
Dec 5, 2017
Messages
5
Points
1
SOLUCIONADO!!!

Muchas gracias, en efecto eran 2 cosas, el servidor Tftp funciona correctamente en Windows y consegui en internet un archivo SEPXXXXX.cnf.xml y lo adecué a cada uno de mis telefonos y LISTO!!!

Telefonos registrados, muchas gracias nuevamente por el tip...

Saludos.!!!
 
Joined
Dec 5, 2017
Messages
5
Points
1
PERDON!!, mil disculpas, solo una última pregunta..

El servidor Tftp debe estar activo siempre o solo se utiliza para el registro de los telefonos?
 
Joined
Nov 27, 2014
Messages
84
Points
8
Buenos dias.
de hecho el tftp server siempre esta activo, lo que generalmente uno nunca hace es desactivarlo.
 
Joined
Nov 6, 2018
Messages
1
Points
1
SOLUCIONADO!!!

Muchas gracias, en efecto eran 2 cosas, el servidor Tftp funciona correctamente en Windows y consegui en internet un archivo SEPXXXXX.cnf.xml y lo adecué a cada uno de mis telefonos y LISTO!!!

Telefonos registrados, muchas gracias nuevamente por el tip...

Saludos.!!!
Por favor me puede compartir el archivo de configuración, y si es posible el procedimiento que realizó para configurar el cp-7841
 

jlopez1567

Forum User
Joined
Jan 23, 2019
Messages
1
Points
1
buenas tardes
yo tengo un problema similar pudieras compartir el archivo sipxxxxx que utilisaste para ver si puedo resolver mi problema gracias de antemano

saludos
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,993
Messages
131,109
Members
17,716
Latest member
Orbit114
Top