Registering to Elastix Behind NAT

Discussion in 'General' started by jmorrison26, Mar 5, 2010.

  1. jmorrison26

    Joined:
    Mar 5, 2010
    Messages:
    26
    Likes Received:
    0
    Hi,

    After upgrading to 1.6, I was faced with the task of testing the system before office hours.

    My Elastix server is behind a router doing NAT, so I tried forward port 5060 from the public IP of the router to the NAT ip of the elastic, however when i tried registering xlite using the public ip of the router it did not work.

    Has anyone ever done this before..please share
     
  2. Telco

    Joined:
    Oct 4, 2007
    Messages:
    275
    Likes Received:
    0
    Make sure you have set your NAT settings in the elastix. Mine are set in the sip_nat.conf file it looks like this.

    externip=0.0.0.0 ;your external IP address
    localnet=192.168.0.0/255.255.255.0 ;your internal ip scheme
    nat=yes
    externrefresh=10
     
  3. lev1987

    Joined:
    Jan 8, 2010
    Messages:
    25
    Likes Received:
    0
    Also, don't forget to route rtp ports usually 10000 - 20000 udp to your asterisk box. Make sure this ports are not natted.
    what router are you using is important as well, I had problems with Checkpoint before and I had to use PFsense instead.
     

Share This Page