registering nokia e71 - wan side doesnt work

Discussion in 'General' started by robert99, Feb 14, 2011.

  1. robert99

    Joined:
    Feb 5, 2010
    Messages:
    7
    Likes Received:
    0
    hi everyone

    have a nokia e71 , can register with my asterisk locally ( 192.168.1.2)
    but no matter what i do ,,, i can not get it to register over wan-for example on 3g mobile or a friends broadband connection.
    everytime i change the registration/proxy details in the nokia from the local ip - to my home public ip,,, leaving the passwords etc unchanged ,, i can not register.

    in asterisk debug , apparently im using the wrong password- which i know im not.

    see below..


    [glen-desktop*CLI>
    [Feb 13 16:50:38] NOTICE[1299]: chan_sip.c:21500 handle_request_register: Registration from '<sip:intphone@192.168.1.2>' failed for '82.70.25.14' - Wrong password
    [Feb 13 16:50:38] DEBUG[1299]: chan_sip.c:21978 handle_request_do: SIP message could not be handled, bad request: h642CpFpoIeeb0djyKJwp0yDZRgPek

    len-desktop




    ive forwarded all ports to my asterisk- 5060 and 10000 thru to
    20000
    on the nokia , i have tried enabling the stun client, but still no go.

    the only thing i dont think ive done , is tell asterisk itself that it should be nat.

    the individual extension- "intphone", has nat=on
    but asterisk server itself i dont think has nat on , likewise , the stun server on my asterisk server is switched off.




    ive had this problem for months ,,,, can someone help?
     
  2. fdiogo

    Joined:
    Sep 7, 2008
    Messages:
    52
    Likes Received:
    0
    Hi,

    configure your router in DMZ with the ip of your pbx.

    put nat yes on your extension.

    have you configure sip_nat.conf????

    i have nokia e71 and it works great!!! :)

    Diogo
     

Share This Page