red-fone foneBridge2 problems

Refuge

Joined
Mar 30, 2009
Messages
13
Likes
0
Points
0
#1
I have a system utilizing a redfone foneBridge2 device. (Single port only, the second port is disabled via firmware.) I am having some trouble getting the system to work with Elastix 1.5 x86_64. I have installed the fonulator 2.0.0-36 package, as well as the v1.2 redfone tool module. I have managed to get the system to see the device, and show all 24 channels as 'green' (dahdi_tool shows a status of 'OK') however, when I try to start asterisk (using amportal) it tells me that there is a problem with the Dahdi Configuration: (Error from log below:)
[Mar 30 15:25:48] ERROR[4422] asterisk.c: Asterisk has detected a problem with your DAHDI configuration and will shutdown for your protection. You have options:
1. You only have to compile DAHDI support into Asterisk if you need it. One option is to recompile without DAHDI support.
2. You only have to load DAHDI drivers if you want to take advantage of DAHDI services. One option is to unload DAHDI modules if you don't need them.
3. If you need Zaptel services, you must correctly configure DAHDI.
I can't see anything wrong with the configuration, and dahdi_toll shows everything as fine. (My system connects to another PBX via a T1, which in turn is out connection to the PSTN, which is why the chan_dahdi is set to switchtype=national, and signalling=pri_net.) Below are my config files:

redfone.conf
[globals]
# IP-address of the IP Configuration port
# Factory defaults are; FB1=192.168.1.254 FB2=192.168.1.253
fb=192.168.1.254
# Which port to use for TDMoE Traffic (1 or 2)
port=1
# Which Asterisk server destination MAC address for TDMoE Traffic?
server=00:19:B9:E8:F0:D1
# For 2.0 version firmware/hardware and above, specify priorities as
# priorities=0,1,2,3
# or for all internal timing
# priorities=0,0,0,0
priorities=0,0,0,0

#SPAN 1 T1
#[span1]
#framing=esf
#encoding=b8zs


#SPAN 2 E1
#[span2]
#framing=ccs
#encoding=hdb3


#SPAN 3 E1
#[span3]
#framing=ccs
#encoding=hdb3


#SPAN 4 E1
#[span4]
#framing=ccs
#encoding=hdb3
dahdi/system.conf
# Autogenerated by /usr/sbin/dahdi_genconf on Mon Mar 30 14:49:46 2009 -- do not hand edit
# Dahdi Configuration File
#
# This file is parsed by the Dahdi Configurator, dahdi_cfg
#
# Span 1: DAHDI_DUMMY/1 "DAHDI_DUMMY/1 (source: RTC) 1" (MASTER)

# Global data

loadzone = us
defaultzone = us

dynamic=ethmf,eth0/00:50:C2:65:D5:0A/0,24,0
#
bchan=1-23
dchan=24
#
loadzone = us
defaultzone=us

chan_dahdi.conf
[trunkgroups]

[channels]
language=en
context=from-pstn
switchtype=national
signalling=pri_net
rxwink=300 ; Atlas seems to use long (250ms) winks
usecallerid=yes
hidecallerid=no
callwaiting=yes
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=yes
transfer=yes
canpark=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=no
faxdetect=incoming
echotraining=800
rxgain=0.0
txgain=0.0
callgroup=1
pickupgroup=1

;Uncomment these lines if you have problems with the disconection of your analog lines
;busydetect=yes
;busycount=3

immediate=no

group=0
context=from-pstn
channel =>1-23


#include dahdi-channels.conf
#include chan_dahdi_additional.conf
I am unable to see any issues with this, and the system worked fine with elastix 1.3 without any trouble on the same settings. Also, with the exception of the fonebridge, and the fact that this is Dahdi, not zaptel, the settings are identical on another production system on trixbox 2.2.8, which is what I am looking to replace with the 1.5 system.
 

doctorpacket

Joined
Apr 16, 2009
Messages
4
Likes
0
Points
0
#2
Checking if you found the solution?
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#3
Refuge said:
.
.

redfone.conf
[globals]
# IP-address of the IP Configuration port
# Factory defaults are; FB1=192.168.1.254 FB2=192.168.1.253
fb=192.168.1.254
# Which port to use for TDMoE Traffic (1 or 2)
port=1
# Which Asterisk server destination MAC address for TDMoE Traffic?
server=00:19:B9:E8:F0:D1
# For 2.0 version firmware/hardware and above, specify priorities as
# priorities=0,1,2,3
# or for all internal timing
# priorities=0,0,0,0
priorities=0,0,0,0

#SPAN 1 T1
#[span1]
#framing=esf
#encoding=b8zs


#SPAN 2 E1
#[span2]
#framing=ccs
#encoding=hdb3

.
.

FWIW . .

In my deployments of redfones, I've always found it necessary to un-comment the span definitions that I want to use in redfone.conf . . . :)

what does fonulator -vq say?
 

Refuge

Joined
Mar 30, 2009
Messages
13
Likes
0
Points
0
#4
it turns out I had my MAC address in redfone.conf for the server, set to the redfone's ethernet MAC, instead of the Server's MAC address. changing that out seems to have resolved that issue. I've got the system working now, however, it still kernel panics up reboot, because the channels don't get properly shut down before the system reboots. if you do a 'amportal stop' and then a 'dahdi_cfg -s', then reboot, it doesn't kernel panic. I've got a bug submitted, however, I've not been able to get a output of the kernel panic screen for lack of a null modem cable.
 

doctorpacket

Joined
Apr 16, 2009
Messages
4
Likes
0
Points
0
#5
Interesting. We have also been seeing problems with kernel panics.

I found a useful Red Hat Knowledge Base article http://kbase.redhat.com/faq/docs/DOC-6039;jsessionid=6DE94031431A077388AE08C9FCB53D24.066ef7ba on a tool to assist capturing kernel panic logs. However I am seeing a problem with kdump that I suspect may be due to the fact that I am trying to get it working on a RAID1 ARRAY.

Anyway, here is the procedure I have extracted:

The kexec and kdump utilities can be used to save a kernel crash dump. Install the kexec-tools utility:
yum -y install kexec-tools

Append the boot parameter crashkernel=128M@16M to the kernel line in /etc/grub.conf, e.g.:
kernel /vmlinuz-2.6.18-92.1.22.el5 ro root=/dev/VolGroupM167/LogVol2906 crashkernel=128M@16M

The RH article covers various location options for writing the kernel crash info. On a LAN, SSH using root user is really simply to setup. Edit /etc/kdump.conf and set appropriately:
net root@remoteserver

Setup kdump so that it can automatically login to the remote server:
service kdump propagate

Utility will create SSH keys and require entry of root password for the remoteserver. Subsequent logins to the remoteserver will not require a password.

Set kdump to start automatically and start kdump
chkconfig kdump on
service kdump start


Force a kernel panic:
echo "c" > /proc/sysrq-trigger

The crash info will be stored on the remote server in /var/crash/[host]-[date]/ directory.
I am seeing the following error when I try to start kdump:
No kdump initial ramdisk found. [WARNING]
Rebuilding /boot/initrd-2.6.18-92.1.22.el5kdump.img
No module ARRAY found for kernel 2.6.18-92.1.22.el5, aborting.
Failed to run mkdumprd
Would be interested to hear if it works for you.

We will try your suggestion regarding the kernel panic problem and see if it relates to the problem we are seeing.

thanks .. .david
 

doctorpacket

Joined
Apr 16, 2009
Messages
4
Likes
0
Points
0
#6
Refuge said:
if you do a 'amportal stop' and then a 'dahdi_cfg -s', then reboot, it doesn't kernel panic.
Checking if you setup a script to automate this whenever the system is shutdown or rebooted?

For example, did you setup scripts in /etc/rc.d/?
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,887
Members
17,565
Latest member
omarmenichetti
Top