Recording. [Solved]

Discussion in 'General' started by xpecta, Feb 4, 2008.

  1. xpecta

    Joined:
    Jan 28, 2008
    Messages:
    18
    Likes Received:
    0
    I can't find recordigs ive preformed through x-lite.
    Where are these located, they are not in /var/spool/asterisk/monitor and not in /var/www/html/recording. It seems like the recording function dont work at all :(.

    Thanks in advance

    / X<br><br>Post edited by: xpecta, at: 2008/02/05 01:35
     
  2. dingoland

    Joined:
    Jan 16, 2008
    Messages:
    220
    Likes Received:
    0
    Re:Recording.

    Hi,

    Can you tell us more about your network configuration please ?
    You have to enable call recordings in the extension options and in the general settings / outbound and inbound dial options.

    And in your router, if your box is on your lan network, you have to forward the SIP (5060) and RTP (UDP only) ports ( 10001 - 20000) to your box.

    In the features.conf, you have to add the featuredigittimeout = 2000 in the general section to allow you to do *1 in the specified time (500ms by default, passed to 2000ms with this command)

    It is working almost fine with X lite for me.

    We need more infos to help you...

    Regards
     
  3. blapoint

    Joined:
    Jun 11, 2007
    Messages:
    34
    Likes Received:
    0
    Re:Recording.

    Are you using the *1 to initiate the recording. If I remember right when using the Xlight soft phone the record button save the recording to the local drive not the server.
     
  4. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    Re:Recording.

    When you record using xlite it records the files in the machine running it, not in the asterisk server.
    To record calls using the asterisk server you have to enable it in the extension configurarion and then use the key combination to enable monitor stored in features.conf
     
  5. xpecta

    Joined:
    Jan 28, 2008
    Messages:
    18
    Likes Received:
    0
    Re:Recording.

    I've tried everything above that you guys described it seems not to work at all :/.
    I've tried it on a public ip it still didnt work out.

    The only featuredigittimeout i have is in followme.conf:featuredigittimeout=>5000

    Hm any further suggestions?

    / Thanks for you're time
     
  6. dingoland

    Joined:
    Jan 16, 2008
    Messages:
    220
    Likes Received:
    0
    Re:Recording.

    You tried on a public IP, the server, x-lite or both ?

    The featuredigittimeout in the followme.conf file is not the same and don't have the same role than this in the features.conf. In the features.conf in general section, add the line:

    featuredigittimeout = 2000

    with this syntax.
    In the features conf, you should have at the last lines normally:

    automon => *1

    It is the line saying how to record on demand the calls.

    If it stills not working, tell us the network configuration precisely, im sure the solution is linked to this. (FQDN, NAT, DNS.....)

    Regards
     
  7. xpecta

    Joined:
    Jan 28, 2008
    Messages:
    18
    Likes Received:
    0
    Re:Recording.

    I've managed to get it working when i press *1.
    But how can i make it work if i only press "record" in x-lite instead of pressing *1?

    Thank you kindly for your help
     
  8. dingoland

    Joined:
    Jan 16, 2008
    Messages:
    220
    Likes Received:
    0
    Re:Recording.

    You cannot !

    - If you press record button on X-lite, your records will be stored on the HDD of the pc, not linked at all to the elastix server recording functions.
    It is like if you record your microphone on your pc by the Windows magnetophone through the soundcard.

    - If you press *1 on x-lite, the elastix server recordings functions are called and in this case, your records are managed by the Elastix server only.

    It is the 2nd solution the good one, not both, sorry.

    Regards<br><br>Post edited by: dingoland, at: 2008/02/04 21:47
     
  9. xpecta

    Joined:
    Jan 28, 2008
    Messages:
    18
    Likes Received:
    0
    Re:Recording.

    No problem!
    I thank you kindly for the effort you and the other people put into helping me out!

    Best regards / X
     

Share This Page