recording does not work at all

Discussion in 'General' started by savenow, Jan 21, 2010.

  1. savenow

    Joined:
    Jan 10, 2010
    Messages:
    4
    Likes Received:
    0
    Hi.. I am facing some problesm when trying to record call to be monitored that does not work al all neither from free-pbx/recording nor from elastix/pbx/monitoring even when users are set to always record calls for both incoming and outgoing on their profiles.

    i am running

    elastix-1.5.2-2.3
    asterisk-1.4.28-1

    the monitor directory is totally empty
    /var/spool/asterisk/monitor/

    can someone please point me to the right direccion on how to solve this problem

    many thanks in advance
     
  2. mattrh

    Joined:
    Jul 15, 2008
    Messages:
    175
    Likes Received:
    0
    how are you trying to record the call. are you recording based on queue or pressing *1
     
  3. savenow

    Joined:
    Jan 10, 2010
    Messages:
    4
    Likes Received:
    0
    just by setting in users's profiles

    Recording Options

    Record Incoming: Always
    Record Outgoing: Always


    regards
     
  4. DaveD

    Joined:
    Nov 12, 2007
    Messages:
    597
    Likes Received:
    0
    Make sure you have " Ww " in general settings dial command
     
  5. savenow

    Joined:
    Jan 10, 2010
    Messages:
    4
    Likes Received:
    0
    you mean here?

    General Setting / Dialing Options

    Asterisk Dial command options: tr


    tha is set like showed above.

    i do have an other server with the same setting working properly in terms of recordings, also i read that Ww is used for recording calls on-demand by pressing *1 but i am setting that to be always..

    i will try that any way..let you know the outcome

    thanks
     
  6. savenow

    Joined:
    Jan 10, 2010
    Messages:
    4
    Likes Received:
    0
    setting Ww did not help the problem. but i found the folowing in

    /etc/asterisk/extensions_additional.conf

    [macro-record-enable]
    include => macro-record-enable-custom
    exten => s,1,MacroExit()

    ; end of [macro-record-enable]

    and edited that to :


    [macro-record-enable]
    include => macro-record-enable-custom
    exten => s,1,GotoIf($["${BLINDTRANSFER}" = ""]?check)
    exten => s,n,ResetCDR(w)
    exten => s,n,StopMixMonitor()
    exten => s,n(check),AGI(recordingcheck,${STRFTIME(${EPOCH},,%Y%m%d-%H%M%S)},${UNIQUEID})
    exten => s,n,MacroExit()
    exten => s,1+998(record),MixMonitor(${MIXMON_DIR}${CALLFILENAME}.${MIXMON_FORMAT},,${MIXMON_POST})

    ; end of [macro-record-enable]


    after doing that magically calls started to record and /var/spool/asterisk/monitor/ starts populating with recording and i was able to play thoses recording from ARI module but not from "monitoring" in elastix yet.

    two thigs i do not understand

    first: why that marcro was not set as it should be from the begining?
    second: why i can not use "monitoring" tab from elastix yet (that doest not show the recording)


    hope someone could answer those questions

    regards
     

Share This Page