Recent install wont record vm outgoing msgs.

Discussion in 'General' started by agidi, Feb 19, 2009.

  1. agidi

    Joined:
    Jan 13, 2008
    Messages:
    152
    Likes Received:
    0
    I'm mostly on the channel, helping out, but this one has me puzzled.

    a one week old fresh install, no freepbx updates.

    I go into VM to record my busy/unavailable msgs, and cant. It goes thru alison's recordings, "after the tone record your..." then BEEP, and "press 1 to accept this recording, press 2 to listen to it. If I press 1 it does the same thing if I press 2 it hangs up on me.

    the CLI says nothing.
    I'm pasting below.

    Any ideas? I already amportal stop, amportal chown, amportal start. Even rebooted.
    all comments and suggestions are welcomed. I would really like to be able to fix it this time, rather than fresh re install AGAIN.
    thanks

    agidipbx*CLI>
    -- Executing [*97@from-internal:1] Answer("SIP/202-09162478", "") in new stack
    -- Executing [*97@from-internal:2] Wait("SIP/202-09162478", "1") in new stack
    -- Executing [*97@from-internal:3] Macro("SIP/202-09162478", "user-callerid|") in new stack
    -- Executing [s@macro-user-callerid:1] NoOp("SIP/202-09162478", "user-callerid: device 202") in new stack
    -- Executing [s@macro-user-callerid:2] Set("SIP/202-09162478", "AMPUSER=202") in new stack
    -- Executing [s@macro-user-callerid:3] GotoIf("SIP/202-09162478", "0?report") in new stack
    -- Executing [s@macro-user-callerid:4] ExecIf("SIP/202-09162478", "1|Set|REALCALLERIDNUM=202") in new stack
    -- Executing [s@macro-user-callerid:5] NoOp("SIP/202-09162478", "REALCALLERIDNUM is 202") in new stack
    -- Executing [s@macro-user-callerid:6] Set("SIP/202-09162478", "AMPUSER=202") in new stack
    -- Executing [s@macro-user-callerid:7] Set("SIP/202-09162478", "AMPUSERCIDNAME=A.Gidi") in new stack
    -- Executing [s@macro-user-callerid:8] GotoIf("SIP/202-09162478", "0?report") in new stack
    -- Executing [s@macro-user-callerid:9] Set("SIP/202-09162478", "AMPUSERCID=202") in new stack
    -- Executing [s@macro-user-callerid:10] Set("SIP/202-09162478", "CALLERID(all)="A.Gidi" <202>") in new stack
    -- Executing [s@macro-user-callerid:11] Set("SIP/202-09162478", "REALCALLERIDNUM=202") in new stack
    -- Executing [s@macro-user-callerid:12] ExecIf("SIP/202-09162478", "0|Set|CHANNEL(language)=") in new stack
    -- Executing [s@macro-user-callerid:13] NoOp("SIP/202-09162478", "TTL: ARG1: ") in new stack
    -- Executing [s@macro-user-callerid:14] GotoIf("SIP/202-09162478", "0?continue") in new stack
    -- Executing [s@macro-user-callerid:15] Set("SIP/202-09162478", "__TTL=64") in new stack
    -- Executing [s@macro-user-callerid:16] GotoIf("SIP/202-09162478", "1?continue") in new stack
    -- Goto (macro-user-callerid,s,23)
    -- Executing [s@macro-user-callerid:23] NoOp("SIP/202-09162478", "Using CallerID "A.Gidi" <202>") in new stack
    -- Executing [*97@from-internal:4] Macro("SIP/202-09162478", "get-vmcontext|202") in new stack
    -- Executing [s@macro-get-vmcontext:1] Set("SIP/202-09162478", "VMCONTEXT=default") in new stack
    -- Executing [s@macro-get-vmcontext:2] GotoIf("SIP/202-09162478", "0?200:300") in new stack
    -- Goto (macro-get-vmcontext,s,300)
    -- Executing [s@macro-get-vmcontext:300] NoOp("SIP/202-09162478", "") in new stack
    -- Executing [*97@from-internal:5] MailboxExists("SIP/202-09162478", "202@default") in new stack
    -- Executing [*97@from-internal:6] GotoIf("SIP/202-09162478", "1?mbexist") in new stack
    -- Goto (from-internal,*97,106)
    -- Executing [*97@from-internal:106] VoiceMailMain("SIP/202-09162478", "202@default") in new stack
    -- <SIP/202-09162478> Playing 'vm-password' (language 'en')
    -- <SIP/202-09162478> Playing 'vm-youhave' (language 'en')
    -- <SIP/202-09162478> Playing 'vm-no' (language 'en')
    -- <SIP/202-09162478> Playing 'vm-messages' (language 'en')
    -- <SIP/202-09162478> Playing 'vm-opts' (language 'en')
    -- <SIP/202-09162478> Playing 'vm-options' (language 'en')
    -- Recording the message
    -- <SIP/202-09162478> Playing 'vm-rec-busy' (language 'en')
    -- <SIP/202-09162478> Playing 'beep' (language 'en')
    -- x=0, open writing: /var/spool/asterisk/voicemail/default/202/busy.tmp format: wav49, (nil)
    -- <SIP/202-09162478> Playing 'vm-review' (language 'en')
    -- Reviewing the message
    == Spawn extension (from-internal, *97, 106) exited non-zero on 'SIP/202-09162478'
    -- Executing [h@from-internal:1] Macro("SIP/202-09162478", "hangupcall") in new stack
    -- Executing [s@macro-hangupcall:1] ResetCDR("SIP/202-09162478", "w") in new stack
    -- Executing [s@macro-hangupcall:2] NoCDR("SIP/202-09162478", "") in new stack
    -- Executing [s@macro-hangupcall:3] GotoIf("SIP/202-09162478", "1?skiprg") in new stack
    -- Goto (macro-hangupcall,s,6)
    -- Executing [s@macro-hangupcall:6] GotoIf("SIP/202-09162478", "1?skipblkvm") in new stack
    -- Goto (macro-hangupcall,s,9)
    -- Executing [s@macro-hangupcall:9] GotoIf("SIP/202-09162478", "1?theend") in new stack
    -- Goto (macro-hangupcall,s,11)
    -- Executing [s@macro-hangupcall:11] Hangup("SIP/202-09162478", "") in new stack
    == Spawn extension (macro-hangupcall, s, 11) exited non-zero on 'SIP/202-09162478' in macro 'hangupcall'
    == Spawn extension (macro-hangupcall, s, 11) exited non-zero on 'SIP/202-09162478'
    agidipbx*CLI> logger mute
    Console is muted.
     
  2. Chilling_Silence

    Joined:
    Sep 23, 2008
    Messages:
    488
    Likes Received:
    0
    Go into your extension, turn off Voicemail. Apply changes.
    Now, go into:
    /var/spool/asterisk/voicemail/

    Check the permissions, rm /var/spool/asterisk/voicemail/default/202

    Then, re-add voicemail, check permissions again :)

    Good luck ;)
     
  3. agidi

    Joined:
    Jan 13, 2008
    Messages:
    152
    Likes Received:
    0
    Hello

    I appreciate the quick reply :)

    I deleted all vm boxes,

    amportal stop
    amportal chown
    amportal restart

    Wen't in with to see permisions on /var/spool/asterisk/voicemail
    but voicemail did not exist. I asummed because I just deleted all VM boxes.

    I re created 202, and checked again, no /var/spool/asterisk/voicemail

    I tried recording the out going message and same thing, it goes right thru.

    It seems its not creating /voicemail I checked the permissions for var 755, spool 755, asterisk 755.

    Should I manually create it? Since I'm logged in as root, how do I make it owned by asterisk? I just know a few commands. But can follow instrucions :)

    thanks for the help.
     

Share This Page