Receiving fax by email and SIP trunk

Discussion in 'General' started by dodiaz, Nov 1, 2009.

  1. dodiaz

    Joined:
    Nov 1, 2009
    Messages:
    5
    Likes Received:
    0
    Hello
    I have elastix 1.5.2-2 installed. In this server I have a 1)my PBX with SIP trunk and 2)a hylafax sever. My problem is that they do not function fine together.

    *My PBX functions fine when i put in the web interface: System ---> Network the gateway: 192.168.236.30, which is the address that has the equipment of my service provider. This equipment has the SIP trunk but it cant leave to internet. Then when my hilafax try to send messages, the log says that "no route to destine" and it is coherent because it tries to leave for the 192.168.236.30 but this equipment can´t leave to internet.
    *On the other hand, My Hylafax server function fine when i put in the web interface:System ---> Network the gateway:192.168.236.33, which is the address of my Domain Server. My domain server has out to internet. In this situation i can receive emails with the fax, but my SIP TRUNK does not function.

    I have tried putting the gateway: 192.168.236.30, and configuring iptables in the server for that the traffic to the port 25 (SMTP Traffic) preroute to the destination:192.168.236.33, but it does not work.

    ¿How can i do when the SIP trunk go to one IP and the trafic of the Hylafax server to another IP?

    If someone can help me i will appreciate.

    Daniel
     
  2. dodiaz

    Joined:
    Nov 1, 2009
    Messages:
    5
    Likes Received:
    0
    Hey

    I have solved my problem. I put a SMTP server in the middle between my asterisk server and the mail server(mail.mycompany.com). The SMTP server that i chose was Argosoft mail server. After I configured this smtp server (in this example with the ip:192.168.236.37) with the correct directions IP: Gateway ip and DNS server, I configured in the asterisk the file /etc/postfix/main.cf with the IP of this SMTP server:

    ------
    relayhost = [192.168.236.37]:587
    -------

    After in /etc/postfix/sasl_passwd i put:
    ----------
    [192.168.236.37]:587 usuario@gmail.com:contraseña
    ---------

    And in the file /etc/postfix/generic i put:
    ---------
    root@loclhost.localdomain usuario@gmail.com
    ---------


    Then i proved sending a fax from hykafax client and i made all fine, the email arrived correctly.

    Note:

    For configuring the sending if fax by email I used the following link:
    http://www.elastix.org/index.php?option ... 3&id=12124


    Thanks the persons who read my case.

    I will be attent if someone has any question.

    Daniel D
     

Share This Page