Receive Fax with Hylafax

Discussion in 'General' started by ozan.yanik, Jul 30, 2010.

  1. ozan.yanik

    Joined:
    Jul 30, 2010
    Messages:
    10
    Likes Received:
    0
    I cant Receive Fax with Hylafax

    I'm not using analog card. On my Audiocodecs FXO Gateway (under tel.profile) T.38 selected. I'm referring incoming fax which received by Audiocodecs FXO gateway to SIP Trunk over Elaxtix.

    In order;

    1- I've created IAX2 extension. Voicemail -> Disabled. Voice Recording -> Disabled.

    2- On Fax tab, by clicking "New Virtual Box" I've entered IAX2 Extension information.

    3- I've created an "Any DIDAny CID" incoming call route. Added the fax options below:

    Fax Extension : Iax2 Extension
    Fax Email : .....@....com
    Fax Detection Type : NvFax
    Pause After Answer : Null

    4- Fax line on General Settings is disabled.

    Despite these configuration, I can't receive fax. Fax signalization of my country is T.38. Here you can see the errors on Hylafax logs.


    Jul 30 14:35:30. http://forum.elastix.org/old_files/hylafax_log.txt http://forum.elastix.org/old_files/hylafax_log.txt 40: [ 3135]: RECV FAX: RSPREC error/got DCN
    Jul 30 14:35:30.40: [ 3135]: RECV FAX: end
    Jul 30 14:35:30.40: [ 3135]: SESSION END

    Softwares and Hardwares we use:

    Elastix 1.6
    Audiocodes Mp118
    TPLink Switch
     
  2. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    On the inbound route, just choose the extension, dont use nvfax, or any other option, just leave them as they are. On the audio code, change t.38 to "voice and fax pass through"
     
  3. ozan.yanik

    Joined:
    Jul 30, 2010
    Messages:
    10
    Likes Received:
    0
    My problem was solved.Thank you very much jgutierrez.! :lol:
     
  4. Dock

    Joined:
    Jul 12, 2010
    Messages:
    9
    Likes Received:
    0
    Re: Re:Receive Fax with Hylafax

    jgutierrez escribió:
    Sorry, I have a similar problem, but can not find
    where change audio codec
    In the configuration options inbound route can not find anything to tell me the coding
    Again, the configuration of the iax extension I can´t find where to change this option
    Could you tell me where to change it?

    This is my configuration


    1- I've created IAX2 extension. Voicemail -> Disabled. Voice Recording -> Disabled.
    id 2000
    secret 2000

    2- On Fax tab, by clicking "New Virtual Box" I've entered IAX2 Extension information.
    Extension de Fax (IAX): *
    2000
    Secreto (IAX): *
    2000

    3- At inbound route (the same as that used for communication via PSTN, working well ). Added the fax options below:

    Fax Extension: 2000 (the sam step 1)
    Fax Email:
    Fax Detection Type: none
    Pause After Answer:

    4- Fax line on General Settings is disabled en general setting page.

    From already thank you very much and sorry for my English http://forum.elastix.org/old_files/log_fax.txt
     
  5. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    The codec configuation was on the ATA, not at the extension configuration, on the inbound routes, just choose the extension, NOT any fax option (leave them as they are).
    You will need to explain more how are you testing, medium though which the fax travels, etc.
     
  6. Dock

    Joined:
    Jul 12, 2010
    Messages:
    9
    Likes Received:
    0
    jgutierrez escribió:
    Hello Thank you for answering.
    My tests are performed, through a conventional fax machine.
    I call dial by the pstn (analog line) to the number of asterick public (is configured with a SPA3102 ata). The ivr respond, given the option to mark an extension, and if dial fax 2000 (iax configured for fax)
    Marking 2000, I get the fax tone, the machine attempts to send the fax, the paper runs about centimeters, it stops and gives the msg error 43. (the machine work fine )


    As for what elastix log attached to this post. Img also attached configuration of the tie.ata spa3102 Pstn line
    http://forum.elastix.org/old_files/log_ata_spa3102.txt

    Config ata spa 3102

    http://www.ta21.com.ar/fax/spa_3102_pstn_line.gif (no logro subirla al foro)

    Reiterate that I am using elastix line, works well for voice communication.
    Sorry mi inglis google


    From already thank you very much
     
  7. ozan.yanik

    Joined:
    Jul 30, 2010
    Messages:
    10
    Likes Received:
    0
    Hi Dock,

    1-Add in a new codec in Coders Table g711U-law_Vbd and g711A-law_Vbd
    2-Instead you choose t.38 to G711 Transport in Tel Profile.

    I showed in pictures, These settings for Audiocodes & Elastix

    Good Luck. [​IMG] [​IMG]
     
  8. Dock

    Joined:
    Jul 12, 2010
    Messages:
    9
    Likes Received:
    0
    Re: Re:Receive Fax with Hylafax

    Thank you very much for responding.
    Forgive my ignorance.
    Could you give me a clue how to get to the screens that you sent,
    I can not find how to get to the editor, is Elastix FreePBX ?, can you tell me how to get to the area to edit or agregregar coders, you
    I would appreciate.
    Sorry my inglis.
    Thank you very much
     
  9. ozan.yanik

    Joined:
    Jul 30, 2010
    Messages:
    10
    Likes Received:
    0
    Did not create the in coming call route in Elastix or FreePBX.I'll send a fax unconditionally to IAX2 Extension.

    I think he should do,before Automatic Dialing (Audiocodes) in a written iax2 extension number.You'll see the faxes are coming [​IMG]
     

Share This Page