Realtek 8110 / 8169 NIC Install

Discussion in 'General' started by DStirrup, Mar 7, 2008.

  1. DStirrup

    Jun 4, 2007
    Likes Received:
    Given many of the new Motherboards are using new Realtek chipsets unsupported by Centos 5.0 or 5.1 here is some info for those needing support.

    This is my 8110 script which I use daily.

    Install a TEMP PCI card that will work with the old Centos kernel 2.6.18-8. I use an old Intel Pro100.

    Make sure you are on the Internet before you start this process.

    1st off go get a kernel-devel package that matches the Elastix distribution kernel. Personal opinion is this should be available in the Elastix repo but isn't!

    Find a location you trust for the kerenl-devel rpm. This location is one I use that works for me, change the URL to suit your needs and availability.
    # cd /usr/src
    # wget ... 5.i686.rpm

    # rpm --install kernel-devel-2.6.18-8.el5.i686.rpm
    # ln -s /usr/src/kernels/2.6.18-8.el5-i686/ /usr/src/linux

    Downloaded and install current rtl811x drivers from Realtek. Check their website for any update to the script names;

    # wget
    # tar vjxf r8169-6.005.00.tar.bz2
    # cd /usr/src/r8169-6.005.00
    # make clean; make clean modules
    # make; make install
    # depmod -a
    # insmod ./src/r8169.ko
    # reboot

    If you end up with the new NIC module as eth1 or eth2 rather than eth0 which is what you want then you will have to look at the following files
    Delete any ifcfg-eth... files that are not what you want including .bak & .sav

    Here is a sample eth0 file that works for me;

    Take note of the MAC address which has to be yours as this will link to the correct NIC port if you have more than 1 NIC. Find this by using "lspci". If there is only a single NIC then you can delete "HWADDR= " as your NIC will be the only resource available.

    For a simple DHCP config using a single NIC try;

    I hope this helps.<br><br>Post edited by: DStirrup, at: 2008/03/08 17:08
  2. lek

    lek Guest

    Thanks for your contribution DStirrup.

    I just want to say that we're planning to include the kernel-devel package.

    Hava a nice day!
  3. zenny

    Jan 20, 2008
    Likes Received:
    I did accordingly as you suggested, and also tried to patch as it is advised in this thread ( ... .6-350564/) but it keeps on producing an error, that reads:

    Actually when the tg3 broadcom driver was not compiled for my eth0, I used the same card to get to the internet as eth0. Obviously I have specified alias to relevant driver modules in the /etc/modprobe.conf file.

    What could be preventing the D-Link DGE-528T - 10/100/1000 gigabit network pci adapter , 33/66mhz 32bit to be used an local interface (eth1) for my local network? Just wondering!
  4. martinparks

    Nov 21, 2007
    Likes Received:
    I did not have an extra card around that would work so I did this instead.

    Using my other computer I
    Download the driver from
    use winrar or something like it to extract the drivers and burn it to a cd, this way I will always have it around

    mount the cdrom drive

    mkdir /mnt/cdrom
    mount /dev/cdrom /mnt/cdrom

    cd /mnt/cdrom

    mv r8168-8.005.00 /usr/src

    cd /usr/src/r8168-8.005.00

    make clean modules
    make install
    depmod -a
    insmod ./src/r8168.ko
    ifconfig -a
    service network restart

    #Reboot the system
    shutdown -r now

    I hope this helps as well.<br><br>Post edited by: martinparks, at: 2008/07/07 21:50
  5. elastixguy

    Mar 1, 2008
    Likes Received:
    I have a r8169 nic, useful information

    Another problem I have is I have 2 nics and want to split the traffic like eth0 does internet only traffic and the other does local network only.

    eth0 has a dedicated internet connection as to guarantee voip quality.

    How can I make sure all internet traffic or at least voip traffic, goes to eth0?

    Have tried a few tricks but none worked properly... For instance, if the eth0 connection failed just for a while the connection would fall back to eth1 and never return to eth0. Only a reboot could reset it to eth0<br><br>Post edited by: elastixguy, at: 2008/07/09 08:10

Share This Page