Read the entire forum!! Lei todos el Forum!!

Discussion in 'General' started by kleyba, Jun 4, 2010.

  1. kleyba

    Feb 26, 2010
    Likes Received:
    Hi yes I read every single post and tried every single suggesion to no avail to here I am asking a question hopiing someone can help... :S

    My setup Rhino E1 card.

    All my lines are comming in from the E1. I setup the IAX2 extention in Elastix.

    Set notranfer to NO, Allow ulaw, disallow all, disable recording.
    Then I created virtual fax, and manually edit the codec to ulaw and refresh to 60 of the /etc/iaxmodem/iaxmodem-cfg.ttyIAX1 file.

    I also tried editing rxgain txgain echo parameters in the /etc/asterisk/chan_dahdi.conf file.

    Got the incomming to work when rxgain was set to 10 but started getting echo in the conversation! I'm just at a loss. Anyone can help me with this problem.

    I'm played with so many parameters don;t even know what to try anymore.

    The error I get in the hylafax log is Training Failed. And it keep trying a slower speed until it fails totally.

    Help desperately needed Thanks!!!!

  2. dicko

    Oct 24, 2008
    Likes Received:
    Allow ulaw, disallow all

    will not work, the other way round will, your order denies all codecs in effectively.

    It is also extremely unlikely that an E1 will be using ulaw pre/de-emphasis , try alaw, the wrong pre/de-empahasis will mess your Faxes up, you will unlikely notice it on a voice call.

    read my other posts on tuning hybrids (2/4 wire interfaces) for echo reduction.


Share This Page