random beeps during an active call

Discussion in 'General' started by cameron, Jun 19, 2010.

  1. cameron

    Joined:
    Jul 18, 2009
    Messages:
    6
    Likes Received:
    0
    Hi all,

    I have a problem and i coulnd find what to do!
    when someone is calling us, we have beeps while talking but when we call somewhere it is ok.

    i have OPENVOX card with 4 FXO and another OPENVOX card with 12 FXS
    Intel(R) Pentium(R) 4 CPU 2.40GHz
    2GB of ram
     
  2. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    Check that on chan_dahdi.conf you have:
    relaxdtmf=yes
    as well you may run the fxo utility:
    1. amportal stop
    2. service asterisk stop (write it down until you get a fail message)
    3. fxotune -i 4 (it will take a couple minutes, be patient)
    4. amportal start
     
  3. cameron

    Joined:
    Jul 18, 2009
    Messages:
    6
    Likes Received:
    0
    First of all i would like to thank you,i have done what you told but i stil have problem, i think it is related to FXS modules not FXO because when i call another ext i have these beeps while talking but when i call office and ring the IPPhones there is no problem.

    what is your idea?
     
  4. cameron

    Joined:
    Jul 18, 2009
    Messages:
    6
    Likes Received:
    0
    i have found some usefull information, when i hear beeps i see some logs in aserisk CLI which may help to solve this problem:


    [Jun 26 09:31:52] DEBUG[22417]: chan_dahdi.c:6335 dahdi_indicate: Requested indication 20 on channel DAHDI/8-1
    [Jun 26 09:31:54] DEBUG[22417]: chan_dahdi.c:4957 dahdi_handle_event: Detected pulse digit '1'
    [Jun 26 09:31:54] DEBUG[22417]: chan_dahdi.c:6335 dahdi_indicate: Requested indication 20 on channel DAHDI/8-1
    [Jun 26 09:31:54] DEBUG[22417]: chan_dahdi.c:6335 dahdi_indicate: Requested indication 20 on channel DAHDI/8-1
    [Jun 26 09:31:54] DEBUG[22417]: chan_dahdi.c:6335 dahdi_indicate: Requested indication 20 on channel DAHDI/8-1
    [Jun 26 09:31:54] DEBUG[22417]: chan_dahdi.c:6335 dahdi_indicate: Requested indication 20 on channel DAHDI/8-1
    [Jun 26 09:31:56] DEBUG[22417]: chan_dahdi.c:6335 dahdi_indicate: Requested indication 20 on channel DAHDI/8-1
    [Jun 26 09:31:56] DEBUG[22417]: chan_dahdi.c:6335 dahdi_indicate: Requested indication 20 on channel DAHDI/8-1
    [Jun 26 09:32:00] DEBUG[22417]: chan_dahdi.c:4957 dahdi_handle_event: Detected pulse digit '1'
    [Jun 26 09:32:00] DEBUG[22417]: chan_dahdi.c:6335 dahdi_indicate: Requested indication 20 on channel DAHDI/8-1
    [Jun 26 09:32:00] DEBUG[22417]: chan_dahdi.c:6335 dahdi_indicate: Requested indication 20 on channel DAHDI/8-1
    [Jun 26 09:32:00] DEBUG[22417]: chan_dahdi.c:6335 dahdi_indicate: Requested indication 20 on channel DAHDI/8-1
    [Jun 26 09:32:00] DEBUG[22417]: chan_dahdi.c:6335 dahdi_indicate: Requested indication 20 on channel DAHDI/8-1
    [Jun 26 09:32:02] DEBUG[22417]: chan_dahdi.c:6335 dahdi_indicate: Requested indication 20 on channel DAHDI/8-1
    [Jun 26 09:32:02] DEBUG[22417]: chan_dahdi.c:6335 dahdi_indicate: Requested indication 20 on channel DAHDI/8-1
    [Jun 26 09:32:06] DEBUG[22417]: chan_dahdi.c:4957 dahdi_handle_event: Detected pulse digit '1'
    [Jun 26 09:32:06] DEBUG[22417]: chan_dahdi.c:6335 dahdi_indicate: Requested indication 20 on channel DAHDI/8-1
    [Jun 26 09:32:06] DEBUG[22417]: chan_dahdi.c:6335 dahdi_indicate: Requested indication 20 on channel DAHDI/8-1
    [Jun 26 09:32:06] DEBUG[22417]: chan_dahdi.c:6335 dahdi_indicate: Requested indication 20 on channel DAHDI/8-1
    [Jun 26 09:32:06] DEBUG[22417]: chan_dahdi.c:6335 dahdi_indicate: Requested indication 20 on channel DAHDI/8-1
    [Jun 26 09:32:08] DEBUG[22417]: chan_dahdi.c:6335 dahdi_indicate: Requested indication 20 on channel DAHDI/8-1
    [Jun 26 09:32:08] DEBUG[22417]: chan_dahdi.c:6335 dahdi_indicate: Requested indication 20 on channel DAHDI/8-1
    ELASTIX*CLI>
     
  5. cameron

    Joined:
    Jul 18, 2009
    Messages:
    6
    Likes Received:
    0
    I Didnt find how to solve this problem but today when i upgrade elastix, asterisk and some other component has been upgraded, and everything is solved!!!!

    but still it is very intresting to me to know what was the problem...
     

Share This Page