Ram en Xen

Discussion in 'General' started by solanet, Aug 30, 2008.

  1. solanet

    Joined:
    Aug 30, 2008
    Messages:
    2
    Likes Received:
    0
    Estoy haciendo unas pruebas con Elstix 1.1.8 sobre Xen. Tengo 8gb de RAM y asigné 1Gb a la VM corriendo Elaxtix. Sin embargo tanto en el Xen Manager como en la VM Elastix solo ve 256Mb. Además de parecer poco elmismo sismtema dice que está al 90%. Como se puede hacer para que tome el GB asignado.
     
  2. rikolen

    Joined:
    Oct 24, 2007
    Messages:
    25
    Likes Received:
    0
    Para obtener que tu maquina virtual acepte 1 GB de RAM es muy sencillo.

    1.- Dom0 Grub configuracion :

    Code:
    title CentOS (2.6.18-92.1.10.el5xen)
            root (hd0,0)
            kernel /xen.gz-3.2.1 dom0_mem=1024000
            module /vmlinuz-2.6.18-92.1.10.el5xen ro root=/dev/lvm1/xen0_root rhgb quiet console=tty0 max_loop=64
            module /initrd-2.6.18-92.1.10.el5xen.img
    2.- egrep -v '(^#|^\s*$)' /etc/xen/xend-config.sxp

    Code:
    (logfile /var/log/xen/xend.log)
    (xend-unix-server yes)
    (xend-unix-path /var/lib/xend/xend-socket)
    (xend-relocation-hosts-allow '^localhost$ ^localhost\\.localdomain$')
    (network-script xen-multi-bridge)
    (vif-script vif-bridge)
    (dom0-min-mem 1024)
    (dom0-cpus 0)
    (vncpasswd '')
    (keymap 'de')
    3.- asi he configurado my DomU Elastix

    # egrep -v '(^#|^\s*$)' /etc/xen/Elastix

    Code:
    name = "ELASTIX"
    memory = "1000"
    disk = [ 'phy:/dev/lvm1/elax11_root,sda1,w',
             'phy:/dev/lvm1/elax11_swap,sda2,w', ]
    vif = [ 'ip=192.168.168.168, bridge=eth0, mac=00:16:3E:6D:F0:D1', ]
    root    = '/dev/sda1 ro'
    UUID = "9ec144aa-1248-cc80-777f-85bd73d8dc68"
    bootloader="/usr/bin/pygrub"
    pci = ['0000:03:00.0', ]
    vcpus=1
    on_reboot = 'restart'
    on_crash = 'destroy'
    on_poweroff = 'destroy'
    extra = ''
    4.- Y por último comprobamos todo luego de reiniciar el servidor con todos los cambios realizados.

    Code:
    $ ssh - root@elax
    root@elax's password:
    Last login: Tue Aug 26 12:26:28 2008 from 192.168.168.200
    
    Welcome to Elastix
    ----------------------------------------------------
    
    For access to the Elastix web GUI use this URL
    http://192.168.168.168
    
    [root@elastix ~]# uname -r
    2.6.18-53.1.19.el5xen
    [root@elastix ~]# free -m
                       total       used       free     shared    buffers     cached
    Mem:               1000        365        634          0         16        147
    -/+ buffers/cache: 201         798
    Swap:              1023          0       1023
    
    Suerte! y mira aver si tambien te da resultados positivos a tíB)
     
  3. solanet

    Joined:
    Aug 30, 2008
    Messages:
    2
    Likes Received:
    0
    Muchas Gracias Rikolen por tu ayuda. Hice los cambios y en principio no tuve resultados, el problema no era el Xen sino la instalación de Elastix. Tuve Exito con la opción Kernel de la instalación de Elastix ejecutando antes de la instalación "linux mem=1024M noprobe".

    Renè
     

Share This Page