Queues not getting displayed on FOP

hema

Joined
Nov 9, 2008
Messages
27
Likes
0
Points
0
#1
Hi All,

I have been trying to show queues on FOP without success. I updated op_button_customs.cfg to display a queue but there is no activity shown after agent logs-in or he gets any call. I restarted FOP server, still problem persists. When drilled down a bit, I found that in retrieve_op_conf_from_mysql.sql, it is referring to "queues_config" table to pull all the queues data. i am using Elastix 1.3 where I did not find this table at all under "asterisk" database. Seems like something is missing here.

Conferences / Extensions are all working fine.

Please suggest how to get all the queues and get it in FOP.
Regards,
-Hema
 

hema

Joined
Nov 9, 2008
Messages
27
Likes
0
Points
0
#2
I got the solution to my issue. The perl file has a bug wherein it is referring to wrong table. To fix the issue change the sql statement to:

Instead of :
$statement = "SELECT extension,descr from queues_config order by extension";

Use:
$statement = "SELECT extension,descr FROM extensions WHERE application = 'Queue' ORDER BY extension";

This has solved my problem. Hope it might be of use for some of you.

Regards,
-Hema
 

hema

Joined
Nov 9, 2008
Messages
27
Likes
0
Points
0
#3
Forgot to mention one more change:
Instead of checking for "queues_config" -> check for "extensions" table.

Hope this helps for others.

Regards,
-Hema
 

Members online

Latest posts

Forum statistics

Threads
30,915
Messages
130,920
Members
17,593
Latest member
dapoalla
Top