queue including a custom extension to outside num

Discussion in 'General' started by jdhatch, Apr 8, 2011.

  1. jdhatch

    Jan 23, 2011
    Likes Received:
    I am trying to allow a queue to have a dynamic include a member that can be easily added and removed to send incoming calls to an outside answering service.

    I am using 3100 as the queue and incoming trunks go straight to it.

    I can get 3100* and then 12345678900# to work w/o a problem (a little cumbersome for the clerical staff)

    I have setup the custom extension 2999 with:
    This device uses custom technology. dial: local/12345678900@outbound-allroutes

    (I am pretty sure the "local/" is my problem but I can not find what to change it to having searched and browsed elastix docs, elastix w/o tears, these forums, FreePBX docs and simply Google)

    If I add to the queue using 3100* and then 2999# the following happens:

    1) if I call 2999 12345678900 does still ring (expected)
    2) if I call 3100 12345678900 does ring (expected)
    3) if I call in on the trunk the other 3100 agents ring but 12345678900 DOES NOT ring (NOT expected)

    Help, please.

    ALSO where do I find the options and syntax for "dial: local/12345678900@outbound-allroutes"

    Thanks, Jason
  2. jgutierrez

    Feb 28, 2008
    Likes Received:
    What I understand from your question, is that you would like a mechanism to forward inbound calls into your queues into an external number that plays back a message?

    If that is what you want, I will recommend you to use "Day/Night" function, so when on "day" it will go into your queue, and when in "night" mode, it will go into a misc destination that will dial to your external number.
    If this is what you want to do, then, the inbound route must go into your "Day/Night" feature.

    But if you want to do it automatically, what you can use is a time condition, that way, if during the working hours a call comes in, it will go into your queue, else it will go into your misc destination.
    Same as before, the inbound route should go into the time condition feature.

Share This Page