PSTN or Elastix!

Discussion in 'General' started by bogzz, Oct 22, 2009.

  1. bogzz

    Joined:
    Oct 22, 2009
    Messages:
    3
    Likes Received:
    0
    hello all!

    i nid some help on my configuration. i am new and dont knwo if this kind of scenario already exist.

    i have 4 trunklines and 1 pilot number. if the 2 numbers is already engaged, the succeding 2 number will just give keep on ringing. i also have installed IVR. any help out there.

    thank you. and more to Eleastix People.
     
  2. unikbit

    Joined:
    Oct 5, 2008
    Messages:
    84
    Likes Received:
    0
    Elastix ver?
    do you have a card with 4 fxo or what else you use.Openvox card? please specify
    list the config of your inbound route

    Virtual Assistant
     
  3. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    bogzz,
    Explain in more details what you want or what you have... I have understood the following:
    * You have 4 analog lines
    * You have configured an IVR
    If you have grouped your lines into a PBX (your telephone company does this job), if the first two lines are busy, and if you call again to your pbx number, then it should answer the IVR on elastix, if it does not, then check the following:

    1. Are you sure that the 4 lines are in one PBX (check this with your telephone company)
    2. Check if the other lines are connected into your card
    3. Check if the other ports are enabled
    4. Check if the other ports are configured
    5. Check if you have configured the inbound route for your other analog lines

    If you just get a ring tone, then the lines are not integrated with your elastix
     
  4. bogzz

    Joined:
    Oct 22, 2009
    Messages:
    3
    Likes Received:
    0
    sir,

    yes, i have 4 analog lines but configure/grouped as trunklines. and one of the line is the pilot no. (6000-pilot number, 6086, 6087, 6088). when i call the pilot number, ivr will answer, then another call, ivr will likewise answer, but on the third call, i only hear a ringing sound, the ivr did not engaged my call. then i tried using another pon n call another line, it will keep on ringing. which is supposedly IVR will be responsible to asnwer then forward it to the designated recipient.

    per my inquiry with the systems integrator all has been configured. byw, am using ver 1.4.24 for asterisk 1.5.2-2 and for elastix running on cisco media convergence server 7835. hehehe. thank you.
     
  5. Bob

    Bob

    Joined:
    Nov 4, 2007
    Messages:
    2,400
    Likes Received:
    1
    There is your problem right there...Cisco is not reliable enough for and Elastix system (Joking):laugh:

    But back to the problem at hand. I assume when you say System Integrator, you are referring to the Carrier that setup the lines?? The one golden rule is never accept it as the truth. I am not saying it is always the case, but a lot of times, they fail to do their job properly.

    From this side, it sounds like a few possibilities and the tests

    1) The Carrier has implemented the "line hunt" however the third number they have in the line-hunt is incorrect and ringing another number that is not associated with your 4 lines.

    Find 4 phones and test full functionality including the rollover when a line is in use. No simple way about it, got to be done

    2) You have a faulty port on the 4 port analog card (or faulty cable). Is the call getting to the Elastix system??

    Test, engage the Asterisk CLI (asterisk -r -vvvvvvvvv)and watch it live when you make the third call (and fourth), does Asterisk show the call coming through (e.g. show the zaptel/Dahdi port being activated.

    3) The third line is dead...

    Tests from number will confirm if it is dead.


    I know this is basics 101, and you may have done these tests already, but if this is the case, you need to be clear with the information, otherwise people are taking guesses (and since there are no prizes - most people won't play).

    I will admit, I have watched this thread, but because some base information was not there, I did not reply earlier (also flat out working).

    Regards

    Bob
     
  6. bogzz

    Joined:
    Oct 22, 2009
    Messages:
    3
    Likes Received:
    0
    sirs,

    i triedcal;ling all the 4 lines sat. and it was ok. all the four lines were functioning as expected. thank you. then another problem came out. if a call is received from PSTN, a abnormal sound that could make u a little bit irritating as it is very annoying to hear but only on our line. the pstn caller could not hear the distorted audio. thank you again.

    also, i have this cisco gateway with 4 units of FXS AND WITH 4 PORTS each. would it be posible for me to utilized this appliance the way it was utilized when i was still running on cisco call manager? can fxs be used instead of fxo ? thank you again.
     

Share This Page