Provisioning cisco 7940 on elastic 2.02 x64

Discussion in 'General' started by ibawany, Oct 25, 2010.

  1. ibawany

    Oct 24, 2010
    Likes Received:
    I am having the same problem on the 2.02 x64 stable as reported on the issues number 245 and 255 in your bug tracker. I have cisco 7940 phones with SIP firmware 8.8 and after I create 2 extensions and use endpoint configuration to assign the extensions to the discovered phones, the phones pickup the configuration from tftp and you can see the name appear on the cisco phones but I cannot dial between extensions, cant dial voicemail, *65 does not work.

    I get the following on the cli>
    == Using SIP RTP TOS bits 184
    == Using SIP RTP CoS mark 5

    nothing else happens. When I do a Show sip registry I get undefined and 2 offlines in the monitor.

    I am trying to replace a 35 phone druid OSE 2.01 for obvious reasons that druid is dead. Elastix seemed to have the best intrface and maturity from all my research and I need to do a migration quick because of all the silly bugs in druid that have not been addressed over the last year.

    I already yum updated freepbx to the lastest version and its the same result. Where do the extensions get defined in Elastix. Do they get called from custom conf files because I cant see them in extensions.conf or sip.conf. However dialplan show from cli lists them.

    If you need me to post my conf files let me know which ones and I will.
  2. vperez69

    Sep 2, 2010
    Likes Received:
    Hi there.

    I do not use the endpoint configurator to provision my Cisco Phone. I simply place my *.cnf files in /tftpboot. The phone itself is configured to loos for as its alternate TFTP server, and when you reboot the phone, it loads its configs from the elastix server, and it works fantastic.
  3. ibawany

    Oct 24, 2010
    Likes Received:
    Thanks for the reply. We are not having problems with the phone gettng the configuration from tftp. We already have option 66 setup in DHCP and after the endpoint configuration is done the phones do get the config from the tftp server and appear to be configured. If you go through the settings menu they have everything filled in correctly.

    What we are having issues with is that the phones dont register with the PBX and are unable to call each others extensions or voicemail or *65. Just like issue 245 and 255 in the bug trakker.

    Its not even clear what the solution is for issue 245 and 255. I have already updated the free PBX to the newest one by yum update freepbx.

    Anyone know why phones are not registering to the PBX?

  4. vperez69

    Sep 2, 2010
    Likes Received:
    Is there a little "X" by the assigned extension? Or does the phone 'think' its properly registered?
  5. vperez69

    Sep 2, 2010
    Likes Received:
    Reason I ask is that when I was configuring my phone, it was a real pain in the neck. As long as that "x" was by the extension, the phone wouldn't work right.

    There are two relevant files: SIP[MAC].cnf and SIPDefault.cnf. SIP[MAC] is easy, just make sure you fillout line1 name, shortname, displayname and authname with your extension, and the password must match your extension. SIPDefault is where the magic happens.

    # Proxy Server

    proxy1_address: ""
    proxy2_address: ""
    proxy3_address: ""
    proxy4_address: ""
    proxy5_address: ""
    proxy6_address: ""

    # Proxy Server Port (default - 5060)

    # Emergency Proxy info
    proxy_emergency: ""
    proxy_emergency_port: "5060"

    # Backup Proxy info
    proxy_backup: ""
    proxy_backup_port: "5060"

    # Outbound Proxy info
    # PERSONAL NOTE: If you only define 1 PBX, its IP must go here, otherwise, it will not
    # register. If you have two or more (like I do), then leave it blank, otherwise it will
    # only register with the one listed.
    outbound_proxy: ""
    outbound_proxy_port: "5060"

    # NAT/Firewall Traversal
    # Personal Note: Most docs I read said that NAT should be no. For me, it was needed.
    nat_enable: "YES"
    nat_address: "<router's ip>"
    voip_control_port: "5061"
    start_media_port: "16384"
    end_media_port: "32766"
    nat_received_processing: "0"

    # Proxy Registration (0-disable (default), 1-enable)
    proxy_register: "1"

    # Phone Registration Expiration [1-3932100 sec] (Default - 3600)
    timer_register_expires: "3600"

    # Codec for media stream (g711ulaw (default), g711alaw, g729)
    preferred_codec: "g711ulaw"

    # TOS bits in media stream [0-5] (Default - 5)
    tos_media: "5"

    # Enable VAD (0-disable (default), 1-enable)
    enable_vad: "0"

    # Allow for the bridge on a 3way call to join remaining parties upon hangup
    cnf_join_enable: "1" ; 0-Disabled, 1-Enabled (default)

    # Allow Transfer to be completed while target phone is still ringing
    semi_attended_transfer: "0" ; 0-Disabled, 1-Enabled (default)

    # Telnet Level (enable or disable the ability to telnet into this phone
    telnet_level: 1"" ; 0-Disabled (default), 1-Enabled, 2-Privileged

    # Inband DTMF Settings (0-disable, 1-enable (default))
    dtmf_inband: "0"

    # Out of band DTMF Settings (none-disable, avt-avt enable (default), avt_always - always avt )
    dtmf_outofband: "avt"

    # DTMF dB Level Settings (1-6dB down, 2-3db down, 3-nominal (default), 4-3db up, 5-6dB up)
    dtmf_db_level: "3"

    # SIP Timers
    timer_t1: "1500" ; Default 1500 msec
    timer_t2: "15000" ; Default 15 sec
    sip_retx: "10" ; Default 11
    sip_invite_retx: "6" ; Default 7
    timer_invite_expires: "360" ; Default 360 sec

    # Setting for Message speeddial to UOne box
    messages_uri: "8000"

    #********* Release 2 new config parameters **********

    # TFTP Phone Specific Configuration File Directory
    tftp_cfg_dir: "./"

    # Time Server
    sntp_mode: "unicast"
    sntp_server: ""
    time_zone: "EST"
    dst_offset: "0"
    dst_start_month: "Mar"
    dst_start_day: ""
    dst_start_day_of_week: "Sun"
    dst_start_week_of_month: "2"
    dst_start_time: "02"
    dst_stop_month: "Nov"
    dst_stop_day: ""
    dst_stop_day_of_week: "Sunday"
    dst_stop_week_of_month: "1"
    dst_stop_time: "2"
    dst_auto_adjust: "0"

    # Do Not Disturb Control (0-off, 1-on, 2-off with no user control, 3-on with no user control)
    dnd_control: "0" ; Default 0 (Do Not Disturb feature is off)

    # Caller ID Blocking (0-disabled, 1-enabled, 2-disabled no user control, 3-enabled no user control)
    callerid_blocking: "0" ; Default 0 (Disable sending all calls as anonymous)

    # Anonymous Call Blocking (0-disbaled, 1-enabled, 2-disabled no user control, 3-enabled no user control)
    anonymous_call_block: "0" ; Default 0 (Disable blocking of anonymous calls)

    # Call Waiting (0-disabled, 1-enabled, 2-disabled with no user control, 3-enabled with no user control)
    call_waiting: "0" ; Default 1 (Call Waiting enabled)

    # DTMF AVT Payload (Dynamic payload range for AVT tones - 96-127)
    dtmf_avt_payload: "101" ; Default 100

    # XML file that specifies the dialplan desired
    dial_template: "dialplan"

    # Network Media Type (auto, full100, full10, half100, half10)
    network_media_type: "auto"

    #Autocompletion During Dial (0-off, 1-on [default])
    autocomplete: "1"

    #Time Format (0-12hr, 1-24hr [default])
    time_format_24hr: "0"

    # URL for external Phone Services
    services_url: "<cisco directory on elastix>"

    # URL for external Directory location
    directory_url: "<cisco directory on elastix>"

    # URL for branding logo
    logo_url: "<cisco directory on elastix>"
  6. ibawany

    Oct 24, 2010
    Likes Received:
    Problem solved.

    You have to set the extensions in Freepbx to NAT=never and Qualify = yes.

    As soon as that was done, the cisco registered right away.

  7. vperez69

    Sep 2, 2010
    Likes Received:
    Interesting. I actually saw that as one of several sample configs that hadn't worked for me. On my phone, setting the NAT to yes and the nat_address to my router's ip, is what (I think) got it going.
  8. theboss

    Dec 5, 2008
    Likes Received:
    Hi vperez69,

    I have cisco WIP310 v5.0.12, i was trying to do provisioning but so far no success.
    Please, can you give some tips how can i perform this and some files example required for cisco to provisioning over Elastix.

    I also have problem with the provisioning of thomson ip phones st2022 and st2030.


Share This Page