Proper configuration for 5 T1 E&M Wink?

Bryant

Joined
Oct 22, 2008
Messages
9
Likes
0
Points
0
#1
Im having some trouble setting up out T1 using E&M signaling. Here is a my current configuration:

zaptel.conf

# Autogenerated by /usr/local/sbin/genzaptelconf -- do not hand edit
# Zaptel Configuration File
#
# This file is parsed by the Zaptel Configurator, ztcfg
#

# It must be in the module loading order


# Span 1: TE4/0/1 "T4XXP (PCI) Card 0 Span 1" (MASTER) B8ZS/ESF ClockSource
span=1,1,0,esf,b8zs
# termtype: te
e&m=1-24

# Span 2: TE4/0/2 "T4XXP (PCI) Card 0 Span 2" B8ZS/ESF
span=2,2,0,esf,b8zs
# termtype: te
e&m=25-48

# Span 3: TE4/0/3 "T4XXP (PCI) Card 0 Span 3" B8ZS/ESF
span=3,3,0,esf,b8zs
# termtype: te
e&m=49-72

# Span 4: TE4/0/4 "T4XXP (PCI) Card 0 Span 4" B8ZS/ESF
span=4,4,0,esf,b8zs
# termtype: te
e&m=73-96

# Span 5: TE4/1/1 "T4XXP (PCI) Card 1 Span 1" B8ZS/ESF
span=5,5,0,esf,b8zs
# termtype: te
e&m=97-120

# Span 6: TE4/1/2 "T4XXP (PCI) Card 1 Span 2" B8ZS/ESF RED
span=6,6,0,esf,b8zs
# termtype: te
e&m=

# Span 7: TE4/1/3 "T4XXP (PCI) Card 1 Span 3" B8ZS/ESF RED
span=7,7,0,esf,b8zs
# termtype: te
bchan=145-167
e&m=

# Span 8: TE4/1/4 "T4XXP (PCI) Card 1 Span 4" B8ZS/ESF RED
span=8,8,0,esf,b8zs
# termtype: te
e&m=

# Global data

loadzone = us
defaultzone = us


Spans 6,7,& 8 are not in use.


zapata.conf

[trunkgroups]

[channels]
context=zaptel-incoming
switchtype=national
usecallerid=yes
hidecallerid=no
callwaiting=yes
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=yes
transfer=yes
canpark=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=yes
rxgain=0.0
txgain=0.0
group=1
callgroup=1
pickupgroup=1
immediate=no
switchtype = national
signalling = em_w
group = 1
channel => 1-24,25-48,49-72,73-96,97-120

;Uncomment these lines if you have problems with the disconection of your analog lines
;busydetect=yes
;busycount=3


immediate=no

#include zapata_additional.conf
#include zapata-channels.conf


Also I need some dirrection on setting up the Trunks with my set up. I set up 1 zap trunk so far basically allowing everything out "91NXXXXXXXXX"

But I am still getting this as a result of making a outbound call:

-- Executing [916306695365@from-internal:1] Macro("SIP/6003-091b9cf0", "user-callerid|SKIPTTL|") in new stack
-- Executing [s@macro-user-callerid:1] NoOp("SIP/6003-091b9cf0", "user-callerid: Bryant Smith 6003") in new stack
-- Executing [s@macro-user-callerid:2] Set("SIP/6003-091b9cf0", "AMPUSER=6003") in new stack
-- Executing [s@macro-user-callerid:3] GotoIf("SIP/6003-091b9cf0", "0?report") in new stack
-- Executing [s@macro-user-callerid:4] ExecIf("SIP/6003-091b9cf0", "1|Set|REALCALLERIDNUM=6003") in new stack
-- Executing [s@macro-user-callerid:5] NoOp("SIP/6003-091b9cf0", "REALCALLERIDNUM is 6003") in new stack
-- Executing [s@macro-user-callerid:6] Set("SIP/6003-091b9cf0", "AMPUSER=1001") in new stack
-- Executing [s@macro-user-callerid:7] Set("SIP/6003-091b9cf0", "AMPUSERCIDNAME=Agent_Test") in new stack
-- Executing [s@macro-user-callerid:8] GotoIf("SIP/6003-091b9cf0", "0?report") in new stack
-- Executing [s@macro-user-callerid:9] Set("SIP/6003-091b9cf0", "AMPUSERCID=1001") in new stack
-- Executing [s@macro-user-callerid:10] Set("SIP/6003-091b9cf0", "CALLERID(all)="Agent_Test" <1001>") in new stack
-- Executing [s@macro-user-callerid:11] Set("SIP/6003-091b9cf0", "REALCALLERIDNUM=1001") in new stack
-- Executing [s@macro-user-callerid:12] ExecIf("SIP/6003-091b9cf0", "0|Set|CHANNEL(language)=") in new stack
-- Executing [s@macro-user-callerid:13] NoOp("SIP/6003-091b9cf0", "TTL: ARG1: SKIPTTL") in new stack
-- Executing [s@macro-user-callerid:14] GotoIf("SIP/6003-091b9cf0", "1?continue") in new stack
-- Goto (macro-user-callerid,s,23)
-- Executing [s@macro-user-callerid:23] NoOp("SIP/6003-091b9cf0", "Using CallerID "Agent_Test" <1001>") in new stack
-- Executing [916306695365@from-internal:2] Set("SIP/6003-091b9cf0", "_NODEST=") in new stack
-- Executing [916306695365@from-internal:3] Macro("SIP/6003-091b9cf0", "record-enable|1001|OUT|") in new stack
-- Executing [s@macro-record-enable:1] GotoIf("SIP/6003-091b9cf0", "0?2:4") in new stack
-- Goto (macro-record-enable,s,4)
-- Executing [s@macro-record-enable:4] AGI("SIP/6003-091b9cf0", "recordingcheck|20081114-115530|1226685330.2") in new stack
-- Launched AGI Script /var/lib/asterisk/agi-bin/recordingcheck
recordingcheck|20081114-115530|1226685330.2: Outbound recording enabled.
recordingcheck|20081114-115530|1226685330.2: CALLFILENAME=OUT-1001-1226685330.2
-- AGI Script recordingcheck completed, returning 0
-- Executing [s@macro-record-enable:999] MixMonitor("SIP/6003-091b9cf0", "OUT-1001-1226685330.2.wav") in new stack
-- Executing [916306695365@from-internal:4] Macro("SIP/6003-091b9cf0", "dialout-trunk|2|1630XXXXXXX||") in new stack
-- Executing [s@macro-dialout-trunk:1] Set("SIP/6003-091b9cf0", "DIAL_TRUNK=2") in new stack
-- Executing [s@macro-dialout-trunk:2] ExecIf("SIP/6003-091b9cf0", "0|Authenticate|") in new stack
-- Executing [s@macro-dialout-trunk:3] GotoIf("SIP/6003-091b9cf0", "0?disabletrunk|1") in new stack
-- Executing [s@macro-dialout-trunk:4] Set("SIP/6003-091b9cf0", "DIAL_NUMBER=16306695365") in new stack
-- Executing [s@macro-dialout-trunk:5] Set("SIP/6003-091b9cf0", "DIAL_TRUNK_OPTIONS=tr") in new stack
-- Executing [s@macro-dialout-trunk:6] Set("SIP/6003-091b9cf0", "GROUP()=OUT_2") in new stack
-- Executing [s@macro-dialout-trunk:7] GotoIf("SIP/6003-091b9cf0", "0?nomax") in new stack
-- Executing [s@macro-dialout-trunk:8] GotoIf("SIP/6003-091b9cf0", "0?chanfull") in new stack
-- Executing [s@macro-dialout-trunk:9] GotoIf("SIP/6003-091b9cf0", "0?skipoutcid") in new stack
-- Executing [s@macro-dialout-trunk:10] Set("SIP/6003-091b9cf0", "DIAL_TRUNK_OPTIONS=") in new stack
-- Executing [s@macro-dialout-trunk:11] Macro("SIP/6003-091b9cf0", "outbound-callerid|2") in new stack
-- Executing [s@macro-outbound-callerid:1] GotoIf("SIP/6003-091b9cf0", "1?start") in new stack
-- Goto (macro-outbound-callerid,s,3)
-- Executing [s@macro-outbound-callerid:3] NoOp("SIP/6003-091b9cf0", "REALCALLERIDNUM is 1001") in new stack
-- Executing [s@macro-outbound-callerid:4] GotoIf("SIP/6003-091b9cf0", "1?normcid") in new stack
-- Goto (macro-outbound-callerid,s,9)
-- Executing [s@macro-outbound-callerid:9] Set("SIP/6003-091b9cf0", "USEROUTCID=") in new stack
-- Executing [s@macro-outbound-callerid:10] Set("SIP/6003-091b9cf0", "EMERGENCYCID=") in new stack
-- Executing [s@macro-outbound-callerid:11] Set("SIP/6003-091b9cf0", "TRUNKOUTCID=") in new stack
-- Executing [s@macro-outbound-callerid:12] GotoIf("SIP/6003-091b9cf0", "1?trunkcid") in new stack
-- Goto (macro-outbound-callerid,s,16)
-- Executing [s@macro-outbound-callerid:16] GotoIf("SIP/6003-091b9cf0", "1?usercid") in new stack
-- Goto (macro-outbound-callerid,s,18)
-- Executing [s@macro-outbound-callerid:18] GotoIf("SIP/6003-091b9cf0", "1?report") in new stack
-- Goto (macro-outbound-callerid,s,22)
-- Executing [s@macro-outbound-callerid:22] NoOp("SIP/6003-091b9cf0", "CallerID set to "Agent_Test" <1001>") in new stack
-- Executing [s@macro-dialout-trunk:12] AGI("SIP/6003-091b9cf0", "fixlocalprefix") in new stack
-- Launched AGI Script /var/lib/asterisk/agi-bin/fixlocalprefix
== Begin MixMonitor Recording SIP/6003-091b9cf0
-- AGI Script fixlocalprefix completed, returning 0
-- Executing [s@macro-dialout-trunk:13] Set("SIP/6003-091b9cf0", "OUTNUM=1630XXXXXXX") in new stack
-- Executing [s@macro-dialout-trunk:14] Set("SIP/6003-091b9cf0", "custom=ZAP/1") in new stack
-- Executing [s@macro-dialout-trunk:15] GotoIf("SIP/6003-091b9cf0", "1?gocall") in new stack
-- Goto (macro-dialout-trunk,s,17)
-- Executing [s@macro-dialout-trunk:17] Macro("SIP/6003-091b9cf0", "dialout-trunk-predial-hook|") in new stack
-- Executing [s@macro-dialout-trunk:18] GotoIf("SIP/6003-091b9cf0", "0?bypass|1") in new stack
-- Executing [s@macro-dialout-trunk:19] GotoIf("SIP/6003-091b9cf0", "0?customtrunk") in new stack
-- Executing [s@macro-dialout-trunk:20] Dial("SIP/6003-091b9cf0", "ZAP/1/1630XXXXXXX|300|") in new stack
== Everyone is busy/congested at this time (1:0/0/1)
-- Executing [s@macro-dialout-trunk:21] Goto("SIP/6003-091b9cf0", "s-CHANUNAVAIL|1") in new stack
-- Goto (macro-dialout-trunk,s-CHANUNAVAIL,1)
-- Executing [s-CHANUNAVAIL@macro-dialout-trunk:1] GotoIf("SIP/6003-091b9cf0", "1?noreport") in new stack
-- Goto (macro-dialout-trunk,s-CHANUNAVAIL,3)
-- Executing [s-CHANUNAVAIL@macro-dialout-trunk:3] NoOp("SIP/6003-091b9cf0", "TRUNK Dial failed due to CHANUNAVAIL - failing through to other trunks") in new stack
-- Executing [91630XXXXXXX@from-internal:5] Macro("SIP/6003-091b9cf0", "outisbusy|") in new stack
-- Executing [s@macro-outisbusy:1] Playback("SIP/6003-091b9cf0", "all-circuits-busy-now|noanswer") in new stack
-- <SIP/6003-091b9cf0> Playing 'all-circuits-busy-now' (language 'en')
-- Executing [s@macro-outisbusy:2] Playback("SIP/6003-091b9cf0", "pls-try-call-later|noanswer") in new stack
-- <SIP/6003-091b9cf0> Playing 'pls-try-call-later' (language 'en')
-- Executing [s@macro-outisbusy:3] Macro("SIP/6003-091b9cf0", "hangupcall") in new stack
-- Executing [s@macro-hangupcall:1] ResetCDR("SIP/6003-091b9cf0", "w") in new stack
-- Executing [s@macro-hangupcall:2] NoCDR("SIP/6003-091b9cf0", "") in new stack
-- Executing [s@macro-hangupcall:3] GotoIf("SIP/6003-091b9cf0", "1?skiprg") in new stack
-- Goto (macro-hangupcall,s,6)
-- Executing [s@macro-hangupcall:6] GotoIf("SIP/6003-091b9cf0", "1?skipblkvm") in new stack
-- Goto (macro-hangupcall,s,9)
-- Executing [s@macro-hangupcall:9] GotoIf("SIP/6003-091b9cf0", "1?theend") in new stack
-- Goto (macro-hangupcall,s,11)
-- Executing [s@macro-hangupcall:11] Hangup("SIP/6003-091b9cf0", "") in new stack
== Spawn extension (macro-hangupcall, s, 11) exited non-zero on 'SIP/6003-091b9cf0' in macro 'hangupcall'
== Spawn extension (macro-hangupcall, s, 11) exited non-zero on 'SIP/6003-091b9cf0' in macro 'outisbusy'
== Spawn extension (macro-hangupcall, s, 11) exited non-zero on 'SIP/6003-091b9cf0'
== End MixMonitor Recording SIP/6003-091b9cf0
athena*CLI>


Im sure I messed up something good here as I have never worked with anything except PRI's
 

Bryant

Joined
Oct 22, 2008
Messages
9
Likes
0
Points
0
#2
Any one have any ideas? Still not going in or out. I called my tel co Cimco. And he tried to manualy bring the T1 back up but when I make an outgoing call the 1st channel goes down. What do I have wrong in my settings?
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,887
Members
17,565
Latest member
omarmenichetti
Top