Problems with web gui after yum update

Discussion in 'General' started by possebon, Mar 13, 2009.

  1. possebon

    Joined:
    Dec 26, 2008
    Messages:
    46
    Likes Received:
    0
    Hi all,

    I faced this situation twice, on the same machine. The first time I though I could did something wrong and messed the Elastix server, but this time, I did not changed, just run the yum update.

    After doing this, I did a reboot on my server, and after rebooting, I'm unable to access the web gui.

    Anyone already faced this too?

    Any clue to fix it? (The first time I reinstalled the whole server, but really don't wanna do this again)

    Best regards

    Fernando
     
  2. possebon

    Joined:
    Dec 26, 2008
    Messages:
    46
    Likes Received:
    0
    An additional information, what happens is the page keeps loading.... never ends
     
  3. rafael

    Joined:
    May 14, 2007
    Messages:
    1,454
    Likes Received:
    1
    Hi possebon,

    Welcome to the Elstix community and hope to see you more often around here :).

    We would need more information. From what version of Elastix to what version are you trying to update? Are you tryin to use the beta repositories?

    Best regards,

    Rafael
     
  4. possebon

    Joined:
    Dec 26, 2008
    Messages:
    46
    Likes Received:
    0
    Hi rafael,

    Thanks for reply.

    I believe that I'm not using the beta repositories, because I did not changed anything on yum repo.

    I downloaded the Elastix 1.3 ISO (stable version), and just applied the updates.

    I've been using Trixbox for 3 years, and 2 months ago discovered Elastix and I decided to try it :)

    Thanks again for attention and I hope contribute a little with Elastix community too.

    Best regards,

    Fernando
     
  5. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    I had similar problems some time ago and I solved them updating the perl modules.
     
  6. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    Have a look at the httpd error logs and you'll find the problems.
    In my case, it was the perl modules, but your problem might be different.
     
  7. possebon

    Joined:
    Dec 26, 2008
    Messages:
    46
    Likes Received:
    0
    Hi ramoncio,

    Thanks for the tip.

    Seems that I have something wrong with Apache. I think that something went wrong on the update and for some reason, the FreePBX has stopped working.

    In my case there was nothing related with Perl (at least there was no reference on httpd logs). I found a lot of entries related with symolic links missing

    Actually I could fix it, reinstalling the FreePBX.

    I used this:

    http://www.freepbx.org/support/document ... our-system

    Only the first par of this article.

    Now its working fine.

    Thanks for the clue.

    Best regards,

    Fernando
     
  8. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    I'm glad to hear that!
     
  9. Patrick_elx

    Joined:
    Dec 14, 2008
    Messages:
    1,120
    Likes Received:
    0
    I had the same kind of problem.

    After a (failed ?) yum update on a very remote location the web gui broke.

    Thanks to this thread, I've looked in the httpd log and I found that it was a pear library problem.

    And for sure, when I looked into the pear directory, I was missing important files.

    I've copied back to the folder from another elastix box and everything worked again.

    I'm glad I won't have to coach over the phone how to reinstall from scratch a whole system...
     
  10. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    Hi Patrick,
    I'm glad to hear this helped you!
     
  11. vabue

    Joined:
    Sep 15, 2008
    Messages:
    4
    Likes Received:
    0
    I have the same problem. I've tried to reinstall FreePBX but it haven't helped.

    cat /val/log/httpd/ssl_error_log

    Any suggestions?
     
  12. slelevier

    Joined:
    Apr 7, 2009
    Messages:
    1
    Likes Received:
    0
    Same problem for me. pear install DB has solved the problem. Otherwise, the file "extensions_additional.conf had been crushed, we have recreated a sip extension via the Elastix gui and there, the file has been regenerated with all extensions.
     
  13. wasi.syed

    Joined:
    Jan 7, 2011
    Messages:
    94
    Likes Received:
    0
    Hello,

    Even we are facing elastix gui login prblem,after updating freepbx many component.

    following error showing on freepbx console.
    Asterisk (Ver. 1.6.2.13): Summary
    ASTERISK MANAGER ERROR

    The module was unable to connect to the Asterisk manager.
    Make sure Asterisk is running and your manager.conf settings are proper.

    regdds..wasi
     
  14. mahpayma

    Joined:
    Sep 24, 2010
    Messages:
    27
    Likes Received:
    0
    Hi,
    I had the same problem after updating using yum update elastix(from 2.0.3 to 2.0.4B4)
    only the web login page loaded and after entering username and pass I got a blank page !!!!!
    can someone tell me the reason and how can I solve this problem.
     
  15. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    Execute and paste the output for:
    /var/lib/asterisk/bin/retrieve_conf
     
  16. mahpayma

    Joined:
    Sep 24, 2010
    Messages:
    27
    Likes Received:
    0
    [root@foneteb ~]# /var/lib/asterisk/bin/retrieve_conf
    Checking for PEAR DB..OK
    Checking for PEAR Console::Getopt..OK
    Checking for /etc/amportal.conf ..OK
    Bootstrapping /etc/amportal.conf ..OK
    Parsing /etc/amportal.conf ..OK
    Parsing /etc/asterisk/asterisk.conf ..OK
    Connecting to database..OK
    Connecting to Asterisk manager interface..OK
    Fri, 10 Jun 2011 00:24:58 +0430 - Got event.. fullybooted
    Fri, 10 Jun 2011 00:24:58 +0430 - No event handler for event 'fullybooted'
    PHP Fatal error: Call to undefined function core_did_list() in /var/www/html/admin/modules/blacklist/functions.inc.php on line 179
     
  17. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    Seems to me that the issue is your blacklist module on freepbx, go to the unembedded section (ip/admin) and then to module admin, and try to repair or uninstall that module.
     
  18. mahpayma

    Joined:
    Sep 24, 2010
    Messages:
    27
    Likes Received:
    0
    I uninstalled the Blacklist module and reboot the machine, but still unable to to see anything in my web gui
     
  19. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    and if you execute again the previous command what do you get??
     
  20. mahpayma

    Joined:
    Sep 24, 2010
    Messages:
    27
    Likes Received:
    0
    Checking for PEAR DB..OK
    Checking for PEAR Console::Getopt..OK
    Checking for /etc/amportal.conf ..OK
    Bootstrapping /etc/amportal.conf ..OK
    Parsing /etc/amportal.conf ..OK
    Parsing /etc/asterisk/asterisk.conf ..OK
    Connecting to database..OK
    Connecting to Asterisk manager interface..OK
    Added to globals: ASTETCDIR = /etc/asterisk
    Added to globals: ASTMODDIR = /usr/lib64/asterisk/modules
    Added to globals: ASTVARLIBDIR = /var/lib/asterisk
    Added to globals: ASTAGIDIR = /var/lib/asterisk/agi-bin
    Added to globals: ASTSPOOLDIR = /var/spool/asterisk
    Added to globals: ASTRUNDIR = /var/run/asterisk
    Added to globals: ASTLOGDIR = /var/log/asterisk
    Added to globals: CWINUSEBUSY = true
    Added to globals: AMPMGRUSER = admin
    Added to globals: AMPMGRPASS = elastix456
    Added to globals: AMPDBENGINE = mysql
    Added to globals: AMPDBHOST = localhost
    Added to globals: AMPDBNAME = asterisk
    Added to globals: AMPDBUSER = asteriskuser
    Added to globals: AMPDBPASS = **********
    Notice: no Parking Lots defined
    Notice: no sip trunks defined
    Notice: no iax trunks defined
    Notice: no AMP Users defined
    Please update your modules and reload Asterisk by browsing to your server.
     

Share This Page