problems with calls provider azroute

Discussion in 'General' started by fabiotrooper, Mar 5, 2011.

  1. fabiotrooper

    Joined:
    Mar 5, 2011
    Messages:
    2
    Likes Received:
    0
    I'm having problems with this provider I have done all kinds of configurations over the call does not complete. This provider uses for authentication ip so do not need strings to record it using only this configuration

    host = 173.236.91.242
    dtmfmode = rfc2833
    dtmf = rfc2833
    type = friend
    context = from-trunk
    insecure = very
    nat = never
    allow = all

    This provider supports only the g729 codec as you can see it has also installed

    core show translation
    Translation times between formats (in milliseconds) for one second of d ata
    Source Format (Rows) Destination Format (Columns)

    g723 gsm ulaw alaw g726aal2 adpcm slin lpc10 g729 speex ilbc g726 g722
    g723 - 2 2 2 2 2 1 2 3 9 - 2 2
    gsm 40 - 2 2 2 2 1 2 3 9 - 2 2
    ulaw 40 2 - 1 2 2 1 2 3 9 - 2 2
    alaw 40 2 1 - 2 2 1 2 3 9 - 2 2
    g726aal2 40 2 2 2 - 2 1 2 3 9 - 1 2
    adpcm 40 2 2 2 2 - 1 2 3 9 - 2 2
    slin 39 1 1 1 1 1 - 1 2 8 - 1 1
    lpc10 40 2 2 2 2 2 1 - 3 9 - 2 2
    g729 40 2 2 2 2 2 1 2 - 9 - 2 2
    speex 98 60 60 60 60 60 59 60 61 - - 60 60
    ilbc - - - - - - - - - - - - -
    g726 40 2 2 2 1 2 1 2 3 9 - - 2
    g722 40 2 2 2 2 2 1 2 3 9 - 2 -


    and also has a softphone that has this codec
    but when I call to any number the softphone when the other side answers the call remains silent and side softphone appears as if I was still dialing in and stays that way and not beep when it appears before calling the other side meet

    My elastix this in a fixed IP with no firewall or nat is directly connected to internet via a dedicated link

    Please could someone help me, I have no more ideas of what might be wrong :unsure:
     
  2. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    2 mistakes heres to clarify configs
    host = 173.236.91.242
    dtmfmode = rfc2833
    dtmf = rfc2833-+----------------this line is broken so dont work delete it
    type = friend
    context = from-trunk
    insecure = very
    nat = yes --------- to put nat in yes does not modify in your case the headers in sip protocol ip address is the same as sip server address
    allow = all ------------its redundant...as your provider does only g729 option all brokes everything asterisk sucks in negociating codecs
    disallow=all
    allow=g729 is the correct line

    see ya
     
  3. fabiotrooper

    Joined:
    Mar 5, 2011
    Messages:
    2
    Likes Received:
    0
    i modify the settings but the problem persists


    thanks for the help

    you have any other ideas? :(
     
  4. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    do you have sip traces?? invite? register, asterisk cli?
     

Share This Page