Probleme CallerID (num)

titilim

Joined
Mar 6, 2009
Messages
13
Likes
0
Points
0
#1
Je suis actuellement en phase de test d'un nouvel operateur VOIP

tout fonctionne a merveille sauf que pour un petit detail j'ai un soucis de callerid en effet lorsque je recoit un appel le 0 est tronqué

j'ai essayé d'ajouter ca dans extensions_custom.conf

[from-trunk-custom]
exten => _.,1,Set(CALLERID(num)=0${CALLERID(num)})
exten => _.,n,Goto(from-trunk,${EXTEN},1)

et biensur de modifier mon type de trunk sans succès
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#2
Presque ....
J'ai déjà au à faire ce genre de manip sur un Elastix en frontal derrière à OXE. Il a fallu que je fasse un test si j'ai 4 chiffres (poste interne OXE) ou 9 chiffres (venant de l'opérateur).
 

titilim

Joined
Mar 6, 2009
Messages
13
Likes
0
Points
0
#3
Malgré le fait que j'ai spécifié dans mon trunk un type=from-trunk-custom, lors d'un appel l'appel ne passe pas par cette procedure

Voici la trace d'un appel et la je suis perdu
Code:
    -- Executing [547484730@from-sip-external:1] NoOp("SIP/194.98.81.144-b7a307c8", "Received incoming SIP connection from unknown peer to 547484730") in new stack
    -- Executing [547484730@from-sip-external:2] Set("SIP/194.98.81.144-b7a307c8", "DID=547484730") in new stack
    -- Executing [547484730@from-sip-external:3] Goto("SIP/194.98.81.144-b7a307c8", "s|1") in new stack
    -- Goto (from-sip-external,s,1)
    -- Executing [s@from-sip-external:1] GotoIf("SIP/194.98.81.144-b7a307c8", "1?from-trunk|547484730|1") in new stack
    -- Goto (from-trunk,547484730,1)
    -- Executing [547484730@from-trunk:1] Set("SIP/194.98.81.144-b7a307c8", "__FROM_DID=547484730") in new stack
    -- Executing [547484730@from-trunk:2] Gosub("SIP/194.98.81.144-b7a307c8", "app-blacklist-check|s|1") in new stack
    -- Executing [s@app-blacklist-check:1] LookupBlacklist("SIP/194.98.81.144-b7a307c8", "") in new stack
    -- Executing [s@app-blacklist-check:2] GotoIf("SIP/194.98.81.144-b7a307c8", "0?blacklisted") in new stack
    -- Executing [s@app-blacklist-check:3] Return("SIP/194.98.81.144-b7a307c8", "") in new stack
    -- Executing [547484730@from-trunk:3] ExecIf("SIP/194.98.81.144-b7a307c8", "0 |Set|CALLERID(name)=555126262") in new stack
    -- Executing [547484730@from-trunk:4] Set("SIP/194.98.81.144-b7a307c8", "__CALLINGPRES_SV=allowed_not_screened") in new stack
    -- Executing [547484730@from-trunk:5] SetCallerPres("SIP/194.98.81.144-b7a307c8", "allowed_not_screened") in new stack
    -- Executing [547484730@from-trunk:6] Goto("SIP/194.98.81.144-b7a307c8", "from-did-direct|103|1") in new stack
    -- Goto (from-did-direct,103,1)
    -- Executing [103@from-did-direct:1] Macro("SIP/194.98.81.144-b7a307c8", "exten-vm|103|103") in new stack
    -- Executing [s@macro-exten-vm:1] Macro("SIP/194.98.81.144-b7a307c8", "user-callerid") in new stack
    -- Executing [s@macro-user-callerid:1] Set("SIP/194.98.81.144-b7a307c8", "AMPUSER=555126262") in new stack
    -- Executing [s@macro-user-callerid:2] GotoIf("SIP/194.98.81.144-b7a307c8", "0?report") in new stack
    -- Executing [s@macro-user-callerid:3] ExecIf("SIP/194.98.81.144-b7a307c8", "1|Set|REALCALLERIDNUM=555126262") in new stack
    -- Executing [s@macro-user-callerid:4] Set("SIP/194.98.81.144-b7a307c8", "AMPUSER=") in new stack
    -- Executing [s@macro-user-callerid:5] Set("SIP/194.98.81.144-b7a307c8", "AMPUSERCIDNAME=") in new stack
    -- Executing [s@macro-user-callerid:6] GotoIf("SIP/194.98.81.144-b7a307c8", "1?report") in new stack
    -- Goto (macro-user-callerid,s,11)
    -- Executing [s@macro-user-callerid:11] GotoIf("SIP/194.98.81.144-b7a307c8", "0?continue") in new stack
    -- Executing [s@macro-user-callerid:12] Set("SIP/194.98.81.144-b7a307c8", "__TTL=64") in new stack
    -- Executing [s@macro-user-callerid:13] GotoIf("SIP/194.98.81.144-b7a307c8", "1?continue") in new stack
    -- Goto (macro-user-callerid,s,20)
    -- Executing [s@macro-user-callerid:20] NoOp("SIP/194.98.81.144-b7a307c8", "Using CallerID "555126262" <555126262>") in new stack
    -- Executing [s@macro-exten-vm:2] Set("SIP/194.98.81.144-b7a307c8", "RingGroupMethod=none") in new stack
    -- Executing [s@macro-exten-vm:3] Set("SIP/194.98.81.144-b7a307c8", "VMBOX=103") in new stack
    -- Executing [s@macro-exten-vm:4] Set("SIP/194.98.81.144-b7a307c8", "EXTTOCALL=103") in new stack
    -- Executing [s@macro-exten-vm:5] Set("SIP/194.98.81.144-b7a307c8", "CFUEXT=") in new stack
    -- Executing [s@macro-exten-vm:6] Set("SIP/194.98.81.144-b7a307c8", "CFBEXT=") in new stack
    -- Executing [s@macro-exten-vm:7] Set("SIP/194.98.81.144-b7a307c8", "RT=15") in new stack
    -- Executing [s@macro-exten-vm:8] Macro("SIP/194.98.81.144-b7a307c8", "record-enable|103|IN") in new stack
    -- Executing [s@macro-record-enable:1] GotoIf("SIP/194.98.81.144-b7a307c8", "1?check") in new stack
    -- Goto (macro-record-enable,s,4)
    -- Executing [s@macro-record-enable:4] AGI("SIP/194.98.81.144-b7a307c8", "recordingcheck|20090326-142317|1238073797.10") in new stack
    -- Launched AGI Script /var/lib/asterisk/agi-bin/recordingcheck
  recordingcheck|20090326-142317|1238073797.10: Inbound recording not enabled
    -- AGI Script recordingcheck completed, returning 0
    -- Executing [s@macro-record-enable:5] MacroExit("SIP/194.98.81.144-b7a307c8", "") in new stack
    -- Executing [s@macro-exten-vm:9] Macro("SIP/194.98.81.144-b7a307c8", "dial|15|tr|103") in new stack
    -- Executing [s@macro-dial:1] GotoIf("SIP/194.98.81.144-b7a307c8", "1?dial") in new stack
    -- Goto (macro-dial,s,3)
    -- Executing [s@macro-dial:3] AGI("SIP/194.98.81.144-b7a307c8", "dialparties.agi") in new stack
    -- Launched AGI Script /var/lib/asterisk/agi-bin/dialparties.agi
  dialparties.agi: Starting New Dialparties.agi
  == Parsing '/etc/asterisk/manager.conf': Found
  == Parsing '/etc/asterisk/manager_additional.conf': Found
  == Parsing '/etc/asterisk/manager_custom.conf': Found
  == Manager 'admin' logged on from 127.0.0.1
  dialparties.agi: Caller ID name is '555126262' number is '555126262'
  dialparties.agi: USE_CONFIRMATION:  'FALSE'
  dialparties.agi: RINGGROUP_INDEX:   ''
  dialparties.agi: Methodology of ring is  'none'
    --  dialparties.agi: Added extension 103 to extension map
       >  dialparties.agi: Extension 103 has call screening off
    --  dialparties.agi: Extension 103 cf is disabled
    --  dialparties.agi: Extension 103 do not disturb is disabled
       >  dialparties.agi: extnum 103 has:  cw: 1; hascfb: 0 [] hascfu: 0 []
       >  dialparties.agi: ExtensionState: 0
    --  dialparties.agi: dbset CALLTRACE/103 to 555126262
    --  dialparties.agi: Filtered ARG3: 103
  == Manager 'admin' logged off from 127.0.0.1
    -- AGI Script dialparties.agi completed, returning 0
    -- Executing [s@macro-dial:7] Dial("SIP/194.98.81.144-b7a307c8", "SIP/103|15|tr") in new stack
    -- Called 103
    -- SIP/103-0962be88 is ringing
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#4
normal, car si tu mets:
type=from-trunk-custom
Je serais asterisk, je planterai.

Par contre,:
context=from-trunk-custom

Pas de problème! ;)
 

titilim

Joined
Mar 6, 2009
Messages
13
Likes
0
Points
0
#5
j'ai bien rajouter mon context dans mon user de mon trunk mais pas moyen il prend en premier le from-sip-external et non mon from-trunk-custom

rrrrr

titilim69@hotmail.com
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#6
j'ai bien rajouter mon context dans mon user de mon trunk
Rajouter un context dans ton user de ton trunk.

Comprend pas!

C'est uniquement dans le trunk qu'il faut mettre context=from-trunk-custom et non dans le user.

A mon avis, tu as mal monté ton trunk!
Tu l'as fait en 2 parties?!
Outgoing Settings et Incoming Settings

Ben non.

Restes fixé sur Outgoing Settings et ne rein mettre dans Incoming Settings ;)

Aller.... un exemple de conf - Outgoing Settings - Trunk Name - PEER Details:
Code:
username=compte
secret=******
type=peer
qualify=yes
host=@IP-opérateur
dtmfmode=rfc2833
context=from-trunk-custom  <--- ICI
canreinvite=no
disallow=all
allow=alaw
 

titilim

Joined
Mar 6, 2009
Messages
13
Likes
0
Points
0
#7
Je suis un boulet
j'etais a l'ouest 1000 pardon
Ca fonctionne avec mon context sauf que mon name est toujours sans le 0

[from-trunk-custom]
exten => _X.,1,Set(CALLERID(num)=0${CALLERID(num)})
exten => _X.,n,Goto(from-trunk,${EXTEN},1)

par contre si maintenant je veux rappeller ce numéro je l'ai dans le baba car mon prefixe de sortie est le 0

Comment puis je rajouter ce prefixe ?

Je debute encore dsl
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#8
Attends, Attends....
C'est dans le num ou dans le name que tu dois rajouter le 0?

Si c'est dans le name, be tu fais CALLERID(name)
Je pense alors que ce soit les 2 (CALLERID(name) et CALLERID(num))

Pour rajouter un préfixe opérateur, il faut aller dans les paramètres de ton trunk, et renseigner le préfixe opérateur Outbound dial prefix (0)
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,915
Messages
130,920
Members
17,595
Latest member
feparra121
Top