PROBLEMAS TRUNK SIP GRANDSTREAM CON ELASTIX

Discussion in 'Elastix 2.x' started by spalacios, Jun 9, 2009.

  1. spalacios

    Joined:
    Jun 9, 2009
    Messages:
    5
    Likes Received:
    0
    Saludos amigos,

    En mi caso he logrado que salgan llamadas sin problema pero para llamadas entrantes tengo el problema que me dice que la extension que he llamado no está en servicio y que trate nuevamente. Mi config es la siguiente:

    Trunk Name: Agxw
    PEER Details:

    host=192.168.0.32 (direccion del grandstream)
    type=peer
    secret=1001
    username=1001 (usuario SIP declarado en el grandstream en channels)
    fromuser=1001
    qualify=yes
    context=from-trunk

    Incoming Settings

    NADA



    en la ruta entrante:


    Edit Incoming Route

    Description: desde gxw
    DID Number: 11001 (DID que mando desde el grandstream en la parte de unconditional forward)


    Intenté por todos los medios que dice en los foros anteriores pero no logra hacer sip trunk. La unica manera que logré fue permitiendo llamadas sip anonimas. Sin embargo por cuestiones de seguridad no quiero que sea asi.

    Sería de gran ayuda si me pueden dar una mano.

    Saludos
     
  2. jcastellanos

    Joined:
    Feb 10, 2009
    Messages:
    2,404
    Likes Received:
    0
    bueno hay que ver que tiene el grandstream, en el momento quie quieras lo podemos checar.

    saludos
     
  3. Baez

    Joined:
    Aug 9, 2008
    Messages:
    50
    Likes Received:
    0
    Utilizo mucho Grandstream sin problemas.
    Trata cambiando la opcion de Allow anonymous calls: a yes en General Settings de tu Elastix y prueba.

    Espero te ayude.
     
  4. jcastellanos

    Joined:
    Feb 10, 2009
    Messages:
    2,404
    Likes Received:
    0
    si, cuentanos como te fue :)
     
  5. spalacios

    Joined:
    Jun 9, 2009
    Messages:
    5
    Likes Received:
    0
    la verdad es que esa es la unica manera que me funciona, porque en outbound calls no tengo problema, sin embargo, la unica manera de recibir llamadas, es poniendo anonymous sip calls en YES. Pero justamente lo que quiero es hacer que no se haga eso por cuestiones de seguridad.

    Alguna otra idea??
     
  6. spalacios

    Joined:
    Jun 9, 2009
    Messages:
    5
    Likes Received:
    0
    ya les voy a poner el dia de maniana la configuracion del grandstream para ver si con eso les doy una idea mas clara de lo que tengo

    Saludos y gracias
     
  7. jcastellanos

    Joined:
    Feb 10, 2009
    Messages:
    2,404
    Likes Received:
    0
    si claro posteanos la configuracion o algunos screenshots para ver que esta pasando.

    pero un fabor, continuemos con tu problema solo en un post, ya que lo estamos biendo en dos, y realmente podemos confundir a los colegas ( o a nosotros mismos :) Gracias

    saludos
     
  8. Baez

    Joined:
    Aug 9, 2008
    Messages:
    50
    Likes Received:
    0
    Para recibir llamadas sin permitir llamadas anónimas, debes crear extensiones en Elastix y configurar los usuarios y contraseñas en el tab de channels dentro del GXW410X. (1 extensión diferente para cada canal)
    Luego en el profile que estes utilizando márcale que si en SIP Registration y el utilizará los datos que pusiste en channels para registrarse con ese profile. Update y Reboot.
    Ya estás listo para recibir llamadas.
    Además, puedes ponerle DID a cada canal del GXW410X.

    Espero esto te ayude.
     

Share This Page