Problemas al recibir faxes en Elastix 1.6.12. SOS!

mmayo

Joined
Feb 24, 2008
Messages
52
Likes
0
Points
0
#1
Escenario:

Dispongo de Instalación de Elastix 1.6.12, con una Openvox A800P con 4 canales instalados y configurados. Todo funciona OK menos la recepción de faxes... y estoy desesperado...!! :(

Los 2 primeros channels (0 y 1) corresponden a una linea (999999991, por ejemplo) y los otros 2 (2 y 3) correspondes a otra diferente (9999999992, por ejemplo).

Para el ruteo de llamadas entrantes, utilizo ZAP DIDs Channels, identificando cada uno de los 2 numeros posibles con sus correspondiente canales.

En las rutas entrantes, si el DIDs corresponde con el numero 999999991, ruteo hacia un grupo de timbrado, por ejemplo el 601, y si corresponde al otro, pues al 602.

Todo esto funciona correctamente en cuanto a llamadas de voz se refiere.

AQUÍ VIENE EL PROBLEMA!

Ahora intento configurar 2 faxes virtuales. Y lo hago así:

Creo dos extensiones IAX2, la 301 para el 999999991 y la 302 para el 999999992, ¿Ok?
Recordemos que en al menos la versión 1.6.12 de Elastix, a la hora de crear la ext. iax2, no exixte ningun campo Fax Handling .

Bien, ahora creo 2 faxes virtuales, ponendoles por ejemplo FAX1 y FAX2. Relleno el nº de ext., secreto, email destino, cod pais (34) y de area (926). Los faxes se crean correctamente.

Por último, en la rutas entrantes, defino en cada una de las rutas el "fax handling"

Por ejemplo, para la linea 999999991
Fax ext.: 301
Fax email: elquesea@loquesea.com
Fax detection Type: NVFAX (Aunque también he probado con ZAPTEL)
Pause after..: He probado con 0, 1, y 2.

En la otra extension, lo mismo pero con ext. 302

Como dato adicional, he de decir que en la configuración general de Elastix, está puesto en FAX MACHINE:

Extension of fax machine....: system
Y los mails correspondientes.

Por último y no se si relevante, por el tema de los ZAP DIDs CHANNELS, tuve que cambiar en un archivo de configuración (no recuerdo cual) el context de from-PSTN a from-ZAPTEL.

El tema está en que no recibo faxes... y es más, juraría que cuando activo lo de los faxes, no descuelga, por lo que creo que además deja de funcionar la recepción de llamadas de voz también, porque entiendo que al menos debería descolgar.

Datos de configuración:

CHAN_DAHDI.CONF


; Auto-generated by /usr/sbin/hardware_detector
[trunkgroups]

[channels]
language=es
context=from-pstn
answeronpolarityswitch=yes
hanguponpolarityswitch=yes
signalling=fxs_ks
rxwink=300 ; Atlas seems to use long (250ms) winks
usecallerid=yes
hidecallerid=no
callwaiting=yes
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=yes
transfer=yes
canpark=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=no
faxdetect=incoming
echotraining=800
rxgain=0.0
txgain=0.0
callgroup=1
pickupgroup=1

;Uncomment these lines if you have problems with the disconection of your analog lines
busydetect=yes
busycount=3



immediate=no

#include dahdi-channels.conf
#include chan_dahdi_additional.conf

DAHDI-CHANNELS.CONF

; Autogenerated by /usr/sbin/dahdi_genconf on Wed Jan 20 13:17:02 2010
; If you edit this file and execute /usr/sbin/dahdi_genconf again,
; your manual changes will be LOST.
; Dahdi Channels Configurations (chan_dahdi.conf)
;
; This is not intended to be a complete chan_dahdi.conf. Rather, it is intended
; to be #include-d by /etc/chan_dahdi.conf that will include the global settings
;

; Span 1: OPVXA1200/12 "OpenVox A1200P/A800P Board 13" (MASTER)
;;; line="1 OPVXA1200/12/0 FXSKS"
signalling=fxs_ks
callerid=asreceived
group=0
context=from-zaptel
answeronpolarityswitch=yes
hanguponpolarityswitch=yes
channel => 1
callerid=
group=
context=default

;;; line="2 OPVXA1200/12/1 FXSKS"
signalling=fxs_ks
callerid=asreceived
group=0
context=from-zaptel
answeronpolarityswitch=yes
hanguponpolarityswitch=yes
channel => 2
callerid=
group=
context=default

;;; line="3 OPVXA1200/12/2 FXSKS"
signalling=fxs_ks
callerid=asreceived
group=0
context=from-zaptel
answeronpolarityswitch=yes
hanguponpolarityswitch=yes
channel => 3
callerid=
group=
context=default

;;; line="4 OPVXA1200/12/3 FXSKS"
signalling=fxs_ks
callerid=asreceived
group=0
context=from-zaptel
answeronpolarityswitch=yes
hanguponpolarityswitch=yes
channel => 4
callerid=
group=
context=default

Espero haber sido suficientemente explicito en todo lo explicado, y que podais ayudarme.

Si es una mala configuración, decidme que debo cambiar, y si es un bug, comentad si debo cambiar algo y en que archivos.

Muchas gracias.
 

mmayo

Joined
Feb 24, 2008
Messages
52
Likes
0
Points
0
#2
Por cierto ya he recordado..

El context lo cambié exclusivamente en cada uno de los canales en Dahdi-channels.conf, como se puede ver en el archivo de configuración expuesto en el anterior post.

Gracias de nuevo.
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,887
Members
17,565
Latest member
omarmenichetti
Top