problema iniciando asterisk !!!!

Discussion in 'General' started by sirsolrac, Jul 9, 2009.

  1. sirsolrac

    Joined:
    Feb 27, 2009
    Messages:
    24
    Likes Received:
    0
    He recien instalado Elastix 1.5.2 estable.
    Cuando quiero emepzar a crear extensiones no puedo. Me sale el siguiente mensaje:


    STARTING ASTERISK
    Asterisk ended with exit status 1
    Asterisk died with code 1.
    Automatically restarting Asterisk.
    mpg123: no process killed
    Asterisk ended with exit status 1
    Asterisk died with code 1.
    Automatically restarting Asterisk.
    mpg123: no process killed

    -----------------------------------------------------
    Asterisk could not start!
    Use 'tail /var/log/asterisk/full' to find out why.
    -----------------------------------------------------



    al digitar ese comando obtengo lo siguiente:

    [root@elastix ~]# tail /var/log/asterisk/full
    [Jul 9 13:38:50] VERBOSE[3833] logger.c: Asterisk Event Logger Started /var/log/asterisk/event_log
    [Jul 9 13:38:50] ERROR[3833] asterisk.c: Asterisk has detected a problem with your DAHDI configuration and will shutdown for your protection. You have options:
    1. You only have to compile DAHDI support into Asterisk if you need it. One option is to recompile without DAHDI support.
    2. You only have to load DAHDI drivers if you want to take advantage of DAHDI services. One option is to unload DAHDI modules if you don't need them.
    3. If you need Zaptel services, you must correctly configure DAHDI.
    [Jul 9 13:38:54] VERBOSE[3858] logger.c: Asterisk Event Logger Started /var/log/asterisk/event_log
    [Jul 9 13:38:55] ERROR[3858] asterisk.c: Asterisk has detected a problem with your DAHDI configuration and will shutdown for your protection. You have options:
    1. You only have to compile DAHDI support into Asterisk if you need it. One option is to recompile without DAHDI support.
    2. You only have to load DAHDI drivers if you want to take advantage of DAHDI services. One option is to unload DAHDI modules if you don't need them.
    3. If you need Zaptel services, you must correctly configure DAHDI.
    [root@elastix ~]#


    No tengo nada con Dahdi ni en ningu momento me pregunto el instalador si deseaba instalarlo, como lo remuevo o que puedo hacer??
     
  2. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    Tienes alguna tarjeta de telefonía instalada? Usualmente ese mensaje de error aparece cuando tienes información acerca de una tarjeta en tus archivos de configuración, pero ya la has sacado...

    Si es que no tienes ninguna, te recomiendo que vayas al módulo de detección de hardware, y le des click en el botón para que recozca el hardware, pero antes selecciona las otras casillas de ahí.
     
  3. virusbcn

    Joined:
    Sep 12, 2008
    Messages:
    99
    Likes Received:
    0
    A mí tambien me pasa es un fallo en la última versión de Elastix, me pasa cuando tengo una tarjeta Digium RDSI instalada, la B410P, tengo que ejecutar "setup" y desactivar el módulo DAHDI y ya de paso activar el MISDN con eso se soluciona.
     

Share This Page