Problema extraño con las extensiónes desde WAN

Discussion in 'General' started by turcko, Nov 21, 2010.

  1. turcko

    Joined:
    Nov 20, 2010
    Messages:
    13
    Likes Received:
    0
    Muy buenas

    Les relato mi problema a ver si alguien me puede dar alguna idea de por donde puede darse el error.

    Tengo un Elastix 2.0 instalado hace 3 días (instalación nueva sin informacion previa), tengo 5 extensiones dadas de alta tipo SIP y un troncal.
    Las 5 extensiones son softphones, 3 por wifi y dos por cable (ext. 10, 11, 15 y 20 y 21)
    El troncal es de VoIPCheap.

    Para poder acceder con mi portatil o con un telefono con iOS4 desde la calle, he configurado el router redirigiendo a la IP de la maquina con Elastix los puertos 5060 (TCP y UDP) y los puertos del 10000 al 60000 (se que no se necesitan tantos, pero por ahora lo tengo asi porque fue una de las pruebas que he hecho), también de ambos tipos, tcp y udp.

    Cuando estoy con las 5 extensiones dentro de mi red (2 por cable y 3 por Wifi) todo funciona perfectamente puedo hablar y/o tranferir llamadas sin ningun problema, realizar llamados dentro y fuera de España usando el servicio de VoIPCheap sin ningun problema.

    Ahora, cuando intento usar desde el smartphone usando 3G o desde mi portatil usando 3G o Wifi (ya que estuve en 3 wifis distintas fuera de mi oficina que es la ubicacion del Elastix) logro registrar el terminal sin problema y hablar con las otras extensiones sin ningun problema pero a la hora de llamar usando servicio de VoIPCheap ni escucho ni me escuchan, se que los telefonos de destino suenan, lo he comprobado en mas de 20 ocaciones, siempre con el mismo resultado, he comprobado los puertos en 2 ocaciones y creo que no hay nada malo.
    Me desconcierta saber que entre las extensiones puedo hablar sin problemas, no entiendo porque solo es cuando estoy con la extension desde la WAN y solo cuando uso el troncal.


    Alguna idea?

    Saludos
    Turcko


    P.D.: He visto que muchos usan IAX para las extensiones desde WAN pero es imposible en mi caso ya que tenemos telefonos SIP que es lo que vamos a usar cuando funcione todo correctamente.
     
  2. chentolin

    Joined:
    Aug 21, 2009
    Messages:
    4
    Likes Received:
    0
    Estoy en las mismas, creo que es archivo sip_nat.conf
     
  3. chentolin

    Joined:
    Aug 21, 2009
    Messages:
    4
    Likes Received:
    0
    Ya di, busca en PBX. tools, Asterisk file editor, busca
    Archivo: sip_nat.conf


    y le agregas tus datos por ejemplo.

    nat=yes
    externhost=xxxx.dyndns.org
    localnet=192.168.1.0/255.255.255.0
    externrefresh=10
     

Share This Page