Problema con troncal en 0.9

Discussion in 'Elastix 2.x' started by gustavob, Nov 22, 2007.

  1. gustavob

    Joined:
    Nov 21, 2007
    Messages:
    6
    Likes Received:
    0
    Me pasa lo mismo que a Lurkan con la versión 0.9 me detecta la placa y me la agrega pero no me la avilita, puse lo mismo que lurkan en el archivo zapta.conf para que me la avilite:

    #include zapata-channels.conf
    #include zapata.conf.template

    y recién entonces me la avilita, pero en el flash operator panel no aparecen los trunk aunque están creados. Le paso esto a alguien mas? y como lo solucionaron?
    Gracias
     
  2. gustavob

    Joined:
    Nov 21, 2007
    Messages:
    6
    Likes Received:
    0
    gente encontré parte de la solución en el foro en ingles y consiste en lo siguiente:
    editar el archivo retrieve_op_conf_from_mysql.pl
    esta en el directorio: /var/lib/asterisk/bin

    $ vi /var/lib/asterisk/bin/retrieve_op_conf_from_mysql.pl

    en la linea 21 y 26 ambiar el nombre del archivo zapata-auto.conf por zapata-channels.conf

    antes de cambiar:

    if (scalar @ARGV == 2)
    {
    $amportalconf = $ARGV[0];
    $zapataconf = $ARGV[1]."/zapata.conf";
    $zapataautoconf = $ARGV[1]."/zapata-auto.conf";
    } else
    {
    $amportalconf = "/etc/amportal.conf";
    $zapataconf="/etc/asterisk/zapata.conf";
    $zapataautoconf="/etc/asterisk/zapata-auto.conf";
    }

    despues de cambiar:

    if (scalar @ARGV == 2)
    {
    $amportalconf = $ARGV[0];
    $zapataconf = $ARGV[1]."/zapata.conf";
    $zapataautoconf = $ARGV[1]."/zapata-channels.conf";
    } else
    {
    $amportalconf = "/etc/amportal.conf";
    $zapataconf="/etc/asterisk/zapata.conf";
    $zapataautoconf="/etc/asterisk/zapata-channels.conf";
    }

    agregar al final del archivo zapata.conf

    #include zapata-channels.conf

    reiniciar todo el sistema, si después de esto sigue sin aparecer la troncal en flash panel simplemente hay que entrar a modificara la troncal y sin modificar nada le damos guardar y listo con eso tiene que funcionar.
     
  3. gustavob

    Joined:
    Nov 21, 2007
    Messages:
    6
    Likes Received:
    0
    el problema que tengo ahora es que en esa troncal tengo conectada una central analógica común con varios internos analógicos, cuando trato de llamar desde un interno ZIP a un interno analógico a través de esa troncal me da ocupado permanentemente.
    Alguna idea? gracias
     

Share This Page