Problema con Llamadas Entrantes

Joined
Jan 16, 2009
Messages
71
Points
0
Hola Amigos

Despues de alejado un tiempo vuelvo, les cuento tengo un problema en una instalacion de Elastix, se cuenta con una Sangoma A200 2 FXS y 2 FXO, llamadas salientes no tengo problema, lo raro se me presenta en las llamadas entrantes a las troncales telefonicas les pondre un ejemplo:

1. Marco a linea 1 con numero XXXXXXX detecta la llamada entrante la tarjeta (DAHDI/1-1) y enruta la llamada correctamente. (marco 10 veces el numero y estos son los resultados)

*** bien 4 responde en DAHDI/2-1
*** mal 3 (please check the number and try again) responde en DAHDI/1-1
*** no responde 3

2. Marco a la linea 2 con numero ZZZZZZZ detecta la llamada por el mismo puerto (DAHDI/1-1) y enruta la llamada perfectamente
marco 10 veces y este es el resultado:

*** bien 0 responde en DAHDI/2-1
*** mal 10 (please check the number and try again) responde en DAHDI/1-1
*** no responde 0

Code:
[Oct  5 15:03:28] VERBOSE[21883] sig_analog.c:     -- Starting simple switch on 'DAHDI/1-1'
[Oct  5 15:03:33] VERBOSE[21883] pbx.c:     -- Executing [s@from-zaptel:1] NoOp("DAHDI/1-1", "Entering from-dahdi with DID == ") in new stack
[Oct  5 15:03:33] VERBOSE[21883] pbx.c:     -- Executing [s@from-zaptel:2] Ringing("DAHDI/1-1", "") in new stack
[Oct  5 15:03:33] VERBOSE[21883] pbx.c:     -- Executing [s@from-zaptel:3] Set("DAHDI/1-1", "DID=s") in new stack
[Oct  5 15:03:33] VERBOSE[21883] pbx.c:     -- Executing [s@from-zaptel:4] NoOp("DAHDI/1-1", "DID is now s") in new stack
[Oct  5 15:03:33] VERBOSE[21883] pbx.c:     -- Executing [s@from-zaptel:5] GotoIf("DAHDI/1-1", "1?dahdiok:checkzap") in new stack
[Oct  5 15:03:33] VERBOSE[21883] pbx.c:     -- Goto (from-zaptel,s,9)
[Oct  5 15:03:33] VERBOSE[21883] pbx.c:     -- Executing [s@from-zaptel:9] NoOp("DAHDI/1-1", "Is a DAHDI Channel") in new stack
[Oct  5 15:03:33] VERBOSE[21883] pbx.c:     -- Executing [s@from-zaptel:10] Set("DAHDI/1-1", "CHAN=1-1") in new stack
[Oct  5 15:03:33] VERBOSE[21883] pbx.c:     -- Executing [s@from-zaptel:11] Set("DAHDI/1-1", "CHAN=1") in new stack
[Oct  5 15:03:33] VERBOSE[21883] pbx.c:     -- Executing [s@from-zaptel:12] Macro("DAHDI/1-1", "from-dahdi-1,s,1") in new stack
[Oct  5 15:03:33] VERBOSE[21883] pbx.c:     -- Executing [s@macro-from-dahdi-1:1] NoOp("DAHDI/1-1", "Entering macro-from-dahdi-1 with DID = s and setting to: 6672620242") in new stack
[Oct  5 15:03:33] VERBOSE[21883] pbx.c:     -- Executing [s@macro-from-dahdi-1:2] Set("DAHDI/1-1", "__FROM_DID=6672620242") in new stack
[Oct  5 15:03:33] VERBOSE[21883] pbx.c:     -- Executing [s@macro-from-dahdi-1:3] Goto("DAHDI/1-1", "from-trunk,6672620242,1") in new stack
[Oct  5 15:03:33] VERBOSE[21883] pbx.c:     -- Goto (from-trunk,6672620242,1)
[Oct  5 15:03:33] VERBOSE[21883] app_macro.c:   == Channel 'DAHDI/1-1' jumping out of macro 'from-dahdi-1'
[Oct  5 15:03:33] VERBOSE[21883] pbx.c:     -- Executing [6672620242@from-trunk:1] Set("DAHDI/1-1", "__FROM_DID=6672620242") in new stack
[Oct  5 15:03:33] VERBOSE[21883] pbx.c:     -- Executing [6672620242@from-trunk:2] NoOp("DAHDI/1-1", "Received an unknown call with DID set to 6672620242") in new stack
[Oct  5 15:03:33] VERBOSE[21883] pbx.c:     -- Executing [6672620242@from-trunk:3] Goto("DAHDI/1-1", "s,a2") in new stack
[Oct  5 15:03:33] VERBOSE[21883] pbx.c:     -- Goto (from-trunk,s,2)
[Oct  5 15:03:33] VERBOSE[21883] pbx.c:     -- Executing [s@from-trunk:2] Answer("DAHDI/1-1", "") in new stack
[Oct  5 15:03:33] VERBOSE[21883] pbx.c:     -- Executing [s@from-trunk:3] Wait("DAHDI/1-1", "2") in new stack
[Oct  5 15:03:35] VERBOSE[21883] pbx.c:     -- Executing [s@from-trunk:4] Playback("DAHDI/1-1", "ss-noservice") in new stack
[Oct  5 15:03:35] VERBOSE[21883] file.c:     -- <DAHDI/1-1> Playing 'ss-noservice.gsm' (language 'en')
Cual podra ser el problema?

Saludos y graicas de antemano
 
Joined
Feb 28, 2008
Messages
5,737
Points
0
Lo que sucede es que al ingresar la llamada, no concuerda con tus rutas entrantes.

Deberás crear una ruta entrante con el campo DID y CID vacíos, al final de la página, escoge el destino.
 
Joined
Oct 16, 2018
Messages
1
Points
1
buenas tardes jgutierrez

te cuanto que tengo algo muy parecido y que me urge que me ayudes.

ya tenia mi elastix 2.6.18 montado sobre una maquina virtual oracle en mi servidor. y estaba funcionando perfectamente de un momento a otro dejo de funcionar y movi de todo y nada.
por eso remonte todo de nuevo, y ya logre que salgan las llamadas de todas las extensiones y entre ellas se comunican y todo pero lo que no logro es que entren las llamadas y tengo mi PEER details asi:

username=VHxxxxxx
type=friend
secret=xxxxxxx
port=5060
nat=yes
insecure=very
host=sip-xxxxxx.accounts.vocalocity.com
fromuser=VHxxxxxxx
fromdomain=sip-xxxxxxx.accounts.vocalocity.com:5060
dtmfmode=rfc2833
disallow=all
defaultexpirey=20
canreinvite=no
auth=md5
allow=g729&ulaw&alaw

ya habilite las llamadas anonimas a YES y ya tengo las entradas de DID abiertas con direccion a un IVR.

por favor ruego me ayudes.
 

Members online

No members online now.

Forum statistics

Threads
30,992
Messages
131,106
Members
17,716
Latest member
Orbit114
Top