Problema con Inbound Route para ZAP Trunk

camf3110

Joined
Mar 12, 2009
Messages
7
Likes
0
Points
0
#1
Hola amigos.
Necesito ayuda para poder realizar la configuración de llamadas entrantes a través de un troncal ZAP. El caso es que una vez instalada la tarjeta A400P de OpenVox, Elastix la detecta y muestra las 4 FXO, al crear un Inbound Route asigno el canal 3, que es donde esta instalada la línea PSTN y derivo para que contesten en un anexo (Recepción), el problema es que no recibo las llamadas.

Tengo instaladas las siguientes versiones:
Elastix 1.0-17
FreePBX 2.3.1.0
mi archivo zapata.conf está como sigue:

zapata.conf

[trunkgroups]

[channels]
context=from-pstn
signalling=fxs_ks
rxwink=300 ; Atlas seems to use long (250ms) winks
usecallerid=yes
hidecallerid=no
callwaiting=yes
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=yes
transfer=yes
canpark=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=no
faxdetect=incoming
;echotraining=yes
;echotraining=800
rxgain=4
txgain=2
callgroup=1
pickupgroup=1

;Uncomment these lines if you have problems with the disconection of your analog lines
busydetect=yes
busycount=6


immediate=no

#include zapata_additional.conf
#include zapata-channels.conf
==========================================================================================

El archivo /etc/zaptel.conf es el siguiente:


# Autogenerated by /usr/sbin/genzaptelconf -- do not hand edit
# Zaptel Configuration File
#
# This file is parsed by the Zaptel Configurator, ztcfg
#

# It must be in the module loading order


# Span 1: WCTDM/0 "Wildcard TDM400P REV E/F Board 1" (MASTER)
fxsks=1
fxsks=2
fxsks=3
fxsks=4

# Global data

loadzone = us
defaultzone = us
=====================================================================================

Ahora bien,, cuando reemplazo fxsks por fxoks me da el siguiente error:

Zaptel Version: 1.4.9.2-Xorcom-trunk-r5517
Echo Canceller: Oslec
Configuration
======================


Channel map:

Channel 01: FXO Kewlstart (Default) (Slaves: 01)
Channel 02: FXO Kewlstart (Default) (Slaves: 02)
Channel 03: FXO Kewlstart (Default) (Slaves: 03)
Channel 04: FXO Kewlstart (Default) (Slaves: 04)

4 channels to configure.

Changing signalling on channel 1 from FXS Kewlstart to FXO Kewlstart
ZT_CHANCONFIG failed on channel 1: Invalid argument (22)
Did you forget that FXS interfaces are configured with FXO signalling
and that FXO interfaces use FXS signalling?
================================================================================

¿A qué se debe esto, está mal instalado?
¿Cómo puedo solucionarlo?
Espero sus comentarios y desde ya agradezco su gentileza.

Un cordial saludo.
Carlos Martínez.
Chile.
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,967
Messages
131,028
Members
17,677
Latest member
John-V
Top