Problema con el Flujo RTP - Va por la ETH erronea

Discussion in 'General' started by cmosquera, Jan 7, 2011.

  1. cmosquera

    Joined:
    Apr 2, 2009
    Messages:
    14
    Likes Received:
    0
    Hola a todos, tengo el siguiente inconveniente y agradezco anticipadamente cualquier colaboración.
    Estoy en Colombia, tengo un Elastix 2.0 y he puesto en la oficina una troncal SIP con la empresa Telmex que funciona excelente. Mi servidor Elastix tiene 2 interfaces de red, una pegada a mi red corporativa (192.168.1.3) y una dedicada exclusivamente a la troncal SIP con Telmex (Y.Y.Y.Y). El default Gateway es la interfaz que se conecta a la oficina ya que es por esta por la que navega.
    Como tengo muchos usuarios viajeros quiero conectar estos con el X-Lite para que continúen utilizando su extensión en cualquier lugar, para ello he activado en Nat en la caja elastix con los siguientes parámetros:
    /etc/asterisk/sip_nat.conf
    externip = X.X.X.X
    localip = 192.168.1.3
    externrefresh = 10



    Las extensiones remotas logran conectarse y la señalización pasa sin problemas, pero el flujo RTP (Voz) no logra pasar. Cuando me pongo a mirar los paquetes SIP que están corriendo veo que todo este tráfico se va por la interfaz que está pegada a la troncal SIP de Telmex Y.Y.Y.Y y debería irse por el default Gateway.

    Nuevamente agradezco cualquier ayuda en este sentido porque no sé qué otro parámetro deba mover para evitar este inconveniente.
     

Share This Page