Problem with second number with second outbound

Server00

Joined
Oct 17, 2009
Messages
2
Likes
0
Points
0
#1
Hi People,

On this moment i have 2 VOIP numbers from the same provider. First VoIP number is working fine for incoming and outgoing calls on my Elastix server. And he shows the number on the screen where I am calling from.

Now I add the second number to my Elastix server. I have created a new Trunk for this second number. In the CLI of Elastix I see both numbers registered correctly, so with this there are no problems.

The incoming part is working perfect, so when in call the second number its going perfectly to the new extension that I created for it.

No I have the following problem:

If I am creating a new outbound route (with the same dial rules as the other outbound route what is working perfect), and I use as “Trunk Sequence” the second numbers its not working.

I can call out. Here are the logs at the moment of calling out with the second number:

Code:
  ==  fixlocalprefix: Dialpattern 0031+Z. matched. 61XX9XXXX -> 003161XX9XXXX
    -- AGI Script fixlocalprefix completed, returning 0
    -- Executing [s@macro-dialout-trunk:13] Set("SIP/103-08f92708", "OUTNUM=003161XX9XXXX") in new stack
    -- Executing [s@macro-dialout-trunk:14] Set("SIP/103-08f92708", "custom=SIP/31172XXXXXX") in new stack
    -- Executing [s@macro-dialout-trunk:15] GotoIf("SIP/103-08f92708", "0?gocall") in new stack
    -- Executing [s@macro-dialout-trunk:16] Set("SIP/103-08f92708", "DIAL_TRUNK_OPTIONS=M(setmusic^none)") in new stack
    -- Executing [s@macro-dialout-trunk:17] Macro("SIP/103-08f92708", "dialout-trunk-predial-hook|") in new stack
    -- Executing [s@macro-dialout-trunk:18] GotoIf("SIP/103-08f92708", "0?bypass|1") in new stack
    -- Executing [s@macro-dialout-trunk:19] GotoIf("SIP/103-08f92708", "0?customtrunk") in new stack
    -- Executing [s@macro-dialout-trunk:20] Dial("SIP/103-08f92708", "SIP/31172XXXXXX"/003161XX9XXXX|300|M(setmusic^none)") in new stack
    -- Called 31172XXXXXX/003161XX9XXXX
    -- SIP/3117231172XXXXXX-08f25460 is circuit-busy
  == Everyone is busy/congested at this time (1:0/1/0)
    -- Executing [s@macro-dialout-trunk:21] Goto("SIP/103-08f92708", "s-CONGESTION|1") in new stack
    -- Goto (macro-dialout-trunk,s-CONGESTION,1)
    -- Executing [s-CONGESTION@macro-dialout-trunk:1] GotoIf("SIP/103-08f92708", "1?noreport") in new stack
    -- Goto (macro-dialout-trunk,s-CONGESTION,3)
    -- Executing [s-CONGESTION@macro-dialout-trunk:3] NoOp("SIP/103-08f92708", "TRUNK Dial failed due to CONGESTION - failing through to other trunks") in new stack
    -- Executing [061XX9XXXX@from-internal:6] Macro("SIP/103-08f92708", "outisbusy|") in new stack
    -- Executing [s@macro-outisbusy:1] Playback("SIP/103-08f92708", "all-circuits-busy-now|noanswer") in new stack
    -- <SIP/103-08f92708> Playing 'all-circuits-busy-now' (language 'en')
    -- Executing [s@macro-outisbusy:2] Playback("SIP/103-08f92708", "pls-try-call-later|noanswer") in new stack
NOTE: I changed some numbers for xx for my own privacy :) . But there are normally numbers on that spot.

If I use the outbound that I first add (for the first number) and I add the number at the second place of the “Trunk Sequence”.

If I use the outbound that I first add (for the first number) and I add the number at the second place of the “Trunk Sequence”, than its working fine.
If I put the outbound from the second number as first in the list than i have the same problem with calling out.

But the problem if I call someone the see the first number on there screen, but it needs to be the second number.

I did a lots of searching on the web, i found something like "Custom Context". I used it but still not working. If you disabled the trunk than the second number noy may use, than i get the following message:

Code:
"Al circuits are busy now"
Really strange :unsure:
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,886
Members
17,563
Latest member
dineshr
Top