problem with realtek lan

Discussion in 'General' started by kiofcon, Apr 25, 2009.

  1. kiofcon

    Joined:
    Feb 11, 2008
    Messages:
    4
    Likes Received:
    0
    i am using elastix with the INTEL BOXD945GCLF2 motherboard cause the ATOM chipset . i am try to build a green pbx and all working fine . only the realtek lan dosnt . cause there is only one pci ( i use an othe older lan cart ) can please add the driver in the new distro ? i think many have the same prob . thanx in advance
     
  2. velez

    Joined:
    Jul 18, 2008
    Messages:
    55
    Likes Received:
    0
    It is very easy to download the driver and compile it since elastix includes the compiler. I copy the driver in a usb drive together with Midnight commander. Mount the USB, Install MC. Use MC to copy the driver locally. And follow the instruction of the driver to compile it. We have done several servers running elastix with the Atom dual core 1.6GB with ssd 32GB
     
  3. beauprgu

    Joined:
    Apr 27, 2009
    Messages:
    1
    Likes Received:
    0
    I had the same problem with a ELX-3000. The appliance use a ATOM and a RealTek Lan IC.

    I simply did what was posted another site.....

    ****************

    Atom and r8101E driver

    To get the Atom box to work this is what I did.
    Grab a USB key drive.

    Go into the BIOS and disable the card and reboot.

    Once running download the driver from and copy to USB key drive.

    http://downloadcenter.intel.com/Detail_ ... D=2916&D...

    Compile the driver by following the directions in the file downloaded.

    Remove the r8169 driver completely, this is the reason that this and all other r8169 based systems will not boot the iso.

    reboot into the bios and enable the card.

    I pointed this issue out months ago to everyone when I still worked on this project. This is one of the main reasons that I would not update the kernel since this module was completely borken in a lot of distros. Here is a link from Intel that shows which distros have issues with this driver. Try booting a standard CentOS 5.2 disk on a r8169/r8101/etc.. based system and see what happens. It will kernel panic, just like the new 2.6.2 iso will.

    http://www.intel.com/support/motherboar ... f/sb/CS-...

    **************

    It worked for me...I hpe it does for you...

    Guy
     

Share This Page