Problem with NGI SQUILLO provider

Discussion in 'General' started by federicom, Nov 15, 2010.

  1. federicom

    Joined:
    Nov 11, 2010
    Messages:
    10
    Likes Received:
    0
    Hello it seems that I've a problem with Italian NGI SQUILLO provider. I can do outgoing calls but seems not registered for incoming calls. I've used all the settings I've in trixbox, with trixbox all is working , with elastix not (other trunks of other providers working).

    How Can I check which is the problem?
    Why with trixbox working and with elastik not receiving calls?

    I wait for your assistance.

    Thank you.
    Federico
     
  2. mm.alpha2k

    Joined:
    Jun 19, 2010
    Messages:
    165
    Likes Received:
    0
    Need to know more details to help you.

    In logger.conf uncomment
    dtmf => dtmf
    console => notice, warning, error
    console => notice, warning, error, debug
    messages => notice, warning, error
    full => notice, warning, error, debug, verbose

    Paste what is happening in the CLI, to learn more details, when the call for the trunk.
     
  3. federicom

    Joined:
    Nov 11, 2010
    Messages:
    10
    Likes Received:
    0
    I think that the incoming trunk is not registered. Which is the command I've to write from asterisk cli to give you the errors? Thank you again.
     
  4. mm.alpha2k

    Joined:
    Jun 19, 2010
    Messages:
    165
    Likes Received:
    0
    Re: Re:problem with NGI SQUILLO provider

    sip show registry
     
  5. federicom

    Joined:
    Nov 11, 2010
    Messages:
    10
    Likes Received:
    0
    After enabling the log I've only

    Host dnsmgr Username Refresh State Reg.Time
    sip.messagenet.it:5061 N 5328554 105 Registered Tue, 16 Nov 2010 08:16:26
    sip.messagenet.it:5061 N 5328555 105 Registered Tue, 16 Nov 2010 08:16:26
    sip.messagenet.it:5061 N 5328560 105 Registered Tue, 16 Nov 2010 08:16:26
    sip.messagenet.it:5061 N 5328559 105 Registered Tue, 16 Nov 2010 08:16:26
    sip.messagenet.it:5061 N 5328552 105 Registered Tue, 16 Nov 2010 08:16:26
    sip.messagenet.it:5061 N 5328556 105 Registered Tue, 16 Nov 2010 08:16:27
    sip.messagenet.it:5061 N 5328634 105 Registered Tue, 16 Nov 2010 08:16:27
    sip.messagenet.it:5061 N 5328553 105 Registered Tue, 16 Nov 2010 08:16:27
    8 SIP registrations.

    Missing the provider with problems on incoming callings.
     
  6. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    My guess is that as your are using SIP on the non-standard port of 5061, you have a router somewhere that is not forwarding effectively those connections, Registrations assume some form of permanence, you are registering several times a second, this is aberrant. check your trunk firewall and NAT settings
     
  7. federicom

    Joined:
    Nov 11, 2010
    Messages:
    10
    Likes Received:
    0
    I think that it's not a problem of port. I'm using 2 sip providers 1 one 5061 (and 8 trunks workings) the other one use port 5060 status on the dashboard is "unknown".

    Which are the commands to check the logs to understand why this issue?
     
  8. federicom

    Joined:
    Nov 11, 2010
    Messages:
    10
    Likes Received:
    0
    After doing some tests, if I have 1 trunk with 1 sip provider no problem and I can receive incoming calls. If I've more than 1 trunk with same sip provider NO incoming connection. By reading some other threats seems that problem only occurs if Asterisk 1.6.xx not with 1.4.xx (this is why with trixbox 2.6 no problem).

    Any suggestion???
     

Share This Page