problem with iptable and vtiger

Discussion in 'General' started by roll72, Aug 14, 2008.

  1. roll72

    Joined:
    Aug 13, 2008
    Messages:
    3
    Likes Received:
    0
    hello,

    I installed the last version of elastix from the 11 august 2008. everything was fine until I want to connect to the web interface. I had to stop iptable process in order to get the login/password page.

    After I succeed to login to sugarcrm but not Vtigercrm. I tried admin/admin without success.
    I saw on the console some error when I tried to login on vtiger :

    avc: denied {name connect } for pid=2280 comm="http...." but I could not find how to fix it.

    May someone got the same issue ?

    regards

    here are the avc log that appears in the log system :

    Aug 13 17:15:35 hardy kernel: audit(1218672935.300:58): avc: denied { name_connect } for pid=2278 comm="httpd" dest=3306 scontext=system_u:system_r:httpd_t:s0 tcontext=system_u:eek:bject_r:mysqld_port_t:s0 tclass=tcp_socket
    Aug 13 17:15:36 hardy kernel: audit(1218672936.069:59): avc: denied { name_connect } for pid=2278 comm="httpd" dest=3306 scontext=system_u:system_r:httpd_t:s0 tcontext=system_u:eek:bject_r:mysqld_port_t:s0 tclass=tcp_socket
    Aug 13 17:15:36 hardy kernel: audit(1218672936.611:60): avc: denied { name_connect } for pid=2280 comm="httpd" dest=3306 scontext=system_u:system_r:httpd_t:s0 tcontext=system_u:eek:bject_r:mysqld_port_t:s0 tclass=tcp_socket
     
  2. rafael

    Joined:
    May 14, 2007
    Messages:
    1,454
    Likes Received:
    1
    Weird, Elastix does not use a firewall by default. You have to enable by hand with iptables. Or you have a firewall in the middle? If yes, you should open port 443 to access to https.

    I just access to vtiger on Elastix 1.1-8 (yum updated from 1.1-6) withou problem. Any way I would report this to the developers so we can try to reproduce this error.

    Regards,

    Rafael
     
  3. roll72

    Joined:
    Aug 13, 2008
    Messages:
    3
    Likes Received:
    0
    Hello,

    I finally succeed to go to vtiger. Issue was coming from the elastix installation, I saw in the installation log :

    Installing wanpipe-util - 3.2.6-0.i686
    /var/tmp/rpm-tmp.87005: line 126: cat: command not found
    /var/tmp/rpm-tmp.87005: line 81: ln: command not found
    error reading information on service wanrouter: No such file or directory
    error: %post(wanpipe-util-3.2.6-0.i686) scriptlet failed, exit status 1


    So I force to reintall this module and now it working fine

    thanks for your help
     

Share This Page