problem with iptable and vtiger

roll72

Joined
Aug 13, 2008
Messages
3
Likes
0
Points
0
#1
hello,

I installed the last version of elastix from the 11 august 2008. everything was fine until I want to connect to the web interface. I had to stop iptable process in order to get the login/password page.

After I succeed to login to sugarcrm but not Vtigercrm. I tried admin/admin without success.
I saw on the console some error when I tried to login on vtiger :

avc: denied {name connect } for pid=2280 comm="http...." but I could not find how to fix it.

May someone got the same issue ?

regards

here are the avc log that appears in the log system :

Aug 13 17:15:35 hardy kernel: audit(1218672935.300:58): avc: denied { name_connect } for pid=2278 comm="httpd" dest=3306 scontext=system_u:system_r:httpd_t:s0 tcontext=system_u:eek:bject_r:mysqld_port_t:s0 tclass=tcp_socket
Aug 13 17:15:36 hardy kernel: audit(1218672936.069:59): avc: denied { name_connect } for pid=2278 comm="httpd" dest=3306 scontext=system_u:system_r:httpd_t:s0 tcontext=system_u:eek:bject_r:mysqld_port_t:s0 tclass=tcp_socket
Aug 13 17:15:36 hardy kernel: audit(1218672936.611:60): avc: denied { name_connect } for pid=2280 comm="httpd" dest=3306 scontext=system_u:system_r:httpd_t:s0 tcontext=system_u:eek:bject_r:mysqld_port_t:s0 tclass=tcp_socket
 

rafael

Joined
May 14, 2007
Messages
1,454
Likes
1
Points
0
#2
roll72 said:
hello,

I installed the last version of elastix from the 11 august 2008. everything was fine until I want to connect to the web interface. I had to stop iptable process in order to get the login/password page.
Weird, Elastix does not use a firewall by default. You have to enable by hand with iptables. Or you have a firewall in the middle? If yes, you should open port 443 to access to https.

After I succeed to login to sugarcrm but not Vtigercrm. I tried admin/admin without success.
I saw on the console some error when I tried to login on vtiger :

avc: denied {name connect } for pid=2280 comm="http...." but I could not find how to fix it.
I just access to vtiger on Elastix 1.1-8 (yum updated from 1.1-6) withou problem. Any way I would report this to the developers so we can try to reproduce this error.

Regards,

Rafael
 

roll72

Joined
Aug 13, 2008
Messages
3
Likes
0
Points
0
#3
Hello,

I finally succeed to go to vtiger. Issue was coming from the elastix installation, I saw in the installation log :

Installing wanpipe-util - 3.2.6-0.i686
/var/tmp/rpm-tmp.87005: line 126: cat: command not found
/var/tmp/rpm-tmp.87005: line 81: ln: command not found
error reading information on service wanrouter: No such file or directory
error: %post(wanpipe-util-3.2.6-0.i686) scriptlet failed, exit status 1


So I force to reintall this module and now it working fine

thanks for your help
 

Members online

No members online now.

Forum statistics

Threads
30,952
Messages
130,980
Members
17,654
Latest member
janko67
Top