Problem with incoming calls...

Discussion in 'General' started by medium_grade, Apr 4, 2009.

  1. medium_grade

    Joined:
    Apr 3, 2009
    Messages:
    9
    Likes Received:
    0
    I am trying to setup Elastix with my SIP trunk provider, but I am having trouble receiving inbound calls. While outbound calls are no problem, users here "the number you have dialed is not in service" when the try to call inbound.

    My PEER details:
    My USER details
    Where "PROVIDER_IP" is the actual IP address from my SIP trunk provider and my USER context is "from-sip-external." I have inbound routes one of which is supposed to go to extension 250. This is what the logs show:
    Can anyone help shed some light on this?
     
  2. Patrick_elx

    Joined:
    Dec 14, 2008
    Messages:
    1,120
    Likes Received:
    0
    Two tests:
    - allow anonymous sip in the general setting (for the duration of the test, as I'm not sure that your trunk is registered)
    - check that on your inbound route you have one with DID: +13232710918 that link to your extension 250


    When that works, we can go to the next steps to clear the "SIP connection from unknown peer".
     
  3. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Your VSP is sending you "+" prepended to the inbound number , make sure that your inbound routes reflect that. also setup an incoming "catchall" route while you debug. (interesting, while technically correct I have never seen or tried to route such a call, especially as I am myself in the 323 areacode (Los Angeles), who is your VSP may I ask?), I wonder if FreePBX can transform/strip that "+" as it would be interpreted differently in every different country, at least for outbound calls)
     
  4. medium_grade

    Joined:
    Apr 3, 2009
    Messages:
    9
    Likes Received:
    0
    Patrick_elx,

    Worked like a charm. Even without the "allow anonymous sip." Thanks.

    Dicko,

    I am using Bandwidth.com
     
  5. Patrick_elx

    Joined:
    Dec 14, 2008
    Messages:
    1,120
    Likes Received:
    0
    great. Enjoy

    As Dicko said, it would be a good idea to add a route for any DID, any CID as a catch all to the operator extension.
     
  6. Patrick_elx

    Joined:
    Dec 14, 2008
    Messages:
    1,120
    Likes Received:
    0
    I have my Nokia sip wifi as an extension on my pabx, and all my phonebook in the nokia is with +.
    I couldn't do anything with freepbx. I had to create a specific context for my Nokia to remove the +

    http://www.elastix.org/index.php?option ... 5280#15283
     
  7. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Exactly, "+" I is surely "metadata" used to "translate" localized locale specific international dial codes to e164 normalized digit strings, if in fact the string is e164 compliant (1NXXNXXXXXX for example) then the + is extraneous and inappropriate for an inbound call (I will check with bandwidth.com as to their interpretation of e164 and why they don't bother to do that conversion themselves, no matter how long I press the # button on my dtmf phone it never changes it to 011, (does work on my blackberry though).)
    Oh well standards will always be broken until people RTFM.
     

Share This Page