Problem with Hylafax and IAX connection

Discussion in 'General' started by azmerlin, Nov 2, 2008.

  1. azmerlin

    Joined:
    Jul 10, 2008
    Messages:
    65
    Likes Received:
    0
    After restarting amportal the IAXmodem are registered and reachable, everything seems to be
    working fine.
    After a few hours all IAXmodem channels are UNREACHABLE and no faxes are received.
    On the Asterisk side the only error we can see is:
    NOTICE[4123] chan_iax2.c: Peer '350' is now UNREACHABLE! Time: 3

    On the IAXmodem device we see the following registration timeout error:
    Registration timed out.
     
  2. tolengo

    Joined:
    Oct 31, 2008
    Messages:
    117
    Likes Received:
    0
    I got it running better with a touch in iax.conf ---> maxregexpire = 3600 . it delays the regitrations.
    I did it and now my PBX runs better but still sometimes i see freezed modems needing to be restarted.
    I really don't know what's wrong with this.
    Try and let me know.

    good luck!
     
  3. azmerlin

    Joined:
    Jul 10, 2008
    Messages:
    65
    Likes Received:
    0
    Thanks, what units do the 3600 represent ?
     
  4. tolengo

    Joined:
    Oct 31, 2008
    Messages:
    117
    Likes Received:
    0
    60 seconds (requested 1200) do the math :)

    did it help you?
     
  5. azmerlin

    Joined:
    Jul 10, 2008
    Messages:
    65
    Likes Received:
    0
    Not sure, I don't currently have access to the server, will try it in the morning.
     
  6. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    Hi there I have had the same problem using asterisk 1.4.19, if I'm not mistaken.

    When I was using that version, I have created an script that will monitor my iax2 fax extension, and if they were down, it restarted them, that way, I wouldn't have to be checking 'em at every hour :S

    Do the following:
    1. add a crontab task
    crontab -e
    */1 * * * * /etc/verificar_iax2.sh

    2. create a script in /etc
    #!/bin/sh
    desregistrado=0
    desregistrado=$(/usr/sbin/asterisk -rx "iax2 show peers" | grep "(Unspecified)" | wc -l)

    if [ ! $desregistrado = 0 ]; then
    /usr/sbin/asterisk -rx "restart when convenient"
    mail jorge@elastix.com -s "Iax2 fax extensions down, asterisk was restarted"
    fi






    As you can see, I use "restart when convenient" that means, that it won't restart asterisk if there is a call (it won't be dropped), it will only restart if there is no activity, you may also use "restart gracefully", you may check it and see if you use it or not.
     
  7. tolengo

    Joined:
    Oct 31, 2008
    Messages:
    117
    Likes Received:
    0
    Nice script but is not the solution, the bug will still in your PBX i know that sometime we haven't another choice than live between bugs :woohoo: :woohoo: :laugh: :laugh:
     
  8. azmerlin

    Joined:
    Jul 10, 2008
    Messages:
    65
    Likes Received:
    0
    Well the first solution worked ( or seems to be) now I need to try the second option, but I do not know if I will notice the results for that.
    Further, it would be nice to hear from the dev team as to what is causing this bug !?!?
     
  9. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    well, I think that is an asterisk related issue :dry:
     
  10. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    Thanks tolengo. I din't know about the maxregexpire parameter. I used to modify iaxmodem's /etc/iaxmodem/iaxmodem-cfg.ttyIAX* for every modem changing the refresh parameter from 300 to 60, but this is a much nicer solution.
     
  11. tolengo

    Joined:
    Oct 31, 2008
    Messages:
    117
    Likes Received:
    0
    I am glad to contribute to Elastix, it is a fantastic solution.

    saludos ;)
     
  12. tolengo

    Joined:
    Oct 31, 2008
    Messages:
    117
    Likes Received:
    0
    I glad to contribute with Elastix fanatics like me :) , it is a fantastic solution.

    saludos
     

Share This Page