Problem with E2 R3 System Recordings - Help

Discussion in 'General' started by emash, Jul 15, 2010.

  1. emash

    Joined:
    Jul 12, 2010
    Messages:
    8
    Likes Received:
    0
    Having a problem with the E2 R3 system recording. No suprise as it is still listed as a bug.

    I have tried the following.

    chown asterisk:asterisk /var/lib/asterisk/sounds/custom
    chown asterisk:asterisk /tmp
    chmod 1777 and 777 /var/lib/asterisk/sounds/custom
    chmod 1777 and 777 /tmp

    edited the asterisk.conf to remove the space. was not 100% clear on this, but tried both removing the space / line above the [options] heading as well as removing the spaces from this line "transmit_silence_during_record = yes" to "transmit_silence_during_record=yes"

    last I read a bug report for E2 R2 to edit "page.recordings.php" by dropping in the line "global $recordings_save_path;" at line 88 right before the line "if (!file_exists($recordings_save_path."{$dest}ivrrecording.$suffix")) {"

    I have tried doing these all and just some but nothing has worked. The closest I have gotten was to just do the chmod commands and edit the "global $recordings_save_path;" and I was able to upload files, but they don't play. I verified they are PCM 16bit 8k mono.

    Here is the kicker - using the text to wav creater included with E2 R3 I created a file and saved it to my desktop and then uploaded it. It plays, but is not useable for an autoattendant for a business.Checking the properties it is also PCM 16bit k mono.

    I could use some help here as I've been at this for almost a week. I need to either be able to upload a file and have it play or be able to recored system recording by phone and have it play so I can deploy this box.

    thanks in advance for those who might help me.

    Erik
     
  2. andreslie1

    Joined:
    Dec 27, 2007
    Messages:
    17
    Likes Received:
    0
    yum update elastix* -y
    the rc4 is now ready and fix that

    also you can use unembebed freepbx system recordings works find
     

Share This Page