Problem wih Inbound Route

Joined
Nov 19, 2007
Messages
3
Points
0
I am using Vitelity for outbound and inbound trunks. I have a DID setup in the inbound route. When i call this number, I get a busy signal, so i looked at the debug, and this is what i get:

SIP/2.0 404 Not Found
Via: SIP/2.0/UDP 64.2.142.30:5060;branch=z9hG4bK40c5fc86;received=64.2.142.30;rport=5060
From: "9313933932" <sip:9313933932@64.2.142.30>;tag=as70cec837
To: <sip:9315630342@68.186.135.56>;tag=as637dd68c
Call-ID: 5e2a9c9657e02766688971cc2f9e18f1@64.2.142.30
CSeq: 102 INVITE
User-Agent: Asterisk PBX
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces
Content-Length: 0
Here is the catch... When I assign the DID to an extension as a Direct DID, it works fine.

any help would be appreciated. thank you ahead of time.
 
Joined
Nov 16, 2007
Messages
42
Points
0
If you're using a SIP Trunk or SIP DAL-Trunk, try editing your /etc/asterisk/sip.conf:

context = from-trunk

Save the file, then reload Asterisk (asterisk -r "reload" at prompt).

If you're using a SIP access line which requires registration, you will have to setup the auth under SIP Trunk register.

You'll need to add a default route in Elastix. The next incoming call to a DID on your trunk's route list should ring to the extension you've built for that DID specifically.
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,987
Messages
131,100
Members
17,716
Latest member
Orbit114
Top