Problem Receiving Calls from VoIP Provider

Discussion in 'General' started by nachogomez, Oct 27, 2008.

  1. nachogomez

    Joined:
    Sep 11, 2008
    Messages:
    65
    Likes Received:
    0
    Hi list,

    I have problems receiving calls from my SIP VoIP Provider (Netuno in Venezuela), I can call any number using this trunk, but when someone tries to call me, the call is rejected.

    If I do a TCPdump I can see a response from my PBX saying:


    18:07:44.424368 IP (tos 0x10, ttl 58, id 4085, offset 0, flags [DF], proto: UDP (17), length: 1427) IP_OF_MY_PROVIDER.sip > MY_IP_ADDRESS.sip: SIP, length: 1399
    INVITE sip:MY_NUMBER@MY_IP SIP/2.0

    18:07:44.424983 IP (tos 0x60, ttl 64, id 14573, offset 0, flags [none], proto: UDP (17), length: 597) MY_IP_ADDRESS.sip > IP_OF_MY_PROVIDER.sip: SIP, length: 569
    SIP/2.0 407 Proxy Authentication Required


    I can receive calls with my TDM Card just fine.

    The support person of my provider have said to me that my config is OK.

    What can be happening here???
     
  2. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    Una pregunta, sí has definido correctamente las rutas entrantes para tu sip trunk?
     
  3. nachogomez

    Joined:
    Sep 11, 2008
    Messages:
    65
    Likes Received:
    0
    Well, I have defined my Inbound Routes to accept "Any DID / Any CallerID". I can receive calls made to my PSTN lines OK, so I'm a little lost right now...
     
  4. nachogomez

    Joined:
    Sep 11, 2008
    Messages:
    65
    Likes Received:
    0
    Someone has had luck setting up Elastix (or any other flavor of Asterisk) with Netuno??? (Venezuela).

    My peer config is working OK since I can place call using it, but I think the "user" part of the setting needs an options that is missing, these are my configurations:


    [netuno]
    username=MyPhoneNumber
    type=peer
    secret=UltraSecret
    qualify=no
    port=5060
    nat=never
    host=IP_OF_SIP_PROVIDER
    fromuser=MyPhoneNumber
    dtmfmode=rfc2833
    context=from-internal
    canreinvite=no
    disallow=all
    allow=g729

    register=MyPhoneNumber:UltraSecret@IP_OF_SIP_PROVIDER/MyPhoneNumber

    [MyPhoneNumber]
    username=MyPhoneNumber
    type=user
    secret=UltraSecret
    rtptimeout=30
    qualify=no
    port=5060
    nat=never
    host=MyPublicIP
    dtmfmode=rfc2833
    context=from-sip-external
    canreinvite=no
    authuser=MyPhoneNumber
    disallow=all
    allow=g729

    Note: MyPhoneNumber is set without the leading 0
     
  5. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    Ok,

    If you can receive your phone calls setting the Inbound Routes to "Any DID / Any CallerID", you will need to know what DID are you receiving from your SIP trunk provider.

    The are some providers that doens't pass all DID digits, only the three last of them, or the fourth last of them. To know exactly what you are receiving, Ill suggest you to do the following:

    On the cli, capture the logs of asterisk when you receive a phone call, and then paste that info in here.
     
  6. nachogomez

    Joined:
    Sep 11, 2008
    Messages:
    65
    Likes Received:
    0
    I can only receive calls made to my PSTN (Analog TDM) lines, I still can't receive any calls made to my SIP line :(, even with the "Any DID / Any CallerID" in the Inbound Route
     
  7. nachogomez

    Joined:
    Sep 11, 2008
    Messages:
    65
    Likes Received:
    0
    Well, today was a very productive day working with my Elastix PBX, I've resolve the problem playing the envelope of the voicemail (thanks commandLineUruguay), I have configured successfully the BLF of my GXP-2000 (thanks nano) and now the most problematic thing: "Problem Receiving Calls from VoIP Provider".

    The problem was basically an include in sip.conf (called sip_general_additional.conf) which only allow calls with ulaw or alaw codec, since my provider only accept g729 and doesn't use the user part of the trunk, it wasn't able to receive the incoming call.

    I've just commented the include and pasted its content to sip.conf, made several reloads in order to confirm that the changes stays and now is working perfect!!!

    Thanks to all who post (danardf, jgutierrez, etc).

    Nacho
     
  8. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    Oh, excellent, those are good news ! B)

    Just make sure that it doesn't get overwriiten when you do a "submit" + "Apply changes" on the web interface
     
  9. nachogomez

    Joined:
    Sep 11, 2008
    Messages:
    65
    Likes Received:
    0
    BTW, how can I change this settings via FreePBX??? I cannot find it in the web gui...
     
  10. nachogomez

    Joined:
    Sep 11, 2008
    Messages:
    65
    Likes Received:
    0
    Nevermind, I've just added allow=g729 to sip_general_custom.conf which is fine because this file doesn't get overwrite by FreePBX
     
  11. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    Yep, that is correct
     

Share This Page