Problem on feature code

Discussion in 'General' started by zeonz, Feb 19, 2010.

  1. zeonz

    Joined:
    Jan 27, 2010
    Messages:
    15
    Likes Received:
    0
    Hi,

    I using Elastix the configuration is like this PhoneNet > Elastix > physical analog phone.

    The phoneNet have a feature code *05, but when i press *0 it give me hang up tone.

    I checked Elastix feature code and changed the feature code in order not to crash with the phoneNet but it still give me the hang up tone.

    Anyone can guide me where can i change or disable the "*0" code in Elastix?


    Thank you!
     
  2. zeonz

    Joined:
    Jan 27, 2010
    Messages:
    15
    Likes Received:
    0
    Anyone can help me on this? thank you
     
  3. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    If the local features are no longer a problem, please ensure that your ATA dialstrings allow such a dial pattern.
     
  4. zeonz

    Joined:
    Jan 27, 2010
    Messages:
    15
    Likes Received:
    0
    i tried if use the phoneNet staight i able to use the *0 but when connect to the Elastix the *0 will give me hang up tone.
     
  5. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    https://<ipaddress>/admin/config.php?type=setup&display=featurecodeadmin

    is where you can change/manage (most of) your feature codes
    *0 is by default speed dial, is that what you are trying to do? If so you need to set them with *75 first, did you do that old "Elastix Without Tears" and other due diligence with FreePBX first before posting here?
     
  6. zeonz

    Joined:
    Jan 27, 2010
    Messages:
    15
    Likes Received:
    0
    Hi dicko, yes i did check the "Elastix Without Tears" and i did check the feature code admin and changed the speeddial to some other code to allow me to use "*0" for the phoneNet. Also i add the dial pattern in "Outbound Routes".

    but it still unable to work :(
     
  7. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Then I must ask what do you expect *0 to do in your deployment? If it is not speed dial what will it do?
     
  8. zeonz

    Joined:
    Jan 27, 2010
    Messages:
    15
    Likes Received:
    0
    ok on the phoneNet there is this code "*05<ext/number>" for forwarding. I just wan Elastix bypass the *0 code to let the phoneNet do the work. Other features code i tested and tried able to pass through, only *0 giving me problem.
     
  9. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    All the call forward codes in Elastix are perfectly usable (and probably more functional than your ATA's ability) as *7[2-4] (all) *9[0-2] (busy) and *5[2-3] (no answer)

    If you want to use your local device's "vertical codes" then specifically enable it and specifically disable *05 (normally by regex exclusion for example *0[0-4,6-9] depending on your documentation) in your dialplan, personally I would let Elastix do it though, *72 and listen to the girl, *73 and *74 for the "added value stuff" . Otherwise if your ATA stops working or becomes dysfunctional/disconnected "it just wont work". If you have a "legacy" situation then consider remapping *72 (call forward unconditional) to *05 in Elastix feature codes.
     
  10. zeonz

    Joined:
    Jan 27, 2010
    Messages:
    15
    Likes Received:
    0
    I know what you mean but due to some reason i will need to use the phoneNet feature code that why i trying to make it work haha..
     

Share This Page