Problem moh in inbound route

Discussion in 'General' started by zeno83, Sep 1, 2010.

  1. zeno83

    Joined:
    Dec 4, 2009
    Messages:
    5
    Likes Received:
    0
    Hi, this is the problem
    I insert a moh in a ring group
    If I call the ring group from extension the moh is started and running
    If insert on a inbound route with the ring groups and call moh, the moh is started and not running
    Parent logs but I see that moh is started.

    Someone tell me would know what could be the problem? :( :(

    Sorry for my English
     
  2. mgaron

    Joined:
    Jun 29, 2010
    Messages:
    23
    Likes Received:
    0
    whats the format of the files used mp3 or wav?
     
  3. zeno83

    Joined:
    Dec 4, 2009
    Messages:
    5
    Likes Received:
    0
    wav
    format file 16bit 8000Hz
    Convert with sox example.wav -r 8000 -c 1 -s -w example2.wav
     
  4. dingoland

    Joined:
    Jan 16, 2008
    Messages:
    220
    Likes Received:
    0
    Hi,

    You have to change the default class then edit your musiconhold_additional.conf and change these lines :
    [default]
    mode=files
    directory=/var/lib/asterisk/mohmp3/yourfolder/ <---- add your moh folder at the end.

    Regards
    Greg
     
  5. zeno83

    Joined:
    Dec 4, 2009
    Messages:
    5
    Likes Received:
    0
    I found the problem, Elastix is not, in fact if I make a SIP trunk to an operator works, my problem and now when I receive calls with this configuration
    bri-> patton 4554 -> Elastix

    I do not know the cause of the problem?
     

Share This Page