Problem installing DNSMASQ

Discussion in 'General' started by limeburner, Aug 26, 2010.

  1. limeburner

    Joined:
    Jan 4, 2009
    Messages:
    10
    Likes Received:
    0
    Hi, We are using Elastix 1.4-4 & trying to install DNSMASQ but getting the below error, not being a Linux guru I don't know how to get around the problem with yum looking for a file that does not exist, any help appreciated.


    yum install dnsmasq
    Loading "fastestmirror" plugin
    Loading mirror speeds from cached hostfile
    * base: mirror.optus.net
    * updates: mirror.optus.net
    * addons: mirror.optus.net
    * elastix: repo.elastix.org
    * extras: mirror.optus.net
    http://repo.elastix.org/centos/5/update ... repomd.xml: [Errno 14] HTTP Error 404: Not Found
    Trying other mirror.
    Error: Cannot retrieve repository metadata (repomd.xml) for repository: elastix. Please verify its path and try again

    thanks
    Matt
     
  2. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    dnsmasq is not available in that repository, and the elastix repos are apparently not available for you right now, try it again with

    yum install dnsmasq --disablerepo=elastix*

    if that doesn't work check your DNS resolution

    (hmmm . . . (I re-read, that repo just doesn't exist), are you sure you haven't been playing with your elastix.repo file? ;) )
     
  3. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    Elastix 1.4-4??
    I don't think that version even existed. I think we passed from 1.3 to 1.5, but I'm not positive.
     
  4. limeburner

    Joined:
    Jan 4, 2009
    Messages:
    10
    Likes Received:
    0
  5. limeburner

    Joined:
    Jan 4, 2009
    Messages:
    10
    Likes Received:
    0
    Thanks Dicko, that worked, and I wouldn't have a clue how to change the elastix.repo file. As we are using a non-released version what would be the best way to get a more stable version of Elastix as we seem to run into a few of these strange anomalies with?
     
  6. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    I meant 1.4 never got stable. You have it in production?? What a brave man! ;)

    Anyway, if it works, don't touch it, and if it doesn't maybe it is time to reinstall your box with version 1.6.
    I wouldn't suggest you to put Elastix 2 right now, in my opinion it's not ready yet.
     

Share This Page