Problem after 24 or 48 hours

Discussion in 'General' started by enzofjh, Feb 4, 2010.

  1. enzofjh

    Joined:
    Feb 3, 2010
    Messages:
    1
    Likes Received:
    0
    Hi there,

    I'm having problems with my Elastix box (Version 1.5.2-2). Its config is the following:

    - Dell PowerEdge T410, 3GB, 1000 Mb ethernet
    - 1 x Digium TE121 (E1) (Span # 1: WCT1/0 "Wildcard TE121 Card 0" (MASTER) HDB3/CCS)

    It has 50 extensions configured with their voicemail (up to 30 online phones). Also it has some DIDs. It's nothing out of this world... very simple.

    The problem occurs after 24 or 48 hours, at the moment everything works fine but then asterisk crashes or all services stops responding. I don't know what really is happening. The current solution is restarting the server completely.

    I noticed that RAM usage grows either if there are calls or not or any activity (even if there is nobody at the office). Please note the attached image.

    My questions are: Where do I need to start looking??? What logs can I check in order to know what is causing the event?? Why asterisk is consuming the memory as the image shows??

    Thanks in advance,
    Regards [​IMG]
     
  2. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    You have a "memory leak" could be hardware or added software, please search these forums and other "well known" resources for possible matches to your particular setup and possible diagnoses.

    good luck, These sort of problems can be quite intractable.

    dicko
     
  3. ashir24

    Joined:
    Sep 1, 2009
    Messages:
    75
    Likes Received:
    0
    Type "top" in your linux console. you can find out which application is eating ur memory.
    i had similar problem once when i created a iax trunk for fax and pointed to a wrong channel. asterisk was trying to connect this trunk every second and created the similar issue. try this.
    gud luck.
     

Share This Page